Kodi Community Forum

Full Version: [SOLVED] kodi keeps looking for deleted files
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
When I start kodi from a terminal, I get spam with error like
libnfs error: NFS: Lookup of /Down/holiday_video.mkv failed with NFS3ERR_NOENT(-2)
the specified file are indeed deleted, and they don't seem to be in my library.

Why kodi still looking for those files ?

I'm using a mysql database, which may or may not be the source of the problem.
Either issue a clean library command Settings/Videos#Library (wiki) or use Texture_Cache_Maintenance_utility (wiki) to cleanup old entries from your databases and prune old invalid entries.
I did a clean library and it has no effect
As for the Texture_Cache_Maintenance_utility, I tried the aclean, vclean and prune (-P) actions, but once again, it has no effect.

Am I doing something wrong ?
A debug log (wiki) is probably needed.
In any case NFS3ERR_NOENT(-2) indicates lack of proper permission server side, you could recheck that your NFS server has set insecure on the share export in question.

A Debug Log will show what the state of the general setup is. I suspect this isnt the only issue there.
I think my export is correct : /Data 192.168.0.0/24(rw,insecure,all_squash)
I see nothing in the debug log
while there is plenty of things in the terminal output
Terminal output to what commands?

In any case look at 165347 (thread)
the command "kodi"
Well dont worry about that then, as the other thread mentions, doesnt seem to be an issue.

The databases store paths for everything and their mothers and the garbage collection in Kodi is just not even ideal.
ok thank you
(2015-08-25, 15:55)uNiversal Wrote: [ -> ]In any case NFS3ERR_NOENT(-2) indicates lack of proper permission server side

Just pointing out that this comment is wrong. NOENT is "No Entry" - means "File or folder does not exist". Permission errors are signaled by NFS3ERR_ACCES(-13).
Thx, yes I realized after the fact that this was just that.