Kodi Community Forum

Full Version: Tv-show episodes disappears after problem with drive mounting.
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello I have problem with Kodi and I don't know if it is general Kodi bug or something with my OS or Kodi port.

Sometimes after system crash, default mountpoint (/media/odroid/Elements) is not deleted and during next boot my drive is mounted with different path(/media/odroid/Elements2). It is a rare situation but it is breaking my tv-shows library. When I run kodi, I see all tv-shows with (un)watched indicators and episodes counter, but containers are empty. I can run episodes via File menu (tv-shows posters are visible), but no (un)watched indicators are there. When I run library rescan all episodes return, but are marked as unwatched.

Movies work without any problem.

HW: Odroid-C1
System: lubuntu
Kodi version: 15.1
Skin: Xperience
Library Addons: Watchdog

Thanks for any help and best regards,
M.
not kodis fault. You have to ensure your library is available at the location specified in your sources.
You should probably add some udev rules to make sure the drive is always mounted at the same mountpoint or do it in /etc/fstab
Thanks for advice, but it happens when my drive is mounted wrong (no content at all) and after that I fix mountpoint to my default (movies, backup, tv-tunes available and no episodes in tv-shows). After I restored backup all episodes are again available with valid (un)watched markers. It is possible that the database is cleaned automatically when tv-shows episodes are not available or maybe some third-party apps?
the DB is never cleaned automatically, but it might be possible that some addon or even remote system triggers it.
Library Addons: Watchdog

Remove it or disable it.