Kodi Community Forum

Full Version: OSX 10.11 el capitan: impossible to use airplay device as audio output with Kodi
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello,
since I installed Mac OSX 10.11 El Capitan, it's no longer possible for me to use airplay device for audio output, configuring it from Kodi's system audio settings.
My airplay system is an airport express.
With Yosemite, I had this setting:
OSX's system preferences -> sound settings -> audio output -> built-in speakers as default system audio output.
Kodi: system -> settings -> system -> audio output device -> Rocco airplay (the name of my airplay device).
It perfectly worked; I had to set general system's output device on built-in speakers because I am totally blind and use Kodi screen reader add-on, and if I let default audio output to the airplay, Kodi screen reader's voice comes from airplay speakers, causing a terrible latency while performing commands. While with my setting, screen reader was talking from macbook's speakers, while music, TV/radio audio, and Kodi sounds came from airplay. It was perfect.
But now, with El Capitan, something goes wrong:
Kodi seemed to reproduce nothing, from airplay; I checked system - output device settings from Kodi itself and Rocco -airplay device- seemed to have disappeared completely.
I tried to reset the airport express base, to check if there was a new firmware from the Airport utility on OSX, no update was there, and I rebooted the base to be sure it worked.
So, I did a double-check:
I went to OSX's sound preferences -without kodi- and set Rocco airplay as default system audio device.
And, that worked; music started to come from big speakers connected to airport express but Kodi screen reader itself, of course came also from there.
I said: OK, let's go back, airplay works, let's bring screen reader back from where it must go; OSX preferences, sounds, output, default sound output set to internal speaker. Now screen reader has came back with its normal behaviour without latency; but... no music!
I went again into kodi interface, settings, system, audio output...
And instead of "Rocco airplay selected", my screen reader told me
AirplayNullEndpointAudioDataSource airplay selected!
With result that no music came... so I was forced to select Kodi to reproduce also audio from internal speakers if I wanted screen reader to talk from there.
Now I am forced to a choice: set airplay to system default soundcard, or don't use it any longer.
I have looked for on Google about this AirplayNullEndpointAudioDataSource string, and found out some threads on apple developers forum, but as far as I could read, it affects all third party apps for airplay and i have no ability to understand if it's an airplay bug, or Apple has changed airplay's interface for third party apps and it's just a matter of time for developers to update code and then release newly supported versions.
Please let me know!
Thanks in advance.
this whole behavior you are used to is 100% in the hand of osx. Ther is nothing we can do about in Kodi. We get the audio devices presented from the operating system and osx decides where audio is routed to when a "default" device is set. Apple changed and broke a lot with ios9 and el capitan when it comes to airplay...
Hi, the fact is I do not understand right now if this of wrong airplay detection by third party apps, is a bug, or it's just that Apple now prevents third party apps from using airplay as default output audio, allowing just to use it as system default by OSX preferences to make it work.
Hello,
update on my issues about Kodi and airplay:
on OSX 10.11.0 on the macbook air, updating to Kodi 15.2 RC3 didn't change a thing.
But on my macbook pro, updated to 10.11.1 developer preview because of my job's matters, something changed a bit, even if it still does not properly work:
Basic setting: OSX default sound card is built-in internal speakers.
Open kodi, go to system - system - audio output - audio device
Airplay seems not to be present in the list of available audio devices.
I set airplay as default on OSX's preferences, then set to built-in speakers again immediately.
After having set OSX's default sound output to built-in speaker again, I go back to Kodi and set Kodi's audio device; this time, Airplay appears there, properly: with its name, Rocco, and not with that awful "AirplayNullEndpointAudioDataSource"
The trouble is that when Airplay is set correctly in Kodi, output coming from Kodi screen reader text-to-speech add-on, comes from airplay device too, even if OSX's audio is set to internal speakers; while in Yosemite it correctly worked:
- screen reader's output came from default OSX's soundcard (built-in speakers)
- music and TV's audio came from airplay (Kodi's output device settings)
I am afraid that right now the good solution should be to see if Kodi screen reader's dev may adjust screen reader's behaviour
Its out of the addon developers hand and also out of our hand. As said - the behavior you are used to is totally in control of osx and might have even been a bug that apple fixed now. If you select an audio device in kodi - all audio will come out to this device. If you want dynamic behavior your only choice is to select the "default" device in Kodi. If you then for example plugin a headphone then the whole kodi audio will be switched from internal speakers to headphone. This magic happens automagically and is done by osx itself - not by kodi. So whatever happend before which pleases your use case doesn't happen anymore (as said - because osx changed).