Kodi Community Forum

Full Version: Live TV and Recordings won't play over network.
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi all,

I recently built a PC to stream live TV from an antenna, and it's been a bit of a struggle. After trying a frustratingly long assortment of front and back end programs (Emby, NPVR, MediaPortal, and probably a few others), I landed on Argus TV + Kodi (which was somewhat convenient, as I'd used Kodi/XBMC for other things in the past). On the host PC, everything works as it should. Argus's consoles are functional, Kodi recognizes the streams, plays and records, no problems.

However, on all of my network clients (Macbook Pro, Nexus 6, Nexus Player), I can't get anything from Argus TV to play, live TV or recordings. On all devices, the plug-in accepts my log in information, it recognizes the channel lists, finds the schedule recordings and the episode guide, etc. Everything appears to be in good order until I try and start streaming a channel. When I select a channel (or recorded show), it first says "Working" in the lower right corner, then says "Buffering, 0%..." in the upper right corner. Then... nothing else. The streams never start, or even show any sign that they actually attempted to load.

Some googling has suggested common problems might be sharing problems/permissions or network problems. I've double checked all the sharing settings (and also put in the administrator credentials to the Argus TV plugin config on all Kodi clients), and have also verified that my network has no trouble streaming from my NAS (Kodi can also stream from this NAS).

Any ideas on what I can try? It's very frustrating to see it work perfectly on the host computer, but to have none of the network clients work.

Thanks in advance, and please let me know if there's additional information I need to provide.
In the Argus Recorder Console, have you set the Record/Timeshift paths as local or UNC?
Is there a setting to select one or the other? Before there was one local path and one network path, I changed them to the same network paths but there was no change.

I'm not able to edit the UNC path, or else I would have tried using an IP address.

I also double-checked sharing, and am able to read both of those folders through a file browser on my Nexus 6, so they do appear to be shared properly.

Image
Your shares look correct to me and the fact you can access them through a file browser means it sounds right. Couple of things:

- I assume you're pointing at NORMANDY as the server and not localhost (I'm sure you are, just covering all bases)
- Have you tried turning off the firewall on the server and seeing if it works
- When you attempt to tune a channel, does a timeshift file appear in the "ARGUS TV Timeshift" folder?
- Have you tried paths without spaces - not sure if this would be an issue for any of your clients
- Could you try tuning a channel and then share the appropriate lines from the Kodi & Argus logs?

I remember I had many problems when I first started trying to set up Argus but I still think it's worth it. Best scheduling abilities around IMHO.
The clients are definitely pointing to the correct server (and locating the EPG information on it, as well as the channel grouping). I just checked without the firewall on, and got the same result.

Channel tuning on clients does produce three files (.ts2).

I haven't tried a path without spaces, but I do know that none of the clients have issues parsing spaced paths.

I just created some logs for both programs. They're unfortunately large (I think I let it sit a little too long while it kept trying to connect), but they seem to repeat over and over again after awhile, so I think all the diagnostic pieces can be found pretty early.

Kodi: http://goo.gl/IGN0gl (some warnings start around line 335, Argus errors start around 486.
Argus: http://pastebin.com/tGQsUb5i

It looks like there is definitely something going wrong on the Kodi end, but I'm not well-versed enough to figure out what that is.
Sorry, not being much help!

Looking through your logs, quite a few people have suggested adding the source of live tv/recordings to the file manager (via SMB) in Kodi and saving the credentials. I know you can access via file manager but still worth a try.
Can you copy files to your devices from your Argus server and play them locally in Kodi?
Did you try to disable HW acceleration in Kodi?

I experienced the same problems with HD files in Kodi that were streamed from my Mediaportal server. I found out that it is not related to Mediaportal but that Kodi's internal player does not work with HW acceleration on my Acer Iconia Tab...

In my case it works with external players (mxplayer, vlc) but unfortunately that does not work for PVR streams because the external players cannot translate Kodi's "pvr://" url into something like "rtsp://".
I had exactly this problem on a Google Nexus 7, I managed to fix it, but then for various unconnected reasons the Nexus lost all its settings and I had to start all over again. Now I cannot fully remember how I fixed it in the first place!

The following may help, though.

I found a post somewhere which indicated that I needed to add the share I was playing from on the source machine into the Kodi System >> File Manager as well. I did this and it then all worked. Unfortunately the details (and the post) escape me, but I assume I must have added //machine/Argus TV. Whatever it was, it completely solved it, so I can only suggest you try something in that area.
Had the same issue also. Guide would show and once channel was selected it would just buffer at 0%. This worked for me. I mapped the share folders for Record and Timeshift on main PC set Argus TV to point to these folders as usual. Your setup seems to be correct for that part. I then went to the public video folder and made sure it was set to share with everyone with read/write. Now back to kodi on cleint PC, I had to go to video, add files, windows SMB and once credentials were entered added Public video folder with TV Show as scraper (not sure if this need) then the 0% buffering issues were resolved.