Kodi Community Forum

Full Version: read - error (-5, nfs_service failed)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Hi there,

Just wondering if someone can shed any light on this error message and exactly what it means and how to troubleshoot it?
(I am getting it on an OpenElec install but I think it's a Kodi error message - can anyone confirm that?)

Context:
- My setup consists of a Synology NAS using NFS shares that are accessed by a chromebox running openelec, along with a windows PC, android tablet and ipad all running the latest official Kodi Builds with standard skins and the base addons.
- I've been using this setup with no problems for about a year. The last update to the synology firmware/DSM was more than a month ago and there have been no changes to my router, cabling setup or file sharing settings on any of my devices.
- Last night all of a sudden the chromebox (openelec) drops whatever video it's playing after almost exactly 8 minutes and throws the above error message a bunch of times before dropping back to the GUI.
- Until the next reboot it can't access anything on that specific share but it can access things on other shares (where it then throws the same error after another 8 minutes of video playing).
- When it throws the error, I can still access and control kodi on the chromebox itself using Yatse, putty or windows explorer (via the SMB share)... it literally just drops the NFS share it was accessing and nothing else.

Troubleshooting:
1. I have confirmed that the other devices (win 7, ipad, android tablet) can all still access and play files from the Synology shares with no issues.
2. I tried the same files from ipad, windows & android (more than 20 different files tested) - all fine so not an issue with a specific file or folder.
3. I don't know what I was trying to rule out but I also queued up a 30minute youtube video on the chromebox... which played all the way through so I guess not a networking or rendering/hardware error?
4. I ruled out cabling issues by replacing the relevant patch leads and also by swapping the chromebox to wireless instead of wired... same errors.
5. At that point I assumed it was an issue with the chromebox and I swapped from NFS to SMB... it still drops the video, just with a different error message "read - error (-1, 22, invalid argument)"
6. I setup an SMB share on my windows 7 machine and accessed that from the chromebox - videos played all the way through without problems.
7. I completely purged my Kodi USERDATA files to make sure it wasn't anything in there that had corrupted... I then setup an entirely new NFS share on the synology with a single video in it... same issue.

Conclusion:
I am totally lost and don't know how to resolve the issue... I know the Synology must be partially responsible (given 5 & 6 above) but those same shares work fine from 3 other different devices so all I can think of is that something in the chromebox has gone corrupt and is now clashing with something in the synology. If that's the case I don't know how it started or how to resolve it. If anyone can offer any advice, suggestions or guidance I would be extremely grateful.

Edit:
I have added a debug log to post #2


Cheers,

TC
Update:
I decided I didn't have anything to lose so I updated OpenElec to the most recent BETA build, cleared all the databases and configs and started again.
I was able to successfully play a video from my existing NFS share without a crash.
However when I tried a second video, it crashed and now the error is back.

Here is my Debug Log:
http://pastebin.com/WULGSu3K

I started the video at 18:16pm.
It didn't crash in 8-10 minutes as expected... I believe because I had SSH'd into the chromebox and was regularly sending my logs to pastebin... I think I was effectively creating a manual keep alive.
8-10 minutes after I closed the putty SSH connection I got the same NFS crash so it's feeling more and more like a Kodi/OpenElec issue.

Any assistance or advice would be greatly appreciated.
Probably not a solution but did you check the nfs settings from your share ? Some permission settings changed since DSM 5.1
http://kodi.wiki/view/NFS#NFS_sharing_fr...gy_or_QNAP -> 7.2.1.1 Synology DSM 5.1
Thanks for the suggestion Walt74 but unfortunately my NFS settings are exactly as per those guidelines.
I even set up a brand new share today using those exact settings... same error appears.

Edit:
Also tried squashing to root and adding the specific IP of my chromebox as an admin for the NFS shares.
Then tried manually editing /etc/exports.. my NFS shares had both ".insecure" and ".insecure_locks" entries so I deleted the ".insecure_locks" entry only as per the Wiki (even though I am on a more recent version of DSM and this shouldn't be an issue). None of this resolved the issue.
And if you play the same files though vlc ? Do they play further or does the same problem occur ?
Thanks but I have ruled out any issues with the files themselves.
They played fine on the chromebox previously and still play fine on my other 3 Kodi clients (win 7, ipad, android) + VLC in win 7.
I have also downloaded a new fresh file on my PC, then manually placed it in the NFS share and played it immediately to confirm the Synology is not somehow corrupting every file on the NAS.

I'm convinced it's either an error in the Synology NFS that only appears on the Chromebox, or an error on the Chromebox that only appears with Synology NFS shares - unfortunately I don't know which or how to troubleshoot further.
So I realise I'm just talking to myself but I'll keep posting in case anyone out there enjoys a challenge and wants to help me, or in case someone has a similar problem in the future.

Troubleshooting Update:
I just turned on DLNA sharing in Kodi on the chromebox and connected to it via wireless from my Sony Bravia TV using the built in software (non android / not Kodi) and was subsequently able to play any file I queued up.
I went through 3 full 45 minute files without any errors. The Kodi logs shows clearly that the NFS connections to my Synology NAS are being opened without a problem and the content is being served to the TV via the chromebox in whatever magical way that works... there were no errors for any of the files and my issue did not reproduce so I have not updated my logs.

Edit:
When I went back a few hours later and tried this same trick (Bravia via DLNA) the files stop playing after a few minutes and I have the same -5 NFS error in my kodi Logs
You mentioned its both on NFS and SMB, other devices are okay, so we can rule out the NAS. Its hardly unlikely you have a hardware malfunction on the ethernet and wifi at once.

from your log:
18:39:27 T:140066613196544 ERROR: ffmpeg[7F63CCB97700]: [mov,mp4,m4a,3gp,3g2,mj2] stream 1, offset 0x9375925: partial file
18:39:27 T:140066613196544 ERROR: Read - Error( -5, nfs_service failed )

Could you try to play an mkv file does it play, responds different ?

I am starting to guess it must be something in the Openelec build you are using. Could you try a newer or older build version ?
Thanks Walt,

I did try alternate file formats including MKV & divX Avi during my troubleshooting to rule out a specific file issue and they still crashed but I wasn't capturing logs at that point so not sure of the errors.
Irrespective of that however the MP4 files work fine from other devices but more importantly, via the chromebox from a windows SMB share so I consider the type of container to be unlikely as the culprit.
I will go and run an MKV now and see what the error is then update this post accordingly.

After the troubleshooting measures in my first post, I upgraded to the latest OE beta and the issue was still present.
Before updating and before this issue, I had been running the standard stable OE build for months without a hitch and I do not tweak or change my setup... I consider it to be pretty vanilla other than a couple of REGEX's in my advancesettings to deal with how I name files... my wife and kids use it so I don't like to tinker with it.

My next step will be a wipe and re-install on the chromebox and I've asked from some advice in the appropriate forum.
Cheers again for your assistance.
TychoCaine

As we talked in IRC, I would still wait a bit as some (not to say 'most') of the devs are at Kodis Devcon: http://kodi.tv/devcon-2015-liveblog/

I guess, someone will jump in later. Maybe you have to provide logs again, because those pastes are deleted after a couple of days from pastebin. So please be patient. Wink

Greets
David
Hi David,

I didn't know about the Devcon so have my fingers crossed for some advice over the next week or so once the devs have some more free time.
At this point I'm really just putting as much info into the thread as I can to assist anyone who takes a look.
The pastebin link above for my log says that it doesn't expire but I will add another one shortly.

Had another weird experience in my troubleshooting... I set one of the NFS shares to squash to root and started a video playing, then I turned off the TV because I didn't want it to distract my kids.
Turned the TV back on 40 minutes later... video was still playing with no errors and finished playing without crashing.
Started the same video again immediately but left the TV on... 8 minutes later I lose my NFS share with that same error.
At this point I think my chromebox is possessed with a trickster evil spirit.


Edit:
I have reproduced the above situation 4 times now... if I start a video and immediately turn off my TV, the video makes it all the way to the end without a crash, even with me turning the TV on every 15minutes or so to check it's still playing. As soon as I leave the TV on, I get the NFS share dropping after 5-10 minutes.
Does your TV has an inet connection? If yes, could you please disable it and try again? I have a thought, but I might be wrong....so test this please.
Random guess: Have you tried turning off the screensaver in Kodi?

I only say this because the issue doesn't appear when you have the TV off. Hence the random guess.
David - My TV is not connected to the internet.
Jogee - The screensaver in my Kodi install is off.

Since my last post I have completely wiped my chromebox and reinstalled OpenElec and the problem is gone so clearly an OpenElec issue but I still don't know what caused it or how it could have been fixed without a wipe and re-install. I'm sure the problem will come up again in the future and I will just have to wipe and reinstall again.

I appreciate the suggestions and assistance people tried to offer.
Said it wrong....is your TV in your local LAN? Has it an IP?
Pages: 1 2