Kodi Community Forum

Full Version: Using Gamepad on Raspberry Pi2
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
today i have tried to use the Retroplayer Image for the Raspberry Pi2 and get it startet.
For playing games i want to use an Logitech Rumblepad 2 which is detected by kodi and listed on input devices.
But I cant configure any Buttons from the gamepad only the remote from the TV.
How I have to get it work and what i should do?

Thanks for help.
You did find the Settings > Games > Configure input menu?
Yes I did find these settings but by pressing a button on my gamepad nothing happened. Pressing a button on my remote will set these setting.
At the list of input devices is listed the gamepad with the right name but the information of the driver are the same as the Keyboard information (zeros and unknown). If it helps i could post a picture of it when i'll be back at home.

Any ideas?
read this: http://openelec.tv/forum/124-raspberry-p...c-possible

Quote:The RPi doesn't have joystick/SDL support because it doesn't run xorg. There is nothing we can do about this right now.
Hmm ok that isn't a good news.
But what i'am wondering is that i tried to use an image of a german openelec user http://www.kodinerds.net/index.php/Threa...ght-Image/
There it was possible to use the gamepad but i didn't get it configure so it was to dificult in use but it worked.
SDL uses evdev on linux for input, so why would it need xorg (unless the SDL libs themselves have a dependency on xorg on linux)? Neither does the old joystick API for that matter, though not all controllers are supported correctly with that API anymore. An input plugin that used raw evdev like retroarch does would probably get round the issue any how.
So you are saying Bluetooth gamepads that are not mainstream will/can be supported eventually?
Well, I'm not a kodi dev, so I can't say what will be implemented, but if your gamepad has a kernel module that recognises it and generates evdev events, then in theory there is no reason it shouldn't be supportable without xorg and thus supported in OpenElec on the RaspberryPI.
Today I have searching a little bit and found two things out. At first using a gamepad should work. Other plattforms like OSMC are discussing these things too like here https://discourse.osmc.tv/t/controlling-...mepad/2636

The second thing which i am wondering is that it seemed that kodi disides between joystick and gamepad (it gives different keymaps) but the driver for my gamepad is joystick

Could my problem depend on a wrong detection or driver?