Kodi Community Forum

Full Version: Sending Youtube Video to Kodi does not work
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Been struggling to get this to work but am running up against the wall, will try to give as much relavant info as I can

I had an older media player running Kodi 14 on Windows 8.1 and was able to use Kore to control it and also send Youtube video links from my Androind phone Youtube app to Play on Kore without issues. Everything worked great

I have now gotten a new media player running Windows 10, and installed Kodi 15.1 on it. Also got a new phone, and installed Kore on it (and I no longer have the old phone or media player)

Kodi has all the options enabled for webserver, remote control, zeroconf and airplay (without password). Bonjour is installed and running. Youtube addon is installed in Kodi and by itself works fine. Windows firewall is turned off and everything is connected to the same LAN. Windows has no additional anti virus or firewall other than what come standard with Windows. This new media player basically has Windows, iTunes, Git (for skin updates) & Kodi installed on it.

I am also using the Titan skin installed from the official repository (although I cannot see how this would be relevant since I have the same problem using Confluence as well)

Kore latest version from the Play store is installed on the phone (HTC M9 which is running Lollipop stock/unrooted)

Kore sees Kodi, finds it, configures itself, and the remote functions all work. Button presses, sending text etc all work as expected

Youtube addon in Kodi itself works as expected - search, play etc all work. Kore is able to correctly control Kodi while interacting with the Youtube addon (navigation, play, pause, send text etc)

But when watching Youtube videos on the phone, and then doing a "Share - Play on Kodi" through the options, nothing happens.

This is the only thing not working. I have tried everything I can think of to get this to work but no joy.

Im sure its something pretty obvious that I am missing. Any suggestions?
Don't have a clue... You might need to look into Kodi's logs to check if something weird is showing up there.
There is nothing strange in the logs at all.

I am starting to think this is a Kore issue. Using another Android remote (Yatse) sending Youtube video's works as expected, but Kore refuses to do so.

Took another phone (Nexus 5 running marshmallow) and downloaded Kore on that to try and possibly eliminate the phone as the culprit, no joy