Kodi Community Forum

Full Version: SNES controller key mapping
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Gidday all,
I have built kodi-game and the addons and can launch SNES games.... but in my fav. game Worms only the A, select, and start buttons works!
I have played this game in retroarch no problem.
I have pressed 't' and remapped the keys eg A->c B->x X->a Y->z start-> enter select -> shift shoulders to pgup/pgdown
What am I doing wrong.

I have built in two ways:
from git://github.com/kodi-game/xbmc.git as:
./configure --prefix=/usr
sudo make install

and the addons from https://github.com/garbear/xbmc.git as:
<in build dir>
cmake -DADDONS_TO_BUILD="peripheral.joystick game.libretro game.libretro.2048 game.libretro.beetle-bsnes game.libretro.beetle-gba game.libretro.beetle-lynx game.libretro.beetle-ngp game.libretro.beetle-pce-fast game.libretro.beetle-psx game.libretro.bluemsx game.libretro.dosbox game.libretro.fceumm game.libretro.gambatte game.libretro.genplus game.libretro.handy game.libretro.meteor game.libretro.mupen64plus game.libretro.nestopia game.libretro.pcsx-rearmed game.libretro.stella game.libretro.vbam game.libretro.vba-next game.libretro.yabause"  -DCMAKE_BUILD_TYPE=Debug -DCMAKE_INSTALL_PREFIX=/usr/lib/kodi/addons ../project/cmake/addons/
sudo make install
Some addons had errors so not in the list
Also built kodi from the https://github.com/garbear/xbmc.git tree as above... same diff.
The documentation is very confusing when new to this. I am still not sure if this is right... I tried the
make -C tools/depends/target/binary-addons PREFIX=$HOME/kodi ADDONS="game.libretro"
method but this failed (not just that game.libretro had broken dependencies like dosbox... )

Other questions like how do we choose emulator (which SNES emu for example...)

How to get a nice pictographic view of the game collection. I have added a ROMS source, but can only browse as files..

and... how to play Atari ST games (and ultimatly Amiga)

Pretty damn cool how it (almost) just works!!!

cheers team 8)

PS: I am happy to update the docs for n00bs to kodi-game such as myself 8)
This description is so totally unlike my experience mapping a controller that I feel like I need to re-install the retroplayer branch just to see things have changed this dramatically. Are you mapping like is done in the first minute of this video?

edit: Oh, wait, are you talking about mapping a keyboard to work with retroplayer?
natethomas it can be configured as in the vid, all good 8)
but yea you should check it out just to play worms again, forget duck tales 8)

So I found the problem which was the beetle-bsnes emulator. Using the bsnes-mercury emulator the game works fine.
But 'Super Famicom Controller Test Program' showed that all buttons works fine with either emulator.

So to answer my own question, with more than one emu for a platform the emu selection dialogue opens... so nice 8)


I tried to build the emu I use in retroplayer snes9x-next as:
sudo cmake -DADDONS_TO_BUILD="game.libretro.snes9x-next "  -DCMAKE_BUILD_TYPE=Debug -DCMAKE_INSTALL_PREFIX=/usr/lib/kodi/addons ../project/cmake/addons/
(I need sudo as cmake looks like it tries to create folders in /usr... or is this a test for whether we need sudo for install??)
does not build the snes9x-next emu.

The internet archive launcher is amazing! If only it could copy the dloaded img's to a ROM source
Please update any documentation you can on the wiki or here to help other users.