Kodi Community Forum

Full Version: Kore unable to connect to media center.
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
So I added a bunch of links to images to show my configurations and why I'm stumped and maybe a more experienced person can help me with my problem.

So I installed Kore and didn't detect anything, so after not getting the media center to show up I installed iTunes so I could use the ZeroConf setup from via Bonjour. This is what I get now:

http://i.imgur.com/B7DpFkt.png

When I select it, I get sent to the manual configuration window/dialogue. Here:

http://i.imgur.com/pJB3pvl.png

Now, I assumed it was a firewall issue, so I turned off Windows Firewall (I'm on Windows 10 FWIW) and then went to my routers settings:

http://i.imgur.com/2GJrp32.png

I'm not 100% on the effect of port forwarding, especially in this situation, but I imagined it could be an issue so I went ahead and set up port forwarding for any relevant ports here:

http://i.imgur.com/uvK44z1.png

Mind you, they are both TCP ports, and 192.168.0.11 is my host PC, my phone's IP is something else.
So the last thing that I can think of that would be relevant is my Kodi configuration. Here's the screenshots for those.

http://i.imgur.com/tvT5aP7.jpg
http://i.imgur.com/aq7Mven.jpg
http://i.imgur.com/RibnsAp.jpg
http://i.imgur.com/GkjZtyp.jpg

Those are the services - settings I enabled to get Kore up and running, just like the FAQ tells me to.

So what do you guys think? I turned off my software firewall (Windows Firewall), my router/modem's firewall is set to NAT only, but I did try a low security setting allowing ALL the traffic through, and that didn't seem to have an effect either. I've tried port forwarding 9090 and 80 to my host PC, and then tried my phone's IP (it won't let me forward the same ports to separate IP's, probably makes sense to networking guys, not so much to me at the moment). And I've tried just not port forwarding at all. No results from anything. The media center won't show up without Zeroconf turned on, but even then, it takes me right to the manual configuration window in Kore. Thanks for the help and cheers! Sorry for the long post.
Your Kodi settings seem fine, though you might have some other service running on port 80, therefore interfering with Kodi/Kore. Try changing the HTTP port to something else on both Kodi/Kore.

I would remove the port forwarding, it should work without that, and that only confuses the configuration. I'm assuming that your media center and your phone are on the same network, have you tried pinging your phone from your media center?

Zeroconf is optional, but useful. If you don't set it up, you just need to specify your media center's ip manually. You can also use your hostname, if you have a dynamic ip.
I love easy fixes like this! Thank you so much! it was port 80 that was the problem, I changed it to 81 and I'm now set and ready to go. Thank you again!
Would be cool if Karlson or someone check http://trac.kodi.tv/ticket/16187 as Windows 10 is spreading and the problem is very common and no error to users.