Kodi Community Forum

Full Version: Xbox One controller support
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
First, I just wanted to thank everyone involved in such a massive project.

I was curious if there was already support for wired xbox one controller, soon to be wireless. I just can't seem to get my controller to respond to any commands inside the latest build of Kodi-RetroPlayer. Also, in the latest version of just Kodi the controller responds but goes right constantly. I would really appreciate if anyone was able to help me out.

EDIT*

I was able to get the controller working properly inside standard Kodi by installing a older version of the driver. This however still did not fix the problem in Kodi-RetroPlayer.
Can you post a debug log?
I have the same issue with my X-Box One Wired controller. I can't even play Rom Collection Browser with it.
As garbear already mentioned please post a debug log.
Also dmesg output may help.
Thank you.
A bit late to the thread, I know, but I've also had this same issue, so I've gone ahead and uploaded a debug log in the hopes that this can be looked at again.

Hopefully I did it properly, I've never tried it before. Here's the link: http://xbmclogs.com/phwjvxatz

Thanks, hope this helps.
It looks like you're using the 16 beta 5 build from our downloads section. Can you give my latest RetroPlayer build (based on 15.2 for now) a try, and post a log from that if it still doesn't work? I have completely re-written controller support, and Xbox One should work out of the box now.

If you can't try a RetroPlayer build, I noticed this in your log file:

Code:
13:47:48 T:8156  NOTICE: CJoystick::EnumJoysticksCallback : Enabled Joystick: Controller (Xbox One For Windows)
13:47:48 T:8156  NOTICE: CJoystick::EnumJoysticksCallback : Total Axis: 6 Total Hats: 1 Total Buttons: 11

You can try adding the string "Controller (Xbox One For Windows)" to the windows family of controllers in the joystick.Microsoft.Xbox.360.Controller.xml keymap file like this. The new controller input will be merged in v17, so this should hold you over until we start releasing betas for that.
Heh, forgot this was the RetroPlayer section, actually.

So after trying it, it does work in that build, so that's good to know.

I also checked that keymap file (in the 16b5 install) and that string was already there (line 155). But it's fine for me that it doesn't work now if it'll be merged from the RetroPlayer build later.

Thanks for the help, it's appreciated!
Yeah, I was pushing to get One support in 16, but the work required would have been quite a lot and likely would have been considered either a feature or might have broken other stuff. And given that 17 is likely to have an entirely new input system, it ultimately seemed not worth it.
FYI; several pull requests been submitted for Linux kernel 4.5 with changes to improve the XPad driver to better handle Xbox One controllers including adding Force Feedback (rumble) support, read:

http://www.phoronix.com/scan.php?page=ne...-Linux-4.5

More details via this pull request:

http://lkml.iu.edu/hypermail/linux/kerne...04543.html

XPad is the Linux USB input driver for Xbox compatible gamepad controllers, and this pull request for the Linux 4.5 kernel also include other improvements like more rubust support for the Xbox 360 Wireless Controller.

https://www.kernel.org/doc/Documentation/input/xpad.txt