Kodi Community Forum

Full Version: music add-ons will not open/launch
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Hi there guys, l have a very strange issue going on with my Kodi install. I'm running the latest 15.2 build. I am using a stock Aeon Nox 5 skin.

Here's what's happening, if l go into my music add-ons section and try to launch any of my plugins (other than Pandora) nothing happens. I get no warning, no notice nothing.
I've also checked the log file and there is nothing in there before or after clicking. Though l've uploaded a copy of it here for you: http://pastebin.com/HnysUYtu

Here's what's really weird tho, if l go to settings > add-ons > music add-ons l can launch the add-ons from there just fine. So l'm not really sure what's going on.
I have also noticed that when in the music add-ons page, if l right-click on any of the plugins it says "play" but there is no "launch" option. Does anyone have any suggestions as to what might be causing this issue?
Does anyone have any suggestions on anything l could try? I can't seem to find any info on google about this?
It seems like all the add-ons (other than Pandora) in my music add-ons list try to "play" instead of "launch" the add-ons.

Any help would be greatly appreciated.

Thanks,
I have the same problem as you. It stopped working last night and only my music add-ons section. Nothing in music add-ons wants to open. I can open stuff like, super favourites plugin, in the video-adds section but it won't open in the music add-ons section, very strange.
I figured out a way to fix it, l switched my theme back to confluence clicked into music add-ons and ran a music addon, then switched my theme back to aeon nox 5. Now the music add-ons work. So there must be something that gets messed up when doing configs with aeon nox.
(2015-12-17, 20:35)Burns263 Wrote: [ -> ]I have the same problem as you. It stopped working last night and only my music add-ons section. Nothing in music add-ons wants to open. I can open stuff like, super favourites plugin, in the video-adds section but it won't open in the music add-ons section, very strange.

Be careful saying anything about the add-on you mentioned above, l had my thread marked as spam and my account suspended for saying that here on the forum. To say the mods are a little over the top and quick to ban/kill is a drastic understatement.
(2015-12-17, 21:43)kimechos Wrote: [ -> ]I figured out a way to fix it, l switched my theme back to confluence clicked into music add-ons and ran a music addon, then switched my theme back to aeon nox 5. Now the music add-ons work. So there must be something that gets messed up when doing configs with aeon nox.

I had exactly the same problem - neither of music add-ons would launch, no error message. I tried Your solution (switching to confluence) and it works now. However, when switching back to Unity or Bello skins the problem remains the same. So, for me, the only skin that works is confluence at the moment.
I am also having the same issue. Music addons worked in Confluence. However, music addons do not work in Aeon Nox. This has been going on for about 2 days. I just went back to Confluence to run some music and try the fix kimechos suggested. Now I'm seeing Conflence music addons don't work either.

I have cleared the cache and re started the program in both builds. Nothing.
I am also facing the same issue as everyone else Sad

All music addons work fine in Confluence but refuse to work in Aeon Nox. The addons will load the list within the addon but will not let me select any of the folders/categories shown Sad

I have also cleared cache, purged packages and cleared thumbnails.

Has anyone come across a solution other than resorting back to Confluence for good?
all of you: please post a Debug Log
I'll post a log tomorrow, but I've got the same issue.

Got a Fire TV for Christmas, did the install, everything works fine, except when I switched the skin to Mimic or Aeon Nox, some of the music addons (Songza and Google Music EXP) won't respond. No error message, no "working", nothing. Pandora and Pandoki work fine though. When I switch back to Confluence they worked fine.

I tried to switch to Mimic again this afternoon, and same issue, except now Songza and Google Music won't work even after I switched back to the default skin.
I think it is an Aeon Nox problem. I am using a fire 7" tablet. I completely wiped the tablet and started from the beginning. After downloading Kodi, I changed skin to Aeon Nox. I ONLY installed 4 music addons. Initially it worked. Then it tried to find a link while trying to play a world music addon. After it stopped, no other music addon would work in Aeon Nox. I went back to Confluence and all links worked just fine.

To ronie: I'm not sure how to post a debug log, hopefully someone else can.
(2015-12-28, 20:17)saigeminus Wrote: [ -> ]To ronie: I'm not sure how to post a debug log, hopefully someone else can.

it's explained in the link: Debug Log
I was able to replicate this on my Mac as well

Here's my log.
- I start in Confluence and go to the NPR app. I can select a state and a station - working normally
- I switch skin to Aeon Nox and head back to NPR - no joy
- Switch to Amber skin - NPR works again
- Switch to Mimic - nuthin'

I'm getting the same behavior from my Amazon FTV setup as well.
i think the issue is happening on skins using the skinshortcuts addon.
it causes addons to be opened in the musiclibrary window instead of musicsongs window.
this won't work in case you don't have a music library.

you should report the issue here: http://forum.kodi.tv/showthread.php?tid=178294
In the most recent version of Skin Shortcuts we switched form using MusicFiles (what I presume you mean by MusicSongs Wink) - aka window 10501 - to MusicLibrary - aka window 10502 - as reports were that these shortcuts weren't working. (Bug report, PR)

But please do come over to the thread Ronie linked to and (re)post your debug logs. Be aware, though, that finding the right solution might not be as simple as switching the window the shortcuts are launching from (and I'm assuming we're talking about music add-ons not working from main menu shortcuts here...), and we may need some help in finding the correct solution for everyone Smile
Pages: 1 2