Kodi Community Forum

Full Version: [SOLVED]Missing Stereo audio track on old movies
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello. On my Intel NUC PC I've installed Lubuntu 15.10 and Kodi following this guide
247152 (thread)
I've a NAD T747 A/V receiver.
Because I want to use the NUC + Kodi to watch movies using HDMI output of the NUC, but also to listen music using audio from USB port of the NUC with my external DAC HRT Music Streamer II+, I've set the Audio Output settings on Kodi like this:

Main audio output: HRT Music Streamer (choosed from the list that Kodi shows)
Audio Passthrough: On
Audio passthrough output: HDMI on NAD T747 (choosed from the list that Kodi shows)

Now, music is correctly played by the DAC, multichannel audio movies are correctly played by the HDMI output, but when I play old movie files with standard audio track, I haven't any audio output

In a prevoius installation on the same PC NUC, I was using Kodibuntu, and I haven't this problem, but the system was very unstable so I had changed following suggestions in this forum..

Maybe the problem can be that I've removed Pulseaudio from Lubuntu as suggested in the guide?
Other ideas?
Many thanks to all.
Hello, I add this comment following other test. I've try using Openelec installed in a USB stick and the problem still the same. Probably it was the same with Kodibuntu but I haven't noticed it (I've used it only for few days).
I think I've identify the problem: when the main audio output is setting different from HDMI (in my case is setting to the external DAC via USB), to listen movies multichannel audio tracks it's necessary to activate the passthrough function, and set the passthrough output to the HDMI output of the PC, as I've done. But, with this setting, the standard stereo audio tracks of old movies are not passed through the HDMI, and only the multichannel audio tracks are passed.
In other words, it seems that the stereo audio tracks from movies doesen't work with passthrough function.
To have stereo audio tracks that works you have two setting possibilities:
-change the main outoput and set it to HDMI output, avoiding the passthrough (but in this case I can't use the external DAC for listen music)
-keep the main stereo output to the external DAC via USB, keep the passthrough function on to the HDMI output, and set the Stereo Upmix function to On (but in this case, when I listen 2 ch music, nothing come out from the external DAC until I set the Stereo Upmix to Off).
I don't know if there are other setting I can work on...For the moment, I can't have just one setting that work for all, and It's a very big limit of the system for me. It is not very usable if I have to change settings any time I've listen music or watching an old movie.
Considering that with my very old 4Geek EVO TVBox I haven't this problem (I used HDMI output for any kind of movie audio tracks without any setting, and the analog stereo output for music) I'm a bit disconsolate...
Other ideas?
Many thanks to all
No Debug Log no issue - please don't write walls of text, but clearly pointing out the issue.
(2015-12-25, 09:35)fritsch Wrote: [ -> ]No Debug Log no issue - please don't write walls of text, but clearly pointing out the issue.

Hello Fritsch sorry but because my particular needs and the several settings involved, I can't explain it with less words... anyway I've tryed to to create Debug Log, but I'm not expert. I don't know if I well done everything. Find here the kodi.log file
http://pastebin.com/u2t5qJpY
many thanks in advance
You at least need to play the title that has the issue - otherwise nothing will be in the log
Sorry Fritsch, I've played a title during debug... maybe it's too complicate for me all this...anyway the problem is not with one specific title, the problem is with all my titles with stereo audio track. As wrote above, it seems that, using passthrough activated on the HDMI output of the NUC, the stereo audio track of movies doesn't pass, or, better, it passes only setting Stereo Upmix to On in the general settings. But, with this settings, I loose the possibility to listen 2 ch music from the external DAC. I've to change settings everytime.
Other related issue is that, during playback of a movie with stereo audio track, when I click on the audio speaker icon on the bottom right of the screen, if I activate the Stereo Upmix in this menu, it doesn't works. I have to go to System/settings/System/Audio Output, then, setting On the Stereo Upmix in this menu, it works.
Hope to been able to explain me clearly enough...
There is still a Debug Log needed. It's not that we don't believe you, but we can't help without that.

So play a file and then upload the log
(2015-12-25, 21:48)David1977 Wrote: [ -> ]There is still a Debug Log needed. It's not that we don't believe you, but we can't help without that.

So play a file and then upload the log

Hello David, no doubt that you believe me..Wink I've done the debug procedure another time right now. I've played a tile named "Le vacanze del piccolo Nicolas", but the Kodi Log Uploader give me an error. The error message says about "Kodi Log Uploader Error: see the log file for more informations".
Anyway please find here the new kodi.log file
http://pastebin.com/5kv645jQ
Many thanks
Quote:'smb://PCFISSO/Multimedia/VIDEO/Film/Bambini/Le Vacanze Del Piccolo Nicolas (2014).avi':
08:38:18 T:140700280121088 INFO: ffmpeg[7FF756376700]: Duration: 01:37:06.82, start: 0.000000, bitrate: 2015 kb/s
08:38:18 T:140700280121088 INFO: ffmpeg[7FF756376700]: Stream #0:0: Video: mpeg4 (Advanced Simple Profile) (XVID / 0x44495658), yuv420p, 720x384 [SAR 1:1 DAR 15:8], 1877 kb/s, 23.98 fps, 23.98 tbr, 23.98 tbn, 23.98 tbc
08:38:18 T:140700280121088 INFO: ffmpeg[7FF756376700]: Stream #0:1: Audio: mp3 (U[0][0][0] / 0x0055), 48000 Hz, stereo, s16p, 128 kb/s
08:38:18 T:140700280121088 DEBUG: CDVDDemuxFFmpeg::AddStream(0, ...) -> 0
08:38:18 T:140700280121088 DEBUG: CDVDDemuxFFmpeg::AddStream(1, ...) -> 1

There is only one AudioTrack - mp3 2 channels. Which should be played the very same way as your music via your DAC.
(2015-12-26, 11:15)fritsch Wrote: [ -> ]
Quote:'smb://PCFISSO/Multimedia/VIDEO/Film/Bambini/Le Vacanze Del Piccolo Nicolas (2014).avi':
08:38:18 T:140700280121088 INFO: ffmpeg[7FF756376700]: Duration: 01:37:06.82, start: 0.000000, bitrate: 2015 kb/s
08:38:18 T:140700280121088 INFO: ffmpeg[7FF756376700]: Stream #0:0: Video: mpeg4 (Advanced Simple Profile) (XVID / 0x44495658), yuv420p, 720x384 [SAR 1:1 DAR 15:8], 1877 kb/s, 23.98 fps, 23.98 tbr, 23.98 tbn, 23.98 tbc
08:38:18 T:140700280121088 INFO: ffmpeg[7FF756376700]: Stream #0:1: Audio: mp3 (U[0][0][0] / 0x0055), 48000 Hz, stereo, s16p, 128 kb/s
08:38:18 T:140700280121088 DEBUG: CDVDDemuxFFmpeg::AddStream(0, ...) -> 0
08:38:18 T:140700280121088 DEBUG: CDVDDemuxFFmpeg::AddStream(1, ...) -> 1

There is only one AudioTrack - mp3 2 channels. Which should be played the very same way as your music via your DAC.
In fact, with the current audio settings, stereo audio tracks from movies are played through the external DAC instead trough the HDMI output od the NUC. The problem is that in my AV receiver I can't obtain audio from HDMI input (necessary for multichannel audio tracks) and from analog input both in the same Input port. I can set the receiver to use both in the same input port, but obviously the receiver have to choose just one input, and it gives priority to the HDMI audio input. At the moment, in order to avoid setting changes on Kodi, to listen movies with stereo audio track I've to change input in the AV receiver passing to an input with only analog audio input activated.
So, the question now is only: with passthrough funciont activated on HDMI output of the NUC, it's normal that stereo audio tracks of movies are not passed through the HDMI? Are there some audio settings to do in Kodi to obtain this, keeping the possibility to listen 2 ch music from the external DAC?
Many thanks
Passthrough is done for: DTS. AC3. DTS-HD, TrueHD (if the AVR supports them).

all formats that are decoded like mp3, aac, flac and so on are sent via the PCM device after decoding.
(2015-12-26, 14:54)fritsch Wrote: [ -> ]Passthrough is done for: DTS. AC3. DTS-HD, TrueHD (if the AVR supports them).

all formats that are decoded like mp3, aac, flac and so on are sent via the PCM device after decoding.

Ok, thanks. It's only my opinion, but I think this is a correct approach for audio files, but in case of audio tracks of movies, I think it could have sense to passthrough any kind of audio format on the HDMI output...
Anyway, many thanks for the information.
(2015-12-26, 18:09)fanta64 Wrote: [ -> ]Ok, thanks. It's only my opinion, but I think this is a correct approach for audio files, but in case of audio tracks of movies, I think it could have sense to passthrough any kind of audio format on the HDMI output...

That's not possible. Many file formats can't be bitstreamed over HDMI as the HDMI standard doesn't support them - so there is no option but to decode them to PCM. AIUI neither FLAC nor MP3 can be bitstreamed over HDMI for example - so they have to be decoded to PCM.
(2015-12-26, 18:23)noggin Wrote: [ -> ]
(2015-12-26, 18:09)fanta64 Wrote: [ -> ]Ok, thanks. It's only my opinion, but I think this is a correct approach for audio files, but in case of audio tracks of movies, I think it could have sense to passthrough any kind of audio format on the HDMI output...

That's not possible. Many file formats can't be bitstreamed over HDMI as the HDMI standard doesn't support them - so there is no option but to decode them to PCM. AIUI neither FLAC nor MP3 can be bitstreamed over HDMI for example - so they have to be decoded to PCM.
OK, thanks