Kodi Community Forum

Full Version: [RELEASE] Flix2Kodi - Just another Netflix-Addon
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

please update to 0.3.1 and make shure you've enabled debug in settings.
then start playing an item again from flix2kodi and post log.
p.s.: you can disable debug logging in kodi. It is enough to enable the debug in flix2kodi setting.
(2015-12-31, 14:22)logi85 Wrote: [ -> ]Snicket:

please update to 0.3.1 and make shure you've enabled debug in settings.
then start playing an item again from flix2kodi and post log.
p.s.: you can disable debug logging in kodi. It is enough to enable the debug in flix2kodi setting.

Thanks for the quick answer!
I will do that but is 0.3.1 in the repo already?
Yes it is.
Options -> Settings -> Addons -> Install from Repository -> select Logi85 Addons -> context menu -> search for updates

Edit: Did a little mistake, please enable kodi debug before trying.

Great job mate!

How this would work on OpenElec?

Thanks logi, for sending a reply! no 4. is my only issue at the moment.. I first used the MCE remote addon, but that didn't work. Like you said, Chrome is, of course, the active window. So I need to find a way to send a ctrl-w command with my MCE remote to windows... I have tried "LM remote keymap", but no matter which remote control I choose (mine is not on the list), so far no luck.. (I tried to change 8 to ^w, to make sure I would press the right button)

Anyone else on windows with any tips??

edit: one solution is to use the KODI remote app on my phone. If i press "back" there, it does go back to KODI.. Would like it to work with my MCE remote. When I found a solution, I'll post it here.
What would be necessary to get this fork work on an Nvidia Shield [Android] TV?
does this addon streams hd content?
@logi85 thanks for taking this on.

how is the navigation with this add-on? that seems to be one of the biggest challenges with the netflix stuff?
(2015-12-31, 13:49)logi85 Wrote: [ -> ]
(2015-12-31, 10:59)Cassiuss Wrote: [ -> ]It is working for me as well now! Fantastic job Zero and Logi85!! Thanks so much for all the effort!! Rofl

Also thanks for opening a new thread, it will be much easier now for other people to find out how it works.

Since I am a simple user, and not a programmer, some (simple) things that are clear for some people are not always directly clear to me. So just to be sure and for the sake of people who don't have a working version yet:

1. Do you manually need to download the latest version of Python for this to work? I believe so, correct me if I'm wrong
2. Do you have to run kodi and/or chrome as administrator for this to work in windows? (I can play around with this myself today, so I can answer it myself later on if nobody has a ready answer)
3.Do you have to install the chromelauncher addon yourself or will it now be done as an "dependency" by kodi?
4.When you are in Netflix, how can you make sure that you can control it with your (MCE/Harmony) remote? At the moment I am not able to go back to kodi (ctrl+w) without keyboard, I think the solution has something to do with adding a keyboard.xml, but I still have to do my research on this. For now I was just very happy that I managed to open a netflix video in kodi
5. Are subtitles and other audio streams supported? I believe not yet. (correct me if I'm wrong)

(2015-12-31, 08:24)thejaffe Wrote: [ -> ]On this version of the addon, running Windows 10, latest Kodi stable, the addon works perfect except My List in TV and Movies shows only a fraction of my content. My Netflix TV list probably has about 100 items, but only shows 37 shows, and with no apparent reasoning, not alphabetical, when I added etc...

I seem to have the same problem... Also on W10, so maybe a windows problem....

Hi Cassius,

1. Kodi should be bundled with a working version, just try.
2. I don't think this is necessary
3. Chromelauncher is not required. However I've added this option for openelec users. Have a look on old thread (Netflixbmc)
4. Can you control Kodi with your remote? My addon captures actions (like keypresses) on playback. So if your remote will send keys / actions to Kodi while playback it should work. You could press keys while watching and then have a look in your Kodi-Logfile. If there are entries like 'Unknown action...' I could add missing actions. If there are no entries your remote does not sent requests to kodi, probably sending to active window, which would be chrome. Perhaps there is an existing plugin which could handle your remote for your browser.
5. Currently not, but I have an open issue on this. But not with highest priority.

My-List missing items is a known issue

More Info:

The My List issue is not machine specific, just did a clean install of Jarvis Beta 4 on a different PC (Win 10 also) produces same result, 37 TV shows listed of about 120 that are actually in list. Not griping, or impatient, just trying to help narrow down. Either it's Windows specific, or Netflix account specific (huge number of crap shows I never watch in My List).
(2015-12-31, 18:30)patria o muerte Wrote: [ -> ]Hi,
does this addon streams hd content?

It's limited to 720P, this is a Chrome limitation. If you use another browser, like EDGE, you can get to 1080P,

In this post, Logi85 tell how to use another browser:


BUT, I don't know if is working right now in new version.
You can try Big Grin
(2015-12-31, 14:02)Snicket Wrote: [ -> ]
(2015-12-31, 13:59)logi85 Wrote: [ -> ]Hi,

if you double-click the cmd, it stays until you close the browser?
Or will it start the browser and then quit?

Both the browser and the cmd stay open until I close the browser.
I also tried it with Chrome Launcher had the same problem with it.

Also having this issue on Windows 10. Here is my log:

Btw, amazing work to get this up and running again.
Hi logi85 the new addon is working great but I'm having a issue with my remote control no longer working neither does the android kore remote I'm using ChromeLauncher with the user script pointed at the chromium remote control addon. The in the old app before the rename it still works and lirc is receiving the commands but nothing happens. Heres a log. Thanks for getting the addon up and running again.
It appears chrome launcher is working for me but after some research I found chrome to only support 720p and I thought I would try getting IE to work in launchbrowser.com, since it supposedly supports 1080p, and I was successful to a point. Everything was as it should be except the remote key mapping for some reason. the logitech remote is configured for WMC remote and work like it always been with chrome but not for IE 11. Wondering if anyone know how I should map the controller for Flix2Kodi hopefully with out breaking the remotes other functions for the Windows 8.1 x64 desktop. I am willing to try it on an alternate browser if it too supports both 1080p and WMC functions. Until then I went back to defaults settings on a perfectly working chrome/netflix setup with Flix2Kodi (...at 720p)
I will add support for other browsers. Please post the default path and parameters for each browser (Firefox, Internet Explorer, edge). I Also Need the window name of the browser while playing a video.
Problem in OpenElec with v0.3.1: video and audio are working fine, but the remote keys are not working anymore. In last plugin.video.netflix version (v0.1) they worked fine ...

Edit: Same problem of v0.3.1 if you add e. g. a movie to database and start from there (v0.1).