Kodi Community Forum

Full Version: [RELEASE] Flix2Kodi - Just another Netflix-Addon
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
The login is correct- the plugin sometime wants to relogin, but it crashes before it can ask for the credentials...
Maybe it has something to do with the localization? Is netflix germany/austria supported?
Anyone working on getting the ability to search fixed?
(2016-09-07, 23:43)MetalChris Wrote: [ -> ]
(2016-09-07, 20:16)mrfreddy Wrote: [ -> ]but it makes me think the problem is not on the Kodi box, but somehow it leaves a trace on Netflix sign-in. but i am not sure how to invetigate ...but if i can do something per instructions i will be glad to help

thx


Netflix does limit the number of devices you can use at one time. Depending on your subscription, you may only be able to use 1 device at time. The most devices you can use at one time is 4.

i have plan for 2 devices. i have played around a little. i installed Chrome launcher addon and Netflix works in there. I will do some more poking around next week to see if i can come up with anything ...

thx
Hi
I just installed version 0.6.6.

When I login "Who's watching" list is empty. How can I fix this?
Is this for Jarvis only? Since I switched to Krypron I cant even start the addon without an error.
still having problems.. can it be that it only works with netflix US?
(2016-09-08, 00:28)murph7355 Wrote: [ -> ]Waiting a little while and/or restarting the machine I can access Netflix OK via a browser. It only goes awry after trying Flix2Kodi (which itself was working fine a little while ago.).

What I suspect is happening is that the Flix2Kodi processes are making Netflix think I'm logged on multiple times, or perhaps trying to "spam" the connection. So the Netflix side shuts me out for a little while.

But I'm not sure why it would be doing this.
...

I've experienced similar things and came to the same conclusion - flix2kodi can somehow put Netflix in a state where it refuses logins (both flix2kodi and directly from browser). Wait a while (not sure how long) and it clears up on its own - can login via both flix2kodi and browser. Unfortunately the browser error message Netflix provides is of the generic "we're currently experiencing technical difficulties - try again later" variety - i.e., it's not terribly useful.
I seem to have managed to break something somewhere during a reinstall
could someone please help or point me to where I could find the answer
regards
charl


ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
- NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
Error Type: <type 'exceptions.ImportError'>
Error Contents: DLL load failed: The specified module could not be found.
Traceback (most recent call last):
File "C:\Users\mediapc\AppData\Roaming\Kodi\addons\plugin.video.flix2kodi\addon.py", line 10, in <module>
from resources import general
File "C:\Users\mediapc\AppData\Roaming\Kodi\addons\plugin.video.flix2kodi\resources\general.py", line 7, in <module>
import add
File "C:\Users\mediapc\AppData\Roaming\Kodi\addons\plugin.video.flix2kodi\resources\add.py", line 10, in <module>
from resources import library
File "C:\Users\mediapc\AppData\Roaming\Kodi\addons\plugin.video.flix2kodi\resources\library.py", line 9, in <module>
import get
File "C:\Users\mediapc\AppData\Roaming\Kodi\addons\plugin.video.flix2kodi\resources\get.py", line 18, in <module>
from resources import connect, video_parser
File "C:\Users\mediapc\AppData\Roaming\Kodi\addons\plugin.video.flix2kodi\resources\connect.py", line 15, in <module>
from resources import chrome_cookie
File "C:\Users\mediapc\AppData\Roaming\Kodi\addons\plugin.video.flix2kodi\resources\chrome_cookie.py", line 16, in <module>
import win32crypt
ImportError: DLL load failed: The specified module could not be found.
-->End of Python script error report<--
are you using windows?
you seem to be missing win32crypt... maybe do a reinstall, or download it (from github?)... I don't know, maybe that helps.

I myself got this error:
http://paste.ubuntu.com/23188007/
I've googled it, but it seems others having the same problem with 0.6.6 ..... Reinstalled it, don't know to fix it... Maybe an update will do it... I hope.
Confused Not working on the Raspberry PI 3 w/LibreElec Kodi. Any suggestions?
could you give use your logfile?
without a log we cannot help you, because we do not know the problem.
Hey guys, I'm getting the blank login on both my Win10 machine and OpenELEC machine... I don't remember Netflix having 2 factor authentication so if that's new I could see that being our problem. Anyway here is my Log.

Thanks!
I think you might be on to something. I just tried running the add-on without a netflix password. I get the same results as if I had a password. Also I noticed in the error logs it is not pulling the correct profile information from the api. Name shows as NULL. I think something certainly changed with the login. I am just not smart enough to trace how netflix handles the logins. Maybe my observations help?
So not sure if this is a official work around but I was able to get it to work on 2 of my systems, maybe coincidence. I am running Linux Mint 17.2 with Kodi 16.1 and Linux Mint 17.2 with Kodi 17. I opened Chrome from the operating system and logged in to Netflix then, on the same system, I ran Flix2Kodi from Kodi. I was then able to select "Who's Watching". I duplicated the results on my second system.

The other thing I noticed was 3 different login screens on the Netflix website.
1 - just has the just email box in a form until after you submit then just a password box in the form. Graphics in background.
2 - Both boxes in one form with Graphics in the background.
3 - Both boxes in form with plain background.
Still getting cookie errors. Am I doing something wrong?

Code:
09:14:03 T:1216   ERROR: [plugin.video.flix2kodi] Error clearing Chrome-Cookie: Traceback (most recent call last):
                                              File "C:\Users\Michael\AppData\Roaming\Kodi\addons\plugin.video.flix2kodi\resources\chrome_cookie.py", line 92, in clear_netflix_cookies
                                                cur.execute(sql, ('.netflix.com',))
                                            OperationalError: disk I/O error
09:14:05 T:1216   ERROR: [plugin.video.flix2kodi] Error setting Chrome-Cookie: Traceback (most recent call last):
                                              File "C:\Users\Michael\AppData\Roaming\Kodi\addons\plugin.video.flix2kodi\resources\chrome_cookie.py", line 138, in set_netflix_cookies
                                                set_cookie(conn, cookie.name, cookie.value, expires_date)
                                              File "C:\Users\Michael\AppData\Roaming\Kodi\addons\plugin.video.flix2kodi\resources\chrome_cookie.py", line 100, in set_cookie
                                                if has_cookie(conn, name):
                                              File "C:\Users\Michael\AppData\Roaming\Kodi\addons\plugin.video.flix2kodi\resources\chrome_cookie.py", line 63, in has_cookie
                                                c.execute('SELECT count(*) FROM cookies WHERE host_key = ? and name=?',('.netflix.com',name))
                                            OperationalError: disk I/O error
09:14:05 T:1216   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.ValueError'>
                                            Error Contents: root_list_id not found in cookies!
                                            Traceback (most recent call last):
                                              File "C:\Users\Michael\AppData\Roaming\Kodi\addons\plugin.video.flix2kodi\addon.py", line 91, in <module>
                                                handle_request()
                                              File "C:\Users\Michael\AppData\Roaming\Kodi\addons\plugin.video.flix2kodi\addon.py", line 37, in handle_request
                                                general.main(video_type)
                                              File "C:\Users\Michael\AppData\Roaming\Kodi\addons\plugin.video.flix2kodi\resources\general.py", line 49, in main
                                                root_list = lolomos.get_root_list()
                                              File "C:\Users\Michael\AppData\Roaming\Kodi\addons\plugin.video.flix2kodi\resources\path_evaluator\types\lolomos.py", line 40, in get_root_list
                                                return get_root_list_id_from_cookie()
                                              File "C:\Users\Michael\AppData\Roaming\Kodi\addons\plugin.video.flix2kodi\resources\path_evaluator\__init__.py", line 68, in get_root_list_id_from_cookie
                                                raise ValueError('root_list_id not found in cookies!')
                                            ValueError: root_list_id not found in cookies!
                                            -->End of Python script error report<--
09:14:05 T:5028   ERROR: XFILE::CDirectory::GetDirectory - Error getting plugin://plugin.video.flix2kodi/?mode=main&thumb&type=show&url
09:14:05 T:5028   ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.flix2kodi/?mode=main&thumb&type=show&url) failed