Kodi Community Forum

Full Version: [RELEASE] Flix2Kodi - Just another Netflix-Addon
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
(2017-02-11, 16:59)orduek Wrote: [ -> ]Just a short update.
After doing some search, I found a nice add-on that can give another option: Remote Control Browser (http://addons.kodi.tv/show/plugin.progra...l.browser/).
It enables Chrome on full screen with remote control working (arrows in remote control can move the mouse cursor).
It is not ideal, but you can easily enter and browse Netflix website. No need to always update settings according to API.

Hmmmm can't get it to install on Krypton.
Nice Job
Working Good!!
Thanks
(2017-02-11, 16:59)orduek Wrote: [ -> ]Just a short update.
...

Hi orduek,
thanks for the hint.
I've installed the the plugin and would like to configure it.
What have you choosen at "browser path"?

I've a openelec installation with chromium plugin. Chromium works well and I'm able to watch Netflix, but it requires an pointing device.

When I choose config > browser path Kodi shows me the Home folder, Root filesystem and 4 net targets.
Unfortunatelly I'm not sure what I've to choose and can't find a documentation which explain this.
Another option, that I am now doing is this: http://openelec.tv/forum/128-addons/7759...azon-prime
I am now running LibreELEC with Chromium and using my remote to control the mouse pointer with the script in the thread.
I've been trying to get kodi connected with my netflix account and it keeps giving me error message. It keeps asking what profile will I be using and then I choose mine and it then brings up an error message and won't go into movies, or tv shows.
does anyone have this addon working?
I have the same problem as shindou.. I choose my profile, and then I get also an error message and the movies or tv show won't load. After that, you can choose your profile again. It looks like it's in a loop.
Hey there,

same Error as shindou and Lifestyle.

I can't get flix2kodi get to run. I run Libreelec 17 on an Intel NUC and Netflix on Chromium runs. When i invoke flix2kodi with chromelauncher as choosen browser, i get the following errors in the log (i deleted the rest of the entries in the log which are not errors and the netflix links. if you need them too, let me know plz):

15:49:20.671 T:139778991364224 ERROR: Control 55 in window 10025 has been asked to focus, but it can't
15:49:31.275 T:139776573921024 ERROR: [plugin.video.flix2kodi] Traceback (most recent call last):
File "/storage/.kodi/addons/plugin.video.flix2kodi/addon.py", line 85, in <module>
handle_request()
File "/storage/.kodi/addons/plugin.video.flix2kodi/addon.py", line 37, in handle_request
general.main(video_type)
File "/storage/.kodi/addons/plugin.video.flix2kodi/resources/general.py", line 50, in main
mylist = lolomos.get_mylist(root_list)
File "/storage/.kodi/addons/plugin.video.flix2kodi/resources/path_evaluator/types/lolomos.py", line 53, in get_mylist
ret = req_path(my_list(root_list_id), lists(root_list_id))
File "/storage/.kodi/addons/plugin.video.flix2kodi/resources/path_evaluator/__init__.py", line 26, in req_path
content = connect.load_netflix_site(generic_utility.evaluator_url % (generic_utility.api_url, endpoints['/pathEvaluator']), post)
File "/storage/.kodi/addons/plugin.video.flix2kodi/resources/connect.py", line 143, in load_netflix_site
raise ValueError('!HTTP-ERROR1!: '+str(status_code)+' loading: "'+url+'", post: "'+ str(post)+'"')
ValueError: !HTTP-ERROR1!: 404 loading: "https://www.netflix.com/api/shakti....
15:49:48.403 T:139776573921024 ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
- NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
Error Type: <type 'exceptions.ValueError'>
Error Contents: !HTTP-ERROR1!: 404 loading: "https://www.netflix.com/api/shakti/....
Traceback (most recent call last):
File "/storage/.kodi/addons/plugin.video.flix2kodi/addon.py", line 91, in <module>
handle_request()
File "/storage/.kodi/addons/plugin.video.flix2kodi/addon.py", line 37, in handle_request
general.main(video_type)
File "/storage/.kodi/addons/plugin.video.flix2kodi/resources/general.py", line 50, in main
mylist = lolomos.get_mylist(root_list)
File "/storage/.kodi/addons/plugin.video.flix2kodi/resources/path_evaluator/types/lolomos.py", line 53, in get_mylist
ret = req_path(my_list(root_list_id), lists(root_list_id))
File "/storage/.kodi/addons/plugin.video.flix2kodi/resources/path_evaluator/__init__.py", line 26, in req_path
content = connect.load_netflix_site(generic_utility.evaluator_url % (generic_utility.api_url, endpoints['/pathEvaluator']), post)
File "/storage/.kodi/addons/plugin.video.flix2kodi/resources/connect.py", line 143, in load_netflix_site
raise ValueError('!HTTP-ERROR1!: '+str(status_code)+' loading: "'+url+'", post: "'+ str(post)+'"')
ValueError: !HTTP-ERROR1!: 404 loading: "https://www.netflix.com/api/shakti....
-->End of Python script error report<--
15:49:48.449 T:139778991364224 ERROR: GetDirectory - Error getting plugin://plugin.video.flix2kodi/?mode=main&thumb&type=movie&url
15:49:48.449 T:139778991364224 ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.flix2kodi/?mode=main&thumb&type=movie&url) failed

Any advice?

Thx
For what it's worth, gnjack updated node-netflix2 based on the changes to the shakti API. I have no clue what the changes entail, but someone who is a little more knowledgeable might be able to do the same for Flix2Kodi.

https://github.com/genderquery/node-netf...d8af865a28
Guess this is a dead addon.
I'm afraid it is... Sad
I'm forked the logi85 project on github. Now it's works, i've only tested in Linux with Kodi 16.x

https://github.com/yamboo-efi/plugin.video.flix2kodi
Nice work @yamboo-efi I have installed your fork of the project and it is working well. I haven't used it much yet, but will post back if I encounter any issues. Thanks!
(2017-04-28, 16:53)yamboo-efi Wrote: [ -> ]I'm forked the logi85 project on github. Now it's works, i've only tested in Linux with Kodi 16.x

https://github.com/yamboo-efi/plugin.video.flix2kodi
Have you opened a new thread and would you like this one closed?
(2017-04-28, 16:53)yamboo-efi Wrote: [ -> ]I'm forked the logi85 project on github. Now it's works, i've only tested in Linux with Kodi 16.x

https://github.com/yamboo-efi/plugin.video.flix2kodi

I tried on Kodi 17 and that didn't work (got an error, but haven't got time to figure out what the issue is). It does work on Kodi 16 icm with Windows