Kodi Community Forum

Full Version: Install guide for OE
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Hello and apologies if this has been asked before.
I have looked for a simple installation guide but only found the "... I need a clean pair of pants" post which is way too complicated for me, so I was left wondering if there is a simpler installation method.

I have downloaded the latest build for openelec (unfortunately it seems MAME is not yet in there) and opened the compressed archive.
Inside there are the classic openelec KERNEL and SYSTEM files.

Should I just pop these in the folder and the system will automagically update to that build?
If not how do I use those files?
Do I have to create a new install usb key?

I am also using Kodi in conjuction with Emby. Will it mess that up?
If you want install it on a device that is not on OE already you can find the needed information here:
If you already have openelec you can copy the tar-file into /storage/.update/ and reboot.

I'm not sure if it will mess up your Emby setup.
(2016-01-01, 19:25)a1rwulf Wrote: [ -> ]If you already have openelec you can copy the tar-file into /storage/.update/ and reboot.

That was quick, thanks!
Does this also apply for future versions? So I can basically just dump that file every time and kodi-retroplayer gets updated every time?

Thanks again
This true for OE in general.

I have managed to install it seamlessly.

Now I have no clue where to go.

I have RCB installed as well, but it asks me to "Select emulator location".
Obviously I have nowhere to point it to...

As per this post

I have the config file open but don't know where to paste the "useBuiltin.." xml tag.
I tried looking for an existing xml and found this one to copy from:

Unfortunately I don't have all those entries because I can't get to the stage where I can give it the folders as I am stuck on RCB wanting the emulator.

Any help would be very much appreciated.

is it possible to somehow launch Retroplayer without Rom Collection Browser? It's quite a nightmare to set up

I'm trying to uninstall RCB but it doesn't seem possible as it is "USED BY AEON MQ6 SKIN". Tried switching to Confluence, no luck, same error.

I have no idea about RCB.
When you use the Confluence skin there is a game section.
You can start your roms directly within kodi then.
Make sure you configure a controller first.
Hi and thanks for following me through this.
Yes my xbox wireless controller was instantly recognised (props for this!) and I was able to configure it right away.
I have changed skin and I can see the .smc files (only SNES for now) in the share.
if I select one of those by pressing "play" or "ok" nothing happens.
Should it start from there?

All the emulator add ons show up as "enabled"; in their context menu the only option I get is "show add on information" and in there I can only choose "change log"
In games > files I see the list of SMC files and if I go in the context menu I get "Play - Add to favourites - Settings".
Settings just does the general setting for Retroplayer where I can change the user input.

Edit: after reading more and installing a different version (charlie's) things have changed a little but still it doesn't work.
It seems remotely-stored roms don't load...
Can anyone confirm?
it depends on the emulator. until now I only tested locally stored ones.
(2016-01-02, 01:18)grumpygamer Wrote: [ -> ]Edit: after reading more and installing a different version (charlie's) things have changed a little but still it doesn't work.
It seems remotely-stored roms don't load...
Can anyone confirm?

I believe this is a per-emulator issue. I forget why. Have you tried copying the files locally and running them there?
take a look here: http://kodi.wiki/view/Game_add-ons#Libretro_cores
I believe the "supports VFS" column will let you know which cores support remotely stored roms.
For loading ROMs from remote the addon / libretro core needs to offer vfs support. (http://kodi.wiki/view/Game_Add-ons, https://github.com/kodi-game/game.libret...on.xml#L14).

EDIT: 1min, too late Big Grin
Oh... right! What a bummer. So we (I) should request this on each relevant core site?
Would Symlinks work?

Edit: I am trying again with Charlie's latest build.
Will post back in a minute as I want to try bSNES Mercury since it seems it DOES support VFS.
Most likely, requesting it for every single core won't work (at least until someone steps up and implements it - if even possible).
There are several snes libretro cores for example, some may provide vfs while others won't.
You will have to stick with the emulators that fit your needs.
snes9x-next launched over smb for me but my controllers were broken with charlies latest build :/
Yep just tried myself.
Oddly enough bSNES Mercury shows as supporting VFS but it doesn't work.

Also many SMCs crash with Snes9X-next Sad
I have a 4130T processor that should be powerful enough...

I am also wondering if it's too early to be able to remove filtering from the emulator?
I have not tested the actual controller yet so I can't confirm your issue.

Edit: would a symlink solve the issue?
Edit: there is also a bug with the volume that prevents any changes while watching a movie

I have tried storing the ROMS locally with the following results:
- In the pop-up for emulator choice now bSNES is present
- If selected all other emulators besides bSNES and Snes9X-Next do nothing
- bSNES seems to work
- Snes9X-Next still crashes most of the ROMS.
Pages: 1 2