Kodi Community Forum

Full Version: Retrospect v5.3.2 Video Add-On
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
(2021-06-26, 02:03)KurtKnakker Wrote: [ -> ]
(2021-06-26, 01:58)KurtKnakker Wrote: [ -> ]https://paste.kodi.tv/zabaheludu

Kodi debug.
I’ll check for the imputstream fix.

Imputstream helper fix worked!

Thanks!
Great!
Since a few weeks, anything from the NEP streaming platform seems broken. This means NPO via Retrospect but also the Videoland addon.
Problem lies here somewhere;

2021-09-22 22:49:44.394 T:1157     INFO <general>: AddOnLog: inputstream.adaptive: Successfully parsed manifest file. #Periods: 1, #Streams in first period: 2, Type: VOD, Download speed: 11544137.7582 Bytes/s
2021-09-22 22:49:45.170 T:1157    ERROR <general>: CCurlFile::FillBuffer - Failed: HTTP returned error 500
2021-09-22 22:49:45.170 T:1157    ERROR <general>: CCurlFile::Open failed with code 500 for https://npo-drm-gateway.samgcloud.nepwor...entication:
2021-09-22 22:49:45.170 T:1157    ERROR <general>: AddOnLog: inputstream.adaptive: License server returned failure
2021-09-22 22:49:45.170 T:1157    ERROR <general>: AddOnLog: inputstream.adaptive: License update not successful (no keys)
2021-09-22 22:49:45.187 T:1157    ERROR <general>: AddOnLog: inputstream.adaptive: Initialize failed (SingleSampleDecrypter)
2021-09-22 22:49:45.188 T:1157    ERROR <general>: CVideoPlayer::OpenInputStream - error opening [plugin://plugin.video.retrospect/?channel=channel.nos.nos2010-uzgjson&action=playvideo&pickle=E9C291CE8A0F700D805933438FB4BD117BBB99FDAD54A7E03CCC75EF0A05B8F1--E9C291CE8A0F700D805933438FB4BD1131EB8969BB23680C1DE7AC3B43111D16]

I have not seen anyone else report this issue. Does anyone have an idea on how to fix this?

EDIT: Why do I always find solutions minutes after asking on a forum... Reinstalled Widevine via inputstreamhelper and its now fixed.
(2021-09-23, 16:47)Ballistic Wrote: [ -> ]Since a few weeks, anything from the NEP streaming platform seems broken. This means NPO via Retrospect but also the Videoland addon.
Problem lies here somewhere;

2021-09-22 22:49:44.394 T:1157     INFO <general>: AddOnLog: inputstream.adaptive: Successfully parsed manifest file. #Periods: 1, #Streams in first period: 2, Type: VOD, Download speed: 11544137.7582 Bytes/s
2021-09-22 22:49:45.170 T:1157    ERROR <general>: CCurlFile::FillBuffer - Failed: HTTP returned error 500
2021-09-22 22:49:45.170 T:1157    ERROR <general>: CCurlFile::Open failed with code 500 for https://npo-drm-gateway.samgcloud.nepwor...entication:
2021-09-22 22:49:45.170 T:1157    ERROR <general>: AddOnLog: inputstream.adaptive: License server returned failure
2021-09-22 22:49:45.170 T:1157    ERROR <general>: AddOnLog: inputstream.adaptive: License update not successful (no keys)
2021-09-22 22:49:45.187 T:1157    ERROR <general>: AddOnLog: inputstream.adaptive: Initialize failed (SingleSampleDecrypter)
2021-09-22 22:49:45.188 T:1157    ERROR <general>: CVideoPlayer::OpenInputStream - error opening [plugin://plugin.video.retrospect/?channel=channel.nos.nos2010-uzgjson&action=playvideo&pickle=E9C291CE8A0F700D805933438FB4BD117BBB99FDAD54A7E03CCC75EF0A05B8F1--E9C291CE8A0F700D805933438FB4BD1131EB8969BB23680C1DE7AC3B43111D16]

I have not seen anyone else report this issue. Does anyone have an idea on how to fix this?

EDIT: Why do I always find solutions minutes after asking on a forum... Reinstalled Widevine via inputstreamhelper and its now fixed.
It's WideVine related: https://github.com/retrospect-addon/plug...ssues/1547 or https://github.com/retrospect-addon/plug...ssues/1515 for the fix.
Hey! I always run a VPN on my Kodi setup, connected to a Dutch server.
When I just tried to start "Forever Young" on NPO it was loading and then instantly stopped.
Then I tried turning off the VPN and tried starting the program again and it started playing immediately.
Do you know what's causing this? Has NPO built in an anti VPN sort of thing?
We do not support that sort of usage - see our VPN policy (wiki) for more details.
Hi
I have noticed some channels are empty with programs and I wonder if you also see the same.

The channels I have come across are Kanal 5, TV 9 and TV 11. All Swedish channels.
Same with VOX.

I get the message popup saying Retrospect error - couldn’t find any programs or channels.

I've updated to latest 5.5.3 on Kodi Leia.

Thanks
(2022-04-03, 16:56)Siddan Wrote: [ -> ]Hi
I have noticed some channels are empty with programs and I wonder if you also see the same.

The channels I have come across are Kanal 5, TV 9 and TV 11. All Swedish channels.
Same with VOX.

I get the message popup saying Retrospect error - couldn’t find any programs or channels.

I've updated to latest 5.5.3 on Kodi Leia.

Thanks

Correct. They broke indefinitely as they moved to discovery and/or Dplay. The login does not work for those. So I am removing them
Ah yea, the Discovery+ gang.
Thanks for your reply
Last night I noticed an issue with my parents' installation of Retrospect on their Nvidia Shield TV (with Kodi 19.3) where the list of channels recently became completely empty. I tried removing the addon and associated configuration and then reinstalling it, but still face the same issue. I can't reproduce this issue with my existing installation at home or a fresh new installation on my phone using the exact same configuration as they have.

Has anyone seen this issue before?

Unfortunately I didn't have time to pull the retrospect.log file but I'll likely go past there sometime next week. Should I check/grab any other logs besides retrospect.log?
(2022-04-10, 12:56)blunden Wrote: [ -> ]Last night I noticed an issue with my parents' installation of Retrospect on their Nvidia Shield TV (with Kodi 19.3) where the list of channels recently became completely empty. I tried removing the addon and associated configuration and then reinstalling it, but still face the same issue. I can't reproduce this issue with my existing installation at home or a fresh new installation on my phone using the exact same configuration as they have.

Has anyone seen this issue before?

Unfortunately I didn't have time to pull the retrospect.log file but I'll likely go past there sometime next week. Should I check/grab any other logs besides retrospect.log?

The Retrospect or Kodi log should tell you what is wrong.
(2022-04-10, 14:20)Basje Wrote: [ -> ]The Retrospect or Kodi log should tell you what is wrong.
Yeah, I'll check the logs the next time I'm there. Smile
It turned out to be a filter that had been applied to the channel list with made it only showed "Viewed" channels. Big Grin