Kodi Community Forum

Full Version: Retrospect v5.3.2 Video Add-On
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hey Basje,

Guess what? Progress, progress, progress! Smile After carefully reviewing my regex and code, I've gotten it to display exactly 1 item on the list, which would be the latest one.

RSS-item that it shows:
Code:
<item>

      <title>commandN Episode 156</title>
      <link>http://www.podtrac.com/pts/redirect.mov/traffic.libsyn.com/commandnpro/commandN_156_H264.mov</link>
      <description>This week, your phone is your wallet, twittering house plants, and New York Times Tech writer David Pogue.&lt;div class="feedflare"&gt;
&lt;a href="http://feeds.feedburner.com/~f/command-n/h264?a=qT0CN"&gt;&lt;img src="http://feeds.feedburner.com/~f/command-n/h264?i=qT0CN" border="0"&gt;&lt;/img&gt;&lt;/a&gt; &lt;a href="http://feeds.feedburner.com/~f/command-n/h264?a=zuYwn"&gt;&lt;img src="http://feeds.feedburner.com/~f/command-n/h264?i=zuYwn" border="0"&gt;&lt;/img&gt;&lt;/a&gt; &lt;a href="http://feeds.feedburner.com/~f/command-n/h264?a=STWFN"&gt;&lt;img src="http://feeds.feedburner.com/~f/command-n/h264?i=STWFN" border="0"&gt;&lt;/img&gt;&lt;/a&gt;

&lt;/div&gt;</description>
      <pubDate>Sun, 09 Nov 2008 09:29:42 -0500</pubDate>
      <guid isPermaLink="false">commandn-episode-156</guid>
      <itunes:author>commandN</itunes:author>
      <itunes:explicit>no</itunes:explicit>
      <itunes:duration>10:55</itunes:duration>

    <author>[email protected] (commandN)</author><enclosure url="http://www.podtrac.com/pts/redirect.mov/traffic.libsyn.com/commandnpro/commandN_156_H264.mov" length="71581911" type="video/quicktime" /><media:content url="http://www.podtrac.com/pts/redirect.mov/traffic.libsyn.com/commandnpro/commandN_156_H264.mov" fileSize="71581911" type="video/quicktime" /><itunes:subtitle>This week, your phone is your wallet, twittering house plants, and New York Times Tech writer David Pogue.</itunes:subtitle><itunes:summary>This week, your phone is your wallet, twittering house plants, and New York Times Tech writer David Pogue.</itunes:summary><itunes:keywords>video,commandN,command,N,command,Amber,MacArthur,Jeff,MacArthur,Mike,Lazazzera,Brian,McKechnie,iPod,Apple,Mac,computers,tech,TV,techTV,television,technology,news,Podcast,commandn,Rocketboom,TWIT,Leo,Laporte,girls,hot,Web,vidcast</itunes:keywords></item>

The code I'm currently using can be found at:

http://www.pastebin.ca/1251613

Any idea why it's only showing 1 video for viewing (episode 156), even though the RSS file has over a hundred entries?

Once we can figure that out, the next step is to fix a weird problem for the date to show a date in 2006 rather than the actual date, and I'd like to enable to ability to Download the video-file instead of playing it, but all that's less important than fixing it to show all episodes, rather than just 1.

Appreciate your thoughts and btw, thanks for the pastebin tip. Now that I work through a proxy, everything seems to be fine, so will be uploading the content there from now on!

Oh, here's a copy of the log too: http://www.pastebin.ca/1251617

The reason why it's showing multiple updating info items is because somehow my context-menu isn't working properly and prevents me from moving my current location with my controller. Again, we'll move that to later Smile
^Mask^ Wrote:Hey Basje,

Guess what? Progress, progress, progress! Smile After carefully reviewing my regex and code, I've gotten it to display exactly 1 item on the list, which would be the latest one.
Your Regex still is not good enough. Try this one (I removed the questionmarks, which will not work very well under Python):
Code:
<item>\W+<title>([^<]+)</title>\W+<link>([^<]+)</link>\W+<description>([^>]+)&lt;div class[^>]+>\W+<pubDate>([^<]+)</pubDate>
Notice that I use a different part for the description (so you should read it from a different part of the resultSet).

You can use this tool: http://www.weitz.de/regex-coach/ to test you regexes.
I can't get the script to work.

Whenever I want to play an episode it give's me the error "Terminating"

Log:

13:32:58 T:3956 M:397565952 WARNING: CUtil::GetMatchingSource... no matching source found for [Video Plugins]
13:33:02 T:3956 M:397856768 ERROR: Unable to load: C:\Program Files\XBMC\plugins\video\XOT-Uzg.v3\resources\settings.xml, Line 0
Failed to open file
13:33:02 T:3984 M:395268096 NOTICE: -->Python Interpreter Initialized<--
13:33:02 T:3984 M:395268096 NOTICE:
13:33:03 T:3984 M:389808128 ERROR: CLocalizeStrings::ClearBlock: Trying to clear non existent block C:\Program Files\XBMC\plugins\video\XOT-Uzg.v3\
13:33:03 T:3984 M:389898240 ERROR: CLocalizeStrings::ClearBlock: Trying to clear non existent block C:\Program Files\XBMC\plugins\video\XOT-Uzg.v3\
13:33:03 T:3984 M:389890048 ERROR: CLocalizeStrings::ClearBlock: Trying to clear non existent block C:\Program Files\XBMC\plugins\video\XOT-Uzg.v3\
13:33:03 T:3984 M:389857280 ERROR: CLocalizeStrings::ClearBlock: Trying to clear non existent block C:\Program Files\XBMC\plugins\video\XOT-Uzg.v3\
13:33:03 T:3984 M:389857280 ERROR: CLocalizeStrings::ClearBlock: Trying to clear non existent block C:\Program Files\XBMC\plugins\video\XOT-Uzg.v3\
13:33:03 T:3984 M:389857280 ERROR: CLocalizeStrings::ClearBlock: Trying to clear non existent block C:\Program Files\XBMC\plugins\video\XOT-Uzg.v3\
13:33:03 T:3984 M:389853184 ERROR: CLocalizeStrings::ClearBlock: Trying to clear non existent block C:\Program Files\XBMC\plugins\video\XOT-Uzg.v3\
13:33:03 T:3984 M:389853184 ERROR: CLocalizeStrings::ClearBlock: Trying to clear non existent block C:\Program Files\XBMC\plugins\video\XOT-Uzg.v3\
13:33:03 T:3984 M:389853184 ERROR: CLocalizeStrings::ClearBlock: Trying to clear non existent block C:\Program Files\XBMC\plugins\video\XOT-Uzg.v3\
13:33:03 T:3984 M:389849088 ERROR: CLocalizeStrings::ClearBlock: Trying to clear non existent block C:\Program Files\XBMC\plugins\video\XOT-Uzg.v3\
13:33:03 T:3984 M:389849088 ERROR: CLocalizeStrings::ClearBlock: Trying to clear non existent block C:\Program Files\XBMC\plugins\video\XOT-Uzg.v3\
13:33:03 T:3984 M:389844992 ERROR: CLocalizeStrings::ClearBlock: Trying to clear non existent block C:\Program Files\XBMC\plugins\video\XOT-Uzg.v3\
13:33:03 T:3984 M:389844992 ERROR: CLocalizeStrings::ClearBlock: Trying to clear non existent block C:\Program Files\XBMC\plugins\video\XOT-Uzg.v3\
13:33:03 T:3984 M:389832704 ERROR: CLocalizeStrings::ClearBlock: Trying to clear non existent block C:\Program Files\XBMC\plugins\video\XOT-Uzg.v3\
13:33:03 T:3984 M:389832704 ERROR: CLocalizeStrings::ClearBlock: Trying to clear non existent block C:\Program Files\XBMC\plugins\video\XOT-Uzg.v3\
13:33:03 T:3984 M:389832704 ERROR: CLocalizeStrings::ClearBlock: Trying to clear non existent block C:\Program Files\XBMC\plugins\video\XOT-Uzg.v3\
13:33:03 T:3984 M:389832704 ERROR: CLocalizeStrings::ClearBlock: Trying to clear non existent block C:\Program Files\XBMC\plugins\video\XOT-Uzg.v3\
13:33:03 T:3984 M:389832704 ERROR: CLocalizeStrings::ClearBlock: Trying to clear non existent block C:\Program Files\XBMC\plugins\video\XOT-Uzg.v3\
13:33:03 T:3984 M:389832704 ERROR: CLocalizeStrings::ClearBlock: Trying to clear non existent block C:\Program Files\XBMC\plugins\video\XOT-Uzg.v3\
13:33:03 T:3984 M:389832704 ERROR: CLocalizeStrings::ClearBlock: Trying to clear non existent block C:\Program Files\XBMC\plugins\video\XOT-Uzg.v3\
13:33:03 T:3984 M:389832704 ERROR: CLocalizeStrings::ClearBlock: Trying to clear non existent block C:\Program Files\XBMC\plugins\video\XOT-Uzg.v3\
13:33:03 T:3956 M:396439552 ERROR: Unable to load: C:\Program Files\XBMC\plugins\video\XOT-Uzg.v3\resources\settings.xml, Line 0
Failed to open file
13:33:04 T:3764 M:394330112 NOTICE: -->Python Interpreter Initialized<--
13:33:04 T:3764 M:394330112 NOTICE:
13:33:06 T:3764 M:390696960 ERROR: GL: Error making context current
13:33:09 T:3764 M:387682304 ERROR: CLocalizeStrings::ClearBlock: Trying to clear non existent block C:\Program Files\XBMC\plugins\video\XOT-Uzg.v3\
13:33:10 T:3956 M:394088448 ERROR: Unable to load: C:\Program Files\XBMC\plugins\video\XOT-Uzg.v3\resources\settings.xml, Line 0
Failed to open file
13:33:10 T:1436 M:391532544 NOTICE: -->Python Interpreter Initialized<--
13:33:10 T:1436 M:391532544 NOTICE:
13:33:12 T:1436 M:387866624 ERROR: GL: Error making context current
13:33:13 T:1436 M:387420160 ERROR: CLocalizeStrings::ClearBlock: Trying to clear non existent block C:\Program Files\XBMC\plugins\video\XOT-Uzg.v3\
13:33:14 T:3956 M:392056832 ERROR: Unable to load: C:\Program Files\XBMC\plugins\video\XOT-Uzg.v3\resources\settings.xml, Line 0
Failed to open file
13:33:14 T:456 M:391516160 NOTICE: -->Python Interpreter Initialized<--
13:33:14 T:456 M:391516160 NOTICE:
13:33:17 T:456 M:387391488 ERROR: CLocalizeStrings::ClearBlock: Trying to clear non existent block C:\Program Files\XBMC\plugins\video\XOT-Uzg.v3\
sander2930 Wrote:I can't get the script to work.

Whenever I want to play an episode it give's me the error "Terminating"

Please post a uzg.log on pastebin.ca (don't post logs on a forum).
is this a sctpt or a plugin. the above is trying to load as a plugin.
Nuka1195 Wrote:is this a sctpt or a plugin. the above is trying to load as a plugin.

It is both! Depends on how you run it. If it is placed in the video plugin folder and called, then it will behave like a plugin.

If you place it in your script folder, it will behave as a script.
clever Smile
Hi,

I tried this great script on XBMC for Apple tv (atlantis final) since I purchased the atv replace my xbox in due time. The script "sort of" works, but is very very slow in responding. It downloads the requested pages well enough but when building the actual list it takes a very long time and you start thinking it its not running but then it pops up. You can actually play a show, but as I tried to explain it misses very much the speed of the implementation on the xbox.

Is there any hope that this great script will be optimized for ATV/Mac? Or maybe I installed in correctly (…) on atv. Is there any experience running this script on Atv /Mac?
terminalx Wrote:Hi,

I tried this great script on XBMC for Apple tv (atlantis final) since I purchased the atv replace my xbox in due time. The script "sort of" works, but is very very slow in responding. It downloads the requested pages well enough but when building the actual list it takes a very long time and you start thinking it its not running but then it pops up. You can actually play a show, but as I tried to explain it misses very much the speed of the implementation on the xbox.

Is there any hope that this great script will be optimized for ATV/Mac? Or maybe I installed in correctly (…) on atv. Is there any experience running this script on Atv /Mac?

Post an uzg.log file (uzgplugin.log) on pastebin.ca and I will have a look.
XBMC T3CH 8.1 Atlantis
XOT-UZG v3.2.0b1 i also tried svt.0801102

The SVTPlay channel loads the titels but does not want to open the video file.
Is SVTPlay down, does anyone know. Does it work for anyone else?
vedix Wrote:XBMC T3CH 8.1 Atlantis
XOT-UZG v3.2.0b1 i also tried svt.0801102

The SVTPlay channel loads the titels but does not want to open the video file.
Is SVTPlay down, does anyone know. Does it work for anyone else?

post a uzg.log file on pastebin.ca please, then I can have a look.
Ok here it is.
http://pastebin.ca/1260716

Thanks for wanting to have a look.
vedix Wrote:Ok here it is.
http://pastebin.ca/1260716

Thanks for wanting to have a look.

Seems that XOT is doing it's work correctly. Win32 might be the problem. Check the xbmc.log (debug mode)
Thanks alot Basje for getting me a bit further, nice to know its not XOT problem.
So I look in XBMClog debugged and see some errors there, but I dont understand what it means really, if you could help me some more and have a look please.

http://pastebin.ca/1260826
vedix Wrote:Thanks alot Basje for getting me a bit further, nice to know its not XOT problem.
So I look in XBMClog debugged and see some errors there, but I dont understand what it means really, if you could help me some more and have a look please.

http://pastebin.ca/1260826

It seems like XBMC is having trouble reading the Realmedia stream. I could check it for you tonight. I will let you know.

EDIT: Seems to be a XBMC win32 problem. Got the same here. So I cannot help you out at the moment.