Kodi Community Forum

Full Version: Retrospect v5.3.2 Video Add-On
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I get errors when I try to view TV3/6/8, but it works without any problems
with the SVT channel. The problem I'm getting is that after about 55 seconds
it cuts the stream and goes back to episode listing..

What may be wrong?


XBMC - UZG - XBMC log
http://pastebin.com/feKAh0td

XBMC - UZG
http://pastebin.com/p2U8un6G


and with another, plugin, Viasat
http://pastebin.com/p2U8un6G
chris.f Wrote:I get errors when I try to view TV3/6/8, but it works without any problems
with the SVT channel. The problem I'm getting is that after about 55 seconds
it cuts the stream and goes back to episode listing..

What may be wrong?


XBMC - UZG - XBMC log
http://pastebin.com/feKAh0td

XBMC - UZG
http://pastebin.com/p2U8un6G


and with another, plugin, Viasat
http://pastebin.com/p2U8un6G
If the streams starts to play and then stops, it's an XBMC problem, not XOT-Uzg. Apparently it can't handle the streams correctly. Did you try a more recent version of XBMC?
That's a shame to hear.
I'm using the most recent version, do you think it would work if I go back a version or so?
chris.f Wrote:That's a shame to hear.
I'm using the most recent version, do you think it would work if I go back a version or so?

No, you are using the latest release. Try an SVN build from end of januari.
Uhm, you mean one of those here?
http://mirrors.xbmc.org/nightlies/win32/

Like the one from March 1st? or should I go earlier?
As I can't find January there I guess you meant March or February or something?

edit..
I'm sorry if I write like a retard or something, but I'm not very used to open source even though I
use a lot of open source regularly.. I just don't know what I'm talking about Wink
chris.f Wrote:Uhm, you mean one of those here?
http://mirrors.xbmc.org/nightlies/win32/

Like the one from March 1st? or should I go earlier?
As I can't find January there I guess you meant March or February or something?

edit..
I'm sorry if I write like a retard or something, but I'm not very used to open source even though I
use a lot of open source regularly.. I just don't know what I'm talking about Wink

Try an early February. If you go any later, you will have problems with plugins and scripts due to sourcecode changes.
Today I finally tried R27758 from the SVN trunk and that did the same thing.
I can watch 20-50 seconds and then it clips off.

What shall I do?
Can it be XOT or is it XBMC that is troubling?
chris.f Wrote:Today I finally tried R27758 from the SVN trunk and that did the same thing.
I can watch 20-50 seconds and then it clips off.

What shall I do?
Can it be XOT or is it XBMC that is troubling?

If it starts playing, it's XBMC troubleshooting. XOT determined the correct stream, XBMC just has trouble playing them.
I have a problem with the script. When I open a channel the list stays empty. For instance in Nederland1, I open it in script mode (or video mode, doesn't make a difference) and I won't get a list with tv shows.

I use an early SVN build (feb 1st) on mac osx.

Here is the pastebin log:

http://pastebin.com/TVUu91yc
sandman4sure Wrote:I have a problem with the script. When I open a channel the list stays empty. For instance in Nederland1, I open it in script mode (or video mode, doesn't make a difference) and I won't get a list with tv shows.

I use an early SVN build (feb 1st) on mac osx.

Here is the pastebin log:

http://pastebin.com/TVUu91yc

Did you update the channels to their most recent version? See http://www.rieter.net/pages/XOT:FAQ#How_...hannels.3F
Basje Wrote:Did you update the channels to their most recent version? See http://www.rieter.net/pages/XOT:FAQ#How_...hannels.3F

Thanks! It was a combination of the Rapier skin (Qualar mod) which doesn't show the titles and outdated channels. With Confluence and the updates it's working now!
Hi,

I am running the latest XOT with the latest SVN build of XBMC for Xbox, the script works well, except for some shows being encrupted with DRM (like herrie in de huiskamer [RTL]), but my biggest issue is that the xbox has problems playing the high quality video streams, is there a way to always pick the lowest quality?

In the file: chn_rtl.py, i found:

Code:
if len(matches) > 0:        
                # sort mediaurl -> get highest quality
                matches.sort(lambda x, y: int(y[1])-int(x[1]))

Perhaps i can use a reverse sort? (EDIT: oh did not work...)

EDIT:
Also i have a problem with RTL's "Bonje met de buren" show, when starting a episode the screen goes black and Xbox will freeze and must be reset, can anyone confirm this issue on xbox?

The last lines of log file are:

Code:
20100408 15:11:34 - DEBUG    - guicontroller.py - 154 - Fetching info for 'Bonje Met De Buren /5'. Setting:
20100408 15:11:34 - DEBUG    - guicontroller.py - 154 - | Description: De Fabeltjeskrant
20100408 15:11:34 - DEBUG    - guicontroller.py - 154 - | Bonje Met De Buren
20100408 15:11:34 - DEBUG    - guicontroller.py - 154 - | Bonje Met De Buren /5
20100408 15:11:34 - DEBUG    - guicontroller.py - 154 - + Image: Q:\scripts\XOT-Uzg.v3\cache\218933.s4m.30654512.Bonje_Met_De_Bure.jpeg
20100408 15:11:34 - DEBUG    - guicontroller.py - 173 - Showing rating: None
20100408 15:11:34 - DEBUG    - chn_rtl.py       - 254 - Created dummy record for playback: Bonje Met De Buren /5 [unknown urls]
20100408 15:11:34 - DEBUG    - mediaitem.py     - 122 - Creating MediaListItem 'Bonje Met De Buren /5' for 'mms://av.rtl.nl/web/components/programma/bonjemetdeburen/218928/218933.s4m.30654512.Bonje_Met_De_Buren_s1_a5.MiMedia_WM_1500K_V9.wmv?MSWMExt=.asf'
20100408 15:11:34 - DEBUG    - chn_rtl.py       - 259 - Starting playback of the high bitrate mediaUrl (mms://av.rtl.nl/web/components/programma/bonjemetdeburen/218928/218933.s4m.30654512.Bonje_Met_De_Buren_s1_a5.MiMedia_WM_1500K_V9.wmv?MSWMExt=.asf)
20100408 15:11:34 - INFO     - chn_class.py     - 953 - Starting Video Playback using the defaultplayer
20100408 15:11:34 - DEBUG    - mediaitem.py     - 53  - Using new MediaItem object for url mms://av.rtl.nl/web/components/programma/bonjemetdeburen/218928/218933.s4m.30654512.Bonje_Met_De_Buren_s1_a5.MiMedia_WM_1500K_V9.wmv?MSWMExt=.asf
martijn189 Wrote:Hi,

I am running the latest XOT with the latest SVN build of XBMC for Xbox, the script works well, except for some shows being encrupted with DRM (like herrie in de huiskamer [RTL]), but my biggest issue is that the xbox has problems playing the high quality video streams, is there a way to always pick the lowest quality?

In the file: chn_rtl.py, i found:

Code:
if len(matches) > 0:        
                # sort mediaurl -> get highest quality
                matches.sort(lambda x, y: int(y[1])-int(x[1]))

Perhaps i can use a reverse sort? (EDIT: oh did not work...)

EDIT:
Also i have a problem with RTL's "Bonje met de buren" show, when starting a episode the screen goes black and Xbox will freeze and must be reset, can anyone confirm this issue on xbox?

The last lines of log file are:

Code:
20100408 15:11:34 - DEBUG    - guicontroller.py - 154 - Fetching info for 'Bonje Met De Buren /5'. Setting:
20100408 15:11:34 - DEBUG    - guicontroller.py - 154 - | Description: De Fabeltjeskrant
20100408 15:11:34 - DEBUG    - guicontroller.py - 154 - | Bonje Met De Buren
20100408 15:11:34 - DEBUG    - guicontroller.py - 154 - | Bonje Met De Buren /5
20100408 15:11:34 - DEBUG    - guicontroller.py - 154 - + Image: Q:\scripts\XOT-Uzg.v3\cache\218933.s4m.30654512.Bonje_Met_De_Bure.jpeg
20100408 15:11:34 - DEBUG    - guicontroller.py - 173 - Showing rating: None
20100408 15:11:34 - DEBUG    - chn_rtl.py       - 254 - Created dummy record for playback: Bonje Met De Buren /5 [unknown urls]
20100408 15:11:34 - DEBUG    - mediaitem.py     - 122 - Creating MediaListItem 'Bonje Met De Buren /5' for 'mms://av.rtl.nl/web/components/programma/bonjemetdeburen/218928/218933.s4m.30654512.Bonje_Met_De_Buren_s1_a5.MiMedia_WM_1500K_V9.wmv?MSWMExt=.asf'
20100408 15:11:34 - DEBUG    - chn_rtl.py       - 259 - Starting playback of the high bitrate mediaUrl (mms://av.rtl.nl/web/components/programma/bonjemetdeburen/218928/218933.s4m.30654512.Bonje_Met_De_Buren_s1_a5.MiMedia_WM_1500K_V9.wmv?MSWMExt=.asf)
20100408 15:11:34 - INFO     - chn_class.py     - 953 - Starting Video Playback using the defaultplayer
20100408 15:11:34 - DEBUG    - mediaitem.py     - 53  - Using new MediaItem object for url mms://av.rtl.nl/web/components/programma/bonjemetdeburen/218928/218933.s4m.30654512.Bonje_Met_De_Buren_s1_a5.MiMedia_WM_1500K_V9.wmv?MSWMExt=.asf

If you open the contextmenu on an RTL video item, you can select the playback of lower bitrates.
Really? oh tried it.. must of missed that one sorry. It's too bad RTL is encrypting most streams with DRM, i can't play most streams on my xbox, i assume everyone has these problems? (Bonje met de buren, GTST, Herrie in de huiskamer)
I'm now running XBMC Live 9.11 on an Asrock Ion 330 HT. First thing I installed next was the XOT-UZG plugin, which is awesome. Initially I installed it is a plugin, but first of all, I did not show the nice interface I was used to from the script, and secondly (like others) when opening a channel, XBMC crashed. Next, I installed as script, which is a lot more stable, and also, the nice GUI shines.

It does have a few quirks though. Sometimes it will take ages to load a channel. For example, when I click page 0 of dumpert.nl, it sometimes takes a very long time. Also, sometimes when a video ends, it takes a long time for the video list to re-appear.