Kodi Community Forum

Full Version: Retrospect v5.3.2 Video Add-On
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Daniel Malmgren Wrote:That is kinda cool! You mean you have a script that regularly tries to download stuff from various channels to check if they're still working the same way?

/Daniel

Yes that is correct. I recently created a special Dev channel that holds a lot of tests stuff. It just got too much to track manually.

There is an option to test all the channels with one click and give me a report on the number of results that were found. That showed me that there were some issues with some channels (like the Swedish channels). I can also check each channel separately.
Basje Wrote:Like I said: i fixed it here, so it will be fixed in the next release.

Nice. Is there a eta for next release?
p47r0n Wrote:Nice. Is there a eta for next release?

Not yet, it's a work in progress.
Another strange problem: I'm trying to see the swedish series "Landet Brunsås" from svt play, but without any success. I get audio only, no picture at all. Other svt programs work (though of course I haven't tried them all). I've tried quite some times now, same result every time. Can't find anything remarkable in neither xot nor xbmc logs. Anyone else that can try?

Can this be some codec I'm missing somewhere?

/Daniel
Daniel Malmgren Wrote:Another strange problem: I'm trying to see the swedish series "Landet Brunsås" from svt play, but without any success. I get audio only, no picture at all. Other svt programs work (though of course I haven't tried them all). I've tried quite some times now, same result every time. Can't find anything remarkable in neither xot nor xbmc logs. Anyone else that can try?

Can this be some codec I'm missing somewhere?

/Daniel
If it starts playing, it's not XOT-Uzg.v3. So I guess it could be a codec issue. Did you try getting the item using RTMPDump?
Basje Wrote:If it starts playing, it's not XOT-Uzg.v3. So I guess it could be a codec issue. Did you try getting the item using RTMPDump?

Yep, tried with RTMPDump now (nice program, never used it before). Got a nice little mp4 file that played perfectly in xbmc. Where does this get us?

/Daniel
Daniel Malmgren Wrote:Yep, tried with RTMPDump now (nice program, never used it before). Got a nice little mp4 file that played perfectly in xbmc. Where does this get us?

/Daniel

Ok, could you send me the command that you had to use to get the stream via RTMPDump? So I can compare them with the ones XOT generates. Please also tell me which exact episode you are trying to watch?
Basje Wrote:Ok, could you send me the command that you had to use to get the stream via RTMPDump? So I can compare them with the ones XOT generates. Please also tell me which exact episode you are trying to watch?

I didn't save the exact command I ran, but it was "rtmpdump.exe -r [exact_url_as_copied_from_uzg.log] > test.mp4". The episodes I've tested was episode 2, 3 and 4 of the serie "Landet Brunsås". I can check closer when I'm at home if you need more detailed info.

/Daniel

edit: Checked at home now. Examples of url's I tested was rtmp://fl11.c91005.cdn.qbrick.com/91005/?slist=/kluster/20110925/PG-1143035-004A-LANDETBRUNSASI-02-mp4-e-v1.mp4 and rtmp://fl11.c91005.cdn.qbrick.com/91005/?slist=/kluster/20110925/PG-1143035-004A-LANDETBRUNSASI-02-mp4-b-v1 (wanted to try out both very high and very low bitrate to see if it differed).
Daniel Malmgren Wrote:I didn't save the exact command I ran, but it was "rtmpdump.exe -r [exact_url_as_copied_from_uzg.log] > test.mp4". The episodes I've tested was episode 2, 3 and 4 of the serie "Landet Brunsås". I can check closer when I'm at home if you need more detailed info.

/Daniel

edit: Checked at home now. Examples of url's I tested was rtmp://fl11.c91005.cdn.qbrick.com/91005/?slist=/kluster/20110925/PG-1143035-004A-LANDETBRUNSASI-02-mp4-e-v1.mp4 and rtmp://fl11.c91005.cdn.qbrick.com/91005/?slist=/kluster/20110925/PG-1143035-004A-LANDETBRUNSASI-02-mp4-b-v1 (wanted to try out both very high and very low bitrate to see if it differed).
What version of RTMPDump did you use?
Basje Wrote:What version of RTMPDump did you use?

rtmpdump-20110925-git-6230845-win32 (just googled for rtmpdump and downloaded something that seemed appropriate Big Grin)

/Daniel
Hi! First of all thanks for the great addon to XBMC!

I'm having trouble using the iRTL streams in the UZG addon. Files won't play when i click on it (for example Goede Tijden Slechte Tijden)

I can't provide any logs right now, but the problems are the same like the ones described here: http://gathering.tweakers.net/forum/list...6#36758796

I'm running the XBMC stable release (10.1) on Windows 7 x64. I've installed the UZG reposiroty from zip, and downloaded all updates available. Should the streams work on this evrsion of XBMC? I will provide logs this evening.
stefan2904 Wrote:Hi! First of all thanks for the great addon to XBMC!

I'm having trouble using the iRTL streams in the UZG addon. Files won't play when i click on it (for example Goede Tijden Slechte Tijden)

I can't provide any logs right now, but the problems are the same like the ones described here: http://gathering.tweakers.net/forum/list...6#36758796

I'm running the XBMC stable release (10.1) on Windows 7 x64. I've installed the UZG reposiroty from zip, and downloaded all updates available. Should the streams work on this evrsion of XBMC? I will provide logs this evening.

Hereby the log files, I hope someone can help me!

xbmc.log - http://pastebin.com/v8jmRMJy
uzg.log - http://pastebin.com/yXC97rPp
Decided to upgrade top the latest nightly version. Now fixed, appears to be a problem in combination with the stable version..
stefan2904 Wrote:Decided to upgrade top the latest nightly version. Now fixed, appears to be a problem in combination with the stable version..

The M38U playlists were implemented in June 2011. That is why it did not work in the old version.
Daniel Malmgren Wrote:rtmpdump-20110925-git-6230845-win32 (just googled for rtmpdump and downloaded something that seemed appropriate Big Grin)

/Daniel

Hi Daniel,

I tried with my latest nightly build, I could play both streams fine! So could you try updating your XBMC?