Kodi Community Forum

Full Version: Retrospect v5.3.2 Video Add-On
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
(2013-05-19, 20:51)antonstarlid Wrote: [ -> ]
(2013-05-18, 13:50)Basje Wrote: [ -> ]
(2013-05-18, 09:13)antonstarlid Wrote: [ -> ]Not sure if this have been noticed yet but TV3Play is broken, i have try whit last release 12.2 Frodo

This is the output from the logfile

xbmc.log
uzgPlugin.log

/ Slaktarn

Your logfiles only show TV6 playback. Could you please create new ones with loglevel set to debug (see here: http://www.rieter.net/content/xot/troubleshooting/) and only playing back TV3. Also please post both uzgplugin.log and uzgplugin.old.log.

uzgPlugin.log
uzgPlugin.old.log

and

xbmc.log
xbmc.old.log

/ Slaktarn
No problem playing this item here from Windows XBMC. I know they are implementing a new ffmpeg version into XBMC. Perhaps it is cause by that? You are using a nightly build of XBMC. So that could be the issue? Did you try a more recent XBMC build?
(2013-05-19, 20:59)Basje Wrote: [ -> ]
(2013-05-19, 20:51)antonstarlid Wrote: [ -> ]
(2013-05-18, 13:50)Basje Wrote: [ -> ]Your logfiles only show TV6 playback. Could you please create new ones with loglevel set to debug (see here: http://www.rieter.net/content/xot/troubleshooting/) and only playing back TV3. Also please post both uzgplugin.log and uzgplugin.old.log.

uzgPlugin.log
uzgPlugin.old.log

and

xbmc.log
xbmc.old.log

/ Slaktarn
No problem playing this item here from Windows XBMC. I know they are implementing a new ffmpeg version into XBMC. Perhaps it is cause by that? You are using a nightly build of XBMC. So that could be the issue? Did you try a more recent XBMC build?

Have try whit fallowing versions

latest nightly build: "XBMCSetup-20130518-0da9a79-master.exe"
latest xbmc build: "xbmc-12.2.exe"
letest xbmc before that build: "xbmc-12.1.exe"
latest xbmc before that build: "xbmc-12.0.exe"

None of those are working for me

The log files are here

/ Slaktarn
(2013-05-20, 11:28)antonstarlid Wrote: [ -> ]
(2013-05-19, 20:59)Basje Wrote: [ -> ]
(2013-05-19, 20:51)antonstarlid Wrote: [ -> ]uzgPlugin.log
uzgPlugin.old.log

and

xbmc.log
xbmc.old.log

/ Slaktarn
No problem playing this item here from Windows XBMC. I know they are implementing a new ffmpeg version into XBMC. Perhaps it is cause by that? You are using a nightly build of XBMC. So that could be the issue? Did you try a more recent XBMC build?

Have try whit fallowing versions

latest nightly build: "XBMCSetup-20130518-0da9a79-master.exe"
latest xbmc build: "xbmc-12.2.exe"
letest xbmc before that build: "xbmc-12.1.exe"
latest xbmc before that build: "xbmc-12.0.exe"

None of those are working for me

The log files are here

/ Slaktarn

I do see from your XBMC log this error:
Code:
11:24:07 T:9220   ERROR: RTMP_HashSWF: couldn't open C:\Users\Administratղ\.swfinfo for writing, errno 0 (No error)

So I think there is an error in XBMC and their RTMP implementation regarding special chars in the username of the user. Perhaps you can make a debug XBMC logfile?
(2013-05-20, 12:28)Basje Wrote: [ -> ]
(2013-05-20, 11:28)antonstarlid Wrote: [ -> ]
(2013-05-19, 20:59)Basje Wrote: [ -> ]No problem playing this item here from Windows XBMC. I know they are implementing a new ffmpeg version into XBMC. Perhaps it is cause by that? You are using a nightly build of XBMC. So that could be the issue? Did you try a more recent XBMC build?

Have try whit fallowing versions

latest nightly build: "XBMCSetup-20130518-0da9a79-master.exe"
latest xbmc build: "xbmc-12.2.exe"
letest xbmc before that build: "xbmc-12.1.exe"
latest xbmc before that build: "xbmc-12.0.exe"

None of those are working for me

The log files are here

/ Slaktarn

I do see from your XBMC log this error:
Code:
11:24:07 T:9220   ERROR: RTMP_HashSWF: couldn't open C:\Users\Administratղ\.swfinfo for writing, errno 0 (No error)

So I think there is an error in XBMC and their RTMP implementation regarding special chars in the username of the user. Perhaps you can make a debug XBMC logfile?

Yes thats 100% correct, i have try whit a name whitout ÅÄÖ as we use in Sewden it works 100% correct was "Administratör"

Thx for help me debug this, Culd you report the bug? Im not really sure i know how to do it

/ Slaktarn
(2013-05-20, 21:59)antonstarlid Wrote: [ -> ]
(2013-05-20, 12:28)Basje Wrote: [ -> ]
(2013-05-20, 11:28)antonstarlid Wrote: [ -> ]Have try whit fallowing versions

latest nightly build: "XBMCSetup-20130518-0da9a79-master.exe"
latest xbmc build: "xbmc-12.2.exe"
letest xbmc before that build: "xbmc-12.1.exe"
latest xbmc before that build: "xbmc-12.0.exe"

None of those are working for me

The log files are here

/ Slaktarn

I do see from your XBMC log this error:
Code:
11:24:07 T:9220   ERROR: RTMP_HashSWF: couldn't open C:\Users\Administratղ\.swfinfo for writing, errno 0 (No error)

So I think there is an error in XBMC and their RTMP implementation regarding special chars in the username of the user. Perhaps you can make a debug XBMC logfile?

Yes thats 100% correct, i have try whit a name whitout ÅÄÖ as we use in Sweden it works 100% correct was "Administratör"

Thx for help me debug this, Culd you report the bug? Im not really sure i know how to do it

/ Slaktarn

I filed a bug report here: http://trac.xbmc.org/ticket/14348
Hi. This addon is great! Works great for me all the time. Or at least has done so since I started using it a long while ago.

However, lately (last few weeks?) the Apple Trailers part gives an error -- no videos were found for the selected item. I've noticed several other trailer addons having issues as well (installed to see if xot was broken), so I suppose Apple changed something again? Any chance of having it fixed? The rest of the streams I use (mainly svtplay) works perfectly though. I could get some logs I guess, but I'm pretty confident that the issues are not on my end. If needed, just say so.

Oh, I'm running xbmc 12.1 & xot 3.3.5.

Appreciate any input on this.
It could very well be that they changed some stuff. Could please raise an issue within the XOT issue tracker: http://code.google.com/p/xot-uzg/issues/list

We will try to fix it in the 3.3.6 version.
Uitzending gemist doest stream anymore since the last update. It only downloads the url. Channal like nickleodeon does stream normally. Is this a bug or just a workaround?
(2013-06-27, 00:10)jazzperm Wrote: [ -> ]Uitzending gemist doest stream anymore since the last update. It only downloads the url. Channal like nickleodeon does stream normally. Is this a bug or just a workaround?

It's a workaround for a bug in XBMC 12.1 & 12.2. It can be disabled via the XOT-Uzg.v3 addon settings by setting the cache duration to 0 days in the channel settings tab.
Hi,

first of all, thanks for this great add-on! I love it.

I'm using it for a couple of weeks now to watch 'het journaal' of the 'VRT De Redactie'.

But now, it only displays the episode of the day before. And when playing that episode, it ony lasts for +-2 minutes.

Do you have any idea what's wrong?

Thx!
Hey Basje,

I really like the xot plugin. Thanks for all your hard work! It's easily one of my favorite addons in xbmc. I use it for the NL channels all the time.

But unfortunatly i've got a couple of issues asswell:

- I'm trying to scrape the plugin to .strm files with xbmc.mylibrary. But i've noticed that the plugin URL's made by this program are to long, so xbmc gets confused with the strm files. If i place the same link in the favorites.xml it plays fine, but not in the .strm. Can something be done about this? Cause for something i'm working on i really need to scrape it to .strm files.

- When viewing a show in "SBS 6" the episodes name are: "Showname - ". That way it's not really clear (except the dates that are shown in some skins), which episode you're dealing with.

Other than those 2 problems, i'm loving this plugin! If it's at all possible, help is really appriciated Smile
(2013-11-13, 03:03)Sleuteltje Wrote: [ -> ]- I'm trying to scrape the plugin to .strm files with xbmc.mylibrary. But i've noticed that the plugin URL's made by this program are to long, so xbmc gets confused with the strm files. If i place the same link in the favorites.xml it plays fine, but not in the .strm. Can something be done about this? Cause for something i'm working on i really need to scrape it to .strm files.

The urls contain the complete item and meta data, that is why they are long. I tried it in multiple different ways but this was the only way of keeping it fast and performing.

(2013-11-13, 03:03)Sleuteltje Wrote: [ -> ]- When viewing a show in "SBS 6" the episodes name are: "Showname - ". That way it's not really clear (except the dates that are shown in some skins), which episode you're dealing with.
I also noticed this. If you create a bug report on the XOT-Uzg.v3 Google code page, I will see if I can fix it.
(2013-11-13, 15:01)Basje Wrote: [ -> ]The urls contain the complete item and meta data, that is why they are long. I tried it in multiple different ways but this was the only way of keeping it fast and performing.

That's a bummer. So there would be no way of having a .strm file that links to, let's say; a net 5 episode? Does XBMC require the extra meta data and such? I don't especially need perfect shownames for the .strm's, i only need to them to load the episode. I want to build "fake" sbs 6 tv channels and such with psuedotv live, but i need .strm files for that. (i use xbmc.mylibrary for scraping the .strm files from plugins)

I'm only a web programmer, so forgive me if i'm mistaken, but wouldn't it be possible to have a link like:
Code:
plugin://pluginname/channel=sbs6&show=showname&episode=episodename
.. and let the plugin then calculate this metadata and such? Or won't it keep performing fast then?

Or is it possible to let the plugin generate .strm files in a temp dir?

I'm just trying to think with you. I would love to help to code. I'm pretty good with javascript and php, but i've opened up your plugin and it looks like chinese to me. So i would definitly have to learn more about python & xbmc before i can be of serious help.

Oh, and i wondered if it would be possible to hide the video's in sbs6 that are below 5 minutes? Cause sbs6 got a lot of previews and commercials.


Basje Wrote:I also noticed this. If you create a bug report on the XOT-Uzg.v3 Google code page, I will see if I can fix it.

I've created the bug report Smile
(2013-11-15, 00:33)Sleuteltje Wrote: [ -> ]
(2013-11-13, 15:01)Basje Wrote: [ -> ]The urls contain the complete item and meta data, that is why they are long. I tried it in multiple different ways but this was the only way of keeping it fast and performing.

That's a bummer. So there would be no way of having a .strm file that links to, let's say; a net 5 episode? Does XBMC require the extra meta data and such? I don't especially need perfect shownames for the .strm's, i only need to them to load the episode. I want to build "fake" sbs 6 tv channels and such with psuedotv live, but i need .strm files for that. (i use xbmc.mylibrary for scraping the .strm files from plugins)

I'm only a web programmer, so forgive me if i'm mistaken, but wouldn't it be possible to have a link like:
Code:
plugin://pluginname/channel=sbs6&show=showname&episode=episodename
.. and let the plugin then calculate this metadata and such? Or won't it keep performing fast then?

Or is it possible to let the plugin generate .strm files in a temp dir?

I'm just trying to think with you. I would love to help to code. I'm pretty good with javascript and php, but i've opened up your plugin and it looks like chinese to me. So i would definitly have to learn more about python & xbmc before i can be of serious help.
The problem is that I need more than the channel, show and episode name.

I need an URL to open so I can get an stream from it. And the episode could actually have multiple videos and should be treated as a folder. In some cases I need meta data from the parent item, like a title or thumb.

I tried storing the meta data in files and just put an ID in the XOT-Uzg.v3 url, but that got very slow on devices like the ATV2 and rPi.

I even created an XBMC service that could store all the meta data in memory, but the overhead from sending and receiving the days was too large and it got a slower and too complex.

So at this point I am stuck with this solution, where I use the url to pass some sort of SessionState on to the next item.

But if there is somebody with a very smart idea to solve this, I am very willing to give it a try.
(2013-11-15, 00:49)Basje Wrote: [ -> ]The problem is that I need more than the channel, show and episode name.

I need an URL to open so I can get an stream from it. And the episode could actually have multiple videos and should be treated as a folder. In some cases I need meta data from the parent item, like a title or thumb.

I tried storing the meta data in files and just put an ID in the XOT-Uzg.v3 url, but that got very slow on devices like the ATV2 and rPi.

I even created an XBMC service that could store all the meta data in memory, but the overhead from sending and receiving the days was too large and it got a slower and too complex.

So at this point I am stuck with this solution, where I use the url to pass some sort of SessionState on to the next item.

But if there is somebody with a very smart idea to solve this, I am very willing to give it a try.

Okay, i think i get the limitations. Maybe this idea is flawed as well, but maybe the link can be:
Code:
plugin://pluginname/link=complete/path/as/in/plugin

That way maybe the plugin can follow the exact path as you would normally do with the remote (as in emulating the browsing with the remote)

Now i'm thinking of it, that would probably also be to slow, since it would "click" its way threw the plugin, which would ofcourse also can take a little while, especially on slower hardware. But hey, i'm justing putting the idea's out there, maybe it helps.


I guess there's also no way to have plugin links that long in a .strm file? Sad (while still being playable by xbmc ofcourse). Then i'm afraid i'll have to give up what i'm trying to do for now.


And i wondered if it would be possible to hide short video's like promo's and such?

Thanks for your quick responses Nerd!