Kodi Community Forum

Full Version: Energy Saving Settings
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Dear all,

I've got some questions in regards to power / energy saving settings due to rather strange behavior of my HTPC, now running on Windows 10 / Kodi 16.5 / Mediaportal TV Server (including Power Plugin):

1. When playing a movie, Youtube or alike with Kodi internal player / plugin, after reaching set time for inactivity the screen goes black.
Q: How can I stop this to happen?

2. Live TV is running forever with no inactivity timer to suspend after a certain time.
Q: Is there a setting to suspend Kodi / the computer with active Live TV after a certain time?

3. I've configured Kodi to be a) automatically started with windows and b) to start in Live TV (to increase WAF).
Q: After resuming - i.e. for a timed record - Kodi will not suspend any more (see Q2). Is there a way to configure that after waking up for a timed record, Kodi is sent to sleep automatically, preferrably showing a dialogue box which allows to interrupt switch to suspend manually?

Many thanks for your suggestions!

Flo
In settings>appearance>screen saver ensure 'none'

1) This must be in your windows config, Kodi plays on.

2) There is a shutdown timer, that has to be activated (skin settings) default is no.

3) Nothing in most skins pertain to this, although that wouldn't preclude a script or batch file.

Perhaps a request in Feature suggestions might being a better response.
Hi PatK,

many thanks for your suggestions.

(2016-01-16, 18:06)PatK Wrote: [ -> ]In settings>appearance>screen saver ensure 'none'

=> Done.

(2016-01-16, 18:06)PatK Wrote: [ -> ]1) This must be in your windows config, Kodi plays on.

=> Yes, there are respective energy saving settings active. But: Is there any way to configure that Windows doesn't assume playback of Video/Movie/Internet sources in Kodi as "inactivity" ? When watching Live-TV, screen saver doesn't become active, too - so, I'd assume there is a way that Kodi is able to influence windows power saving behaviour.

(2016-01-16, 18:06)PatK Wrote: [ -> ]2) There is a shutdown timer, that has to be activated (skin settings) default is no.

=> I don't find this setting in my skin settings (Aeon Nox 5, Confluence). Maybe this diappeared in 16.5?

(2016-01-16, 18:06)PatK Wrote: [ -> ]3) Nothing in most skins pertain to this, although that wouldn't preclude a script or batch file.
Perhaps a request in Feature suggestions might being a better response.

=> Yep, this would really be a desirable function...

Cheers,

Flo
Windows shouldn't assume inactivity on play back (To turn off a screen saver, in the Screen saver list, click (None), and then click OK.) but a work around might be a mouse jigglerif you use a mouse.

Look in settings>system>power savings [expert mode] for the shutdown timer.

http://forum.kodi.tv/forumdisplay.php?fid=9 for Feature Requests.
Hi PatK,

thanks, I've found the setting as described. For whatsoever reason, this does not suspend Live-TV. I've configured 5 minutes for the shutdown timer but Live TV is rumming now for >20 minutes... :-(
In regards to Internet TV, this now works well and does not suspend... Actually, I'm not really sure why. The only thing I've done was to visit energy settings of windows 10 but without really changing something...
Meanwhile, I came over another issue: Even though there was a timer active, the system didn't wake up to record. To be honest, I see that there are some still some shortcomings in the way how Kodi is dealing with suspend / power saving settings....

Cheers,

Flo
Quote:still some shortcomings in the way how Kodi is dealing with suspend / power saving settings....
I see these as windows shortcomings... but Kodi users are used to work-a-rounds, join the group.