Kodi Community Forum

Full Version: [SOLVED] DVB-T and DVB-S not working together
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

OK, I'm really having some hard time with this. I have a DVB-S2 and a DVB-T2 tuner. DVBSky S960 and MyGica T230.
Using the channels.conf with both DVB-S2 and DVB-T channels, only the DVB-S channels work, if I switch to DVB-T, I get No Data message.
If I use a channels.conf that only has the DVB-T channels, DVB-T is also working fine. This really drives me crazy.
DVB-S is working always, but DVB-T only when there is no DVB-S channels in channels.conf. Any ideas?

I followed the thread here to compile VDR and VNSI-server, everything should be fine.

@FernetMenta: I know you would need logs, but how can I provide some? Is there a command that I can get you all the VDR related logs?
If your are using systemd: journalctl -u vdr
OK, we managed to fix the issue. It turned out that it was not VDR or tuner related at all, but it was because TWO (2!) diplexers were of cheap quality (even if they were brands, not no name ones). We ruled out the error on the first diplexer when we replaced it with another tested item (I started with hw error trial before I wrote here). I got an advise from a professional sat guy to try an Alcad professional diplexer. As I was really desperate, I bought one and suddenly everything started to work!

So it was not at all related to VDR or kernel or any Ubuntu update.
good to hear. wasn't this thread longer? I think to remember I have replied to this topic.
Yes, i was glad too, after installing dozens of distros and compiling vdr over and overSmile I started with ruling out HW error, and I was so unlucky to have TWO faulty (or perhaps working, but of very low quality) diplexer units, so I assumed it was software related.

You are correct about the topic, but it was off site conversation, when you tried to help me (thanks for your efforts)!