Kodi Community Forum

Full Version: Question about an folder after Upgrade from 14 to 15
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello,

i upgraded my Kodi from 14.1 to 15.2. After the Upgrade also VNSI my Channelicons were gone. So i looked at the appropriate folder and see to the TV26.db is an new TV29.db added. I copied the TV26.db over the TV29.db and all icons are there now. But why is this, and what about to delete some unused files?

Folder in Kodi 14.1

Code:
-rw-r--r-- 1 xbmc ldapbenutzer  2342912  1. Feb 19:30 Addons16.db
drwxr-xr-x 2 xbmc ldapbenutzer     4096 14. Mär 2015  CDDB/
-rw-r--r-- 1 xbmc ldapbenutzer 37982208  2. Feb 16:44 Epg8.db
-rw-r--r-- 1 xbmc ldapbenutzer   192512 14. Mär 2015  MyMusic48.db
-rw-r--r-- 1 xbmc ldapbenutzer   450560 14. Mär 2015  MyVideos90.db
-rw-r--r-- 1 xbmc ldapbenutzer   233472  2. Feb 16:43 TV26.db
-rw-r--r-- 1 xbmc ldapbenutzer  4792320  2. Feb 14:25 Textures13.db
-rw-r--r-- 1 xbmc ldapbenutzer    28672  2. Feb 14:02 ViewModes6.db
Folder in Kodi 15.2

Code:
-rw-r--r-- 1 xbmc ldapbenutzer  2342912  1. Feb 19:30 Addons16.db
-rw-r--r-- 1 xbmc ldapbenutzer  2400256  2. Feb 21:41 Addons19.db
drwxr-xr-x 2 xbmc ldapbenutzer     4096 14. Mär 2015  CDDB/
-rw-r--r-- 1 xbmc ldapbenutzer 37982208  2. Feb 22:49 Epg10.db
-rw-r--r-- 1 xbmc ldapbenutzer 37982208  2. Feb 16:44 Epg8.db
-rw-r--r-- 1 xbmc ldapbenutzer   192512 14. Mär 2015  MyMusic48.db
-rw-r--r-- 1 xbmc ldapbenutzer   450560 14. Mär 2015  MyVideos90.db
-rw-r--r-- 1 xbmc ldapbenutzer   233472  2. Feb 16:43 TV26.db_bak
-rw-r--r-- 1 xbmc ldapbenutzer   233472  2. Feb 22:49 TV29.db
-rw-r--r-- 1 xbmc ldapbenutzer   233472  2. Feb 22:42 TV29.db_bak
-rw-r--r-- 1 xbmc ldapbenutzer  4890624  2. Feb 22:44 Textures13.db
-rw-r--r-- 1 xbmc ldapbenutzer    28672  2. Feb 14:02 ViewModes6.db

There some other things after an Upgrade what i must have to notice?

Thanks for infos
Best Regards
you broke the db by copying the old file... remove
Thanks for your reply, but to move back did not help:

18:06:30 T:140296229394496 ERROR: DBus: Error org.freedesktop.DBus.Error.InvalidArgs - No such property CanSuspend
18:06:30 T:140296229394496 ERROR: DBus: Error org.freedesktop.DBus.Error.InvalidArgs - No such property CanHibernate
18:06:31 T:140296229394496 ERROR: SQL: Abort due to constraint violation
18:06:31 T:140296229394496 ERROR: Exception updating database Epg10 from version 8 to 10
18:06:31 T:140296229394496 ERROR: Error updating database Epg10 from version 8 to 10
18:06:33 T:140296229394496 ERROR: SQL: Abort due to constraint violation
18:06:33 T:140296229394496 ERROR: Exception updating database Epg10 from version 8 to 10
18:06:33 T:140296229394496 ERROR: Error updating database Epg10 from version 8 to 10
18:06:33 T:140296229394496 ERROR: ExecuteAsync - Not executing non-existing script script.skin.info.service
18:06:34 T:140294368524032 ERROR: SQL: The database disk image is malformed
18:06:34 T:140294368524032 ERROR: ExecuteQuery - failed to execute query 'DELETE FROM epgtags WHERE iEndTime < 1454432794'
18:06:34 T:140294368524032 ERROR: SQL: Field not found: sOriginalTitle
18:06:34 T:140294368524032 ERROR: Get - couldn't load EPG data from the database
18:06:34 T:140294368524032 ERROR: SQL: Field not found: sOriginalTitle
18:06:34 T:140294368524032 ERROR: Get - couldn't load EPG data from the database
18:06:34 T:140294368524032 ERROR: SQL: Field not found: sOriginalTitle
18:06:35 T:140294368524032 ERROR: SQL: The database disk image is malformed
18:06:35 T:140294368524032 ERROR: ResultQuery - failed to execute query 'SELECT * FROM epgtags WHERE idEpg = 28;'
18:06:35 T:140294368524032 ERROR: SQL: The database disk image is malformed
18:06:35 T:140294368524032 ERROR: ResultQuery - failed to execute query 'SELECT * FROM epgtags WHERE idEpg = 29;'
18:06:35 T:140294368524032 ERROR: SQL: The database disk image is malformed
18:06:35 T:140294368524032 ERROR: ResultQuery - failed to execute query 'SELECT * FROM epgtags WHERE idEpg = 30;'
18:06:35 T:140294368524032 ERROR: SQL: Field not found: sOriginalTitle
18:06:35 T:140294368524032 ERROR: Get - couldn't load EPG data from the database


-rw-r--r-- 1 xbmc ldapbenutzer 2342912 1. Feb 19:30 Addons16.db
-rw-r--r-- 1 xbmc ldapbenutzer 2400256 3. Feb 17:56 Addons19.db
drwxr-xr-x 2 xbmc ldapbenutzer 4096 14. Mär 2015 CDDB/
-rw-r--r-- 1 xbmc ldapbenutzer 37982208 3. Feb 18:06 Epg10.db
-rw-r--r-- 1 xbmc ldapbenutzer 37982208 2. Feb 16:44 Epg8.db
-rw-r--r-- 1 xbmc ldapbenutzer 192512 14. Mär 2015 MyMusic48.db
-rw-r--r-- 1 xbmc ldapbenutzer 450560 14. Mär 2015 MyVideos90.db
-rw-r--r-- 1 xbmc ldapbenutzer 233472 3. Feb 18:06 TV29.db
-rw-r--r-- 1 xbmc ldapbenutzer 4902912 3. Feb 18:07 Textures13.db
-rw-r--r-- 1 xbmc ldapbenutzer 28672 2. Feb 14:02 ViewModes6.db
as said, its broken. Start with a clean user data folder or at least remove the db completely and rescan your library.
Ok, i've deleted the Databasefolder. And it works fine again. MSQLdatabase is ok now... Smile No importent Errors in the log.

Thanks for the help!