Kodi Community Forum

Full Version: Picture interrupts
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi everyone,

while watching TV (via Kodi (pvr.hts plugin)) I got picture interrupts.
Syslog tells me the following when an interrupt occurs:

Code:
Feb 11 13:44:58 kodi tvheadend[1969]: TS: Astra/10832.25H/RTL HD: H264 @ #255 Continuity counter error (total 1)
Feb 11 13:44:58 kodi tvheadend[1969]: TS: Astra/10832.25H/RTL HD: AC3 @ #259 Continuity counter error (total 1)
Feb 11 13:44:58 kodi tvheadend[1969]: TS: Astra/10832.25H/RTL HD: TELETEXT @ #32 Continuity counter error (total 1)
Feb 11 13:44:58 kodi tvheadend[1969]: descrambler: cannot decode packets for service "RTL HD"

Or again:

Quote:Feb 11 13:51:28 kodi tvheadend[1969]: TS: Astra/10832.25H/RTL HD: AC3 @ #259 Continuity counter error (total 4)
Feb 11 13:51:28 kodi tvheadend[1969]: TS: Astra/10832.25H/RTL HD: H264 @ #255 Continuity counter error (total 4)
Feb 11 13:51:28 kodi tvheadend[1969]: TS: Astra/10832.25H/RTL HD: TELETEXT @ #32 Continuity counter error (total 4)
Feb 11 13:51:28 kodi tvheadend[1969]: descrambler: cannot decode packets for service "RTL HD"

TVHeadend Version: 4.1-1491~g6c3d114
PVR.HTS Version: Don't exactly know (see thread: http://forum.kodi.tv/showthread.php?tid=259396)
Tuner: Digital Devices DVB-S2 (Dual Tuner PCI-E)

Last line looks like a problem with my descrambler(?) OScam!?

In Oscam I can't find any problems:

Quote:2016/02/11 13:51:22 3558BCEE c (newcamd) client connected to 31000 port
2016/02/11 13:51:22 3558BCEE c (client) anonymous disconnected from 127.0.0.1
2016/02/11 13:51:29 10A1D828 c (ecm) dvbapi ([email protected]/0641/EF10/98:xxxE79D9F037BA031BF4CC3EB0BE): found (2327 ms) by RASPBIAN
2016/02/11 13:51:36 10A1D828 c (ecm) dvbapi ([email protected]/0641/EF10/98:xxxD04512F4283EE2AE05C9077): found (251 ms) by RASPBIAN
2016/02/11 13:51:42 67546727 c (newcamd) client connected to 31005 port
2016/02/11 13:51:42 67546727 c (client) anonymous disconnected from 127.0.0.1

Can someone tell me what's causing this problem and how to fix this?
Yes, seems like a problem with the descrambler or tvheadend itself but it's not allowed to talk about this here...
Anyway I wouldn't use tvh 4.1.xy as it's still unstable software, use 4.08.
(2016-02-12, 17:17)glenn 1990 Wrote: [ -> ]Yes, seems like a problem with the descrambler or tvheadend itself but it's not allowed to talk about this here...
Anyway I wouldn't use tvh 4.1.xy as it's still unstable software, use 4.08.

Why wouldn't it be allowed to talk about this? Seems like he's running a local oscam, so no card sharing or other shady stuff?


Anyway, I would not suggest to use older versions. Tvheadend is usually pretty stable in the so-called unstable builds and bug fixes are done almost daily. Although you could of course try an older version to be sure, but I doubt it would solve the problem.
The oscam issue is a symptom of the continuity errors, not the other way around. Continuity errors are always due to reception issues or tuner problems. Since you have a DD tuner it's gotta me the dish or the cabling.

@willemd discussing software descrambling is not allowed, doesn't matter if you have a local card or not.