Kodi Community Forum

Full Version: TMDB Scraper unable to connect
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
For a couple of days at least, it seems the TMDB Scraper can no longer connect:

21:00:45 T:13480 ERROR: CCurlFile::Open failed with code 401 for http://api.tmdb.org/3/search/movie?api_k...anguage=en

If I open that URL in the browser, the error is the following
{"status_code":7,"status_message":"Invalid API key: You must be granted a valid key."}

I assume the API key included has expired. I have the same problem on Windows 10 and Raspberry Pi 2 (OSMC), so this seems like a really critical issue that possibly effects everyone, but I haven't found any info on this problem and this forum seems like the best place to report it.
check for addon updates
I actually decided to upgrade to Jarvis RC3, but on old one add-on updates also seems to fail:

21:00:45 T:13744 ERROR: CCurlFile::Open failed with code 0 for http://mirrors.kodi.tv/addons/isengard/addons.xml.md5
21:00:45 T:13744 ERROR: XFILE::CFileCache::Open - failed to open source <http://mirrors.kodi.tv/addons/isengard/addons.xml.md5>
21:00:45 T:13744 ERROR: Failed to fetch checksum for directory listing http://mirrors.kodi.tv/addons/isengard/addons.xml for repository repository.xbmc.org.
(2016-02-17, 21:48)Martijn Wrote: [ -> ]check for addon updates

Thanks, that did the trick for me.
I've been using version 2.7.2 of Universal Movie Scraper while there was 2.8 version in repository.
However I had to manualy force refresh of the official repository and then I could install updates.
TMDB add-on Update is grayed out for me. I guess it will show up or get pushed through soon?
It just auto updated. Works fine.
I have the same issue, during every Kodi Jarvis RC3 start I'm getting several "Unable to connect to remote server. Would you like to continue scanning?" notifications.
Complete Kodi log is here.

The TMDB plugin (1.8.3) and The Movie DB (3.8.8) both are up-to-date.


The error log shows this:
Quote:09:03:47 T:5180 ERROR: CCurlFile::FillBuffer - Failed: HTTP returned error 401
09:03:47 T:5180 ERROR: CCurlFile::Open failed with code 401 for http://api.tmdb.org/3/search/movie?api_k...anguage=en
09:03:47 T:5180 ERROR: ADDON::CScraper::Run: Unable to parse web site

When manually opening the URL in a browser, this is the response:
Quote:{"status_code":7,"status_message":"Invalid API key: You must be granted a valid key."}

Any hints are appreciated.
Quote:I have the same issue, during every Kodi Jarvis RC3 start I'm getting several "Unable to connect to remote server. Would you like to continue scanning?" notifications.
Complete Kodi log is here.

The TMDB plugin (1.8.3) and The Movie DB (3.8.8) both are up-to-date.


The error log shows this:
Quote:
09:03:47 T:5180 ERROR: CCurlFile::FillBuffer - Failed: HTTP returned error 401
09:03:47 T:5180 ERROR: CCurlFile::Open failed with code 401 for http://api.tmdb.org/3/search/movie?api_k...anguage=en
09:03:47 T:5180 ERROR: ADDON::CScraper::Run: Unable to parse web site

When manually opening the URL in a browser, this is the response:
Quote:
{"status_code":7,"status_message":"Invalid API key: You must be granted a valid key."}

Any hints are appreciated.

Installed the final 16.0 version earlier today and it seems to be fixed.
Using Isengard here and the scraper is still not connecting. I'm getting the same errors as others posted. I have version 3.9.0 of the addon.