Kodi Community Forum

Full Version: Scheduled repeat recording (guide based) missing on completion (v4.0.8)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi All,
I'm currently evaluating tvheadend as a replacement DVR. I'm currently having a strange issue with Guide Based Repeat Recordings.

Issue:
Schedule a repeat recording (guide based).
Entries appears in the list of future recordings, and the show will record on each schedule.
The problem is once each recording has finished, it is not put into the completed recordings list and does not appear in the "Recordings" in Kodi. The actual recording file IS on the file system.
Interestingly, if I manually start a one off recording from the guide, that does appear in the completed recording list and also appears in the "Recording" section in Kodi.

I have scanned the files in the ~/.hts folder, but can not find any entry that contains information about the completed recording, only about future recordings.

OS: Linux Mint 17.3
TVheadend: 4.0.8
Kodi: 16

Any suggestions as to a fix for this?

Thanks
I have almost the same setup (tvh version , Kodi version) and no problems with series recordings.

How do things look in the tvheadend webif? Do the recordings in question appear there? If yes, which tab (failed recordings, ...)?
You already have the answer to my question with your post. ;-)

If the finished recordings do not show up in tvheadend webif, this is a tvheadend, not a Kodi problem. Sorry, no idea what's wrong with your tvheadend setup.
Thanks for the advice. No, they don't appear in the webif, not in failed or complete. I agree that this is a tvheadend issue and not a kodi one. I've raised the issue in the tvheadend forum, but if anyone here knows how to solve this, I would appreciate the help.
Hi ksooooooo, what Linux Dist and version are you using. I might just switch to that and give it a try.
I'm using OpenELEC, running both Kodi and tvheadend on the same machine.
By any chance, have you set "forever" as default lifetime value in the add-on's timer settings tab? If so, does changing this to some concrete value fix your problem?

I fear "forever" as lifetime default in combination with tvh 4.0.x is buggy. Will have to debug this, though.

Please don't forget to restart Kodi (not just the add-on, which will happen automatically) after changing the add-on setting. This is important.
Thanks for the suggestion. I'll give it a go. I've just switched over to lubuntu 15.10 to see if this has the same issue. Even if it doesn't, I'll go back to mint and try your suggestion. I might even get the source and see if I can work out what is causing the problem.
ksoooo, thank you for the suggestion. Looks like the "forever" lifetime is the issue. I tried 2 recordings on lubuntu, one with forever and one with 3 years. 3 years worked, forever did not. Now to try it on mint. Will post results.
Thanks for checking. I don't think that the distro will make a difference. This is either a Kodi, pvr.hts add-on or tvheadend issue. I tend to say that it's an issue with the add-on, will test later today.
Confirming it is not an issue with the distro. The problem does appear to be setting the repeat duration to forever. This actually sets the value to 2147483647 in the tvh schedule. Setting it to approx 30 years (10960) is okay, but 300 years (109600) the issue occurs.
Debugged this yesterday. It is a bug in tvheadend 4.0.x. 4.1 should work, though.

https://github.com/kodi-pvr/pvr.hts/issues/201

EDIT: setting the value to 2^31 is intended, btw. This means "forever". ;-)
Thanks for all the help. BTW I'm running the test system on a 32-bit os and tvh. Let me know if you want me test anything, I'm going to leave this system setup for testing purposes.