Kodi Community Forum

Full Version: Controller issues
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I've been trying to read all the documentation but I can't get things to work.

My setup:
Rpi2 with your last test build 2/17/2016
8bitdo snes30 Pro.

At the beginning I was having troubles trying to set the controller up because the d-pad didn't work.
Now I managed to fix it, the controller passes the set up
And all the keys, included the d-pad are mapped.

So I finally decided to start a game, but the controller doesn't work.
I load a random game through the internet archive addon, I pick the emulator, the game starts but no input from controller.
Any suggestion?
debug log please

After reboot the RPI I run the controller wizard and uploaded the log.

If you look at line 964 it seems that the d-pad events have been removed due to a conflict.
Is that the reason why I can't start any mame game (through left-right combination)?
Monday is my last available day to return the joystick.
Can anybody suggests me a controller that works out of the box?
turn the controller on with joystick mode.. hold start + right bumper. If u just hold the start button the dpad emulates a keyboard press.
If you can configure the controller inside Kodi and you can use the controller to navigate Kodi the controller is working fine. If you can't control a game that's a problem with RetroPlayer. I've had this with several builds as well.
At the beginning I was having trouble setting up the controller because the wizard didn't recognize the d-pad press.
So I figure out that holding start+right bumper was the only option to pair the controller as joystick.

I went to the wizard and finally it recognized the D-pad press (up down left right).

To answer your question Montellese:
After I finished to configure the controller I'm still not able to navigate through kodi. No button works at all.
So it shouldn't be a problem of retroplayer.

I also have a wireless keyboard attached to the RPI, is that the cause of conflict? I'll try later without the keyboard, maybe using Yatze and see if I can at least configure the controller to navigate through kodi
Which platforms did you configure the controller for? You need to configure the "Kodi" platform to be able to use the controller to navigate Kodi. And you need to configure the specific game platform to be able to use the controller in a specific game platform.
I'm so dumb.
I configured the controller on Kodi (the first of the list on the wizard) and I can finally use the controller on Kodi.

I tried to open a mame game and finally the game starts
With the left-right combination, although I don't know how to put coins.

So you're saying I'm supposed to configure the controller for each emulator through the wizard?
I thought I was supposed to do it only on SNES because that's what the controller looks like.
Which one is Mame?
It might be that there's no platform controller configuration for MAME yet because it's one of the more complex/flexible ones.

Every controller can be configured for multiple platforms so you have all the possibilities.
With your help over been able to configure everything.
The problem now is that I'm having audio issue playing mame games. The audio is choppy.
I've read that I'm supposed to overclock the PI?
Do you have any other suggestions?
Thanks for your time everybody
RetroPlayer isn't perfect yet. As an example depending on which SNES you get very different audio quality. So I'm not sure if the issue is the performance of the pi. But I never tried MAME so I don't really know.