Kodi Community Forum

Full Version: TMDB not scrapping properly
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
So I rebuilt my HTPC and started everything with a fresh install and started all scrapping from scratch and it appears that TMDB addon isn't scrapping properly and is getting the wrong info for random movies. I have multiple computers with Kodi installs, if I go to one that has the correct info and do a refresh on the movie it then comes up with the wrong info just like my HTPC. So far these are the movies I have noticed to be affected A Man Apart, A thousand words, Three Amigos.
TMDB scraper grabbed everything but fan art for me today. I added it manually for the few movies I added. I guess there'll be an update soon?
I confirm TMDB scrapper suddenly stopped working well.

Scrapper configured to grab spanish information.

Grabs all Spanish info, except of the Poster, which grabs the english version. I've double checked that all these movies do have spanish cover on tmdb.
I've debugged it a bit and it seems like there's an extra space and ; inside the urls which falls back to en poster.

Code:
15:47:44 T:1548   DEBUG: scraper: GetTMDBGenresByIdChain returned <details><url function="ParseTMDBGenres" cache="tmdb-he-9806.json">http://api.tmdb.org/3/movie/9806?api_key=XXXX&amp;language=he</url></details>
15:47:44 T:1548   DEBUG: scraper: ParseTMDBGenres returned <details><genre>הרפתקאות</genre><genre>משפחה</genre><genre>אנימציה</genre><genre>אקשן</genre></details>
15:47:44 T:1548   DEBUG: scraper: GetTMDBThumbsByIdChain returned <details><url function="ParseTMDBBaseImageURL" cache="tmdb-config.json">http://api.tmdb.org/3/configuration?api_key=XXXX</url><url function="ParseTMDBThumbs" cache="tmdb-images-he-9806.json">http://api.tmdb.org/3/movie/9806/images?api_key=XXXX&amp;language=he</url></details>
15:47:44 T:1548   DEBUG: scraper: ParseTMDBBaseImageURL returned <details>http://image.tmdb.org/t/p/</details>
15:47:44 T:1548   DEBUG: CurlFile::Open(0B8C34A0) http://api.tmdb.org/3/movie/9806/images?api_key=XXXX&language=he
15:47:44 T:1548   DEBUG: CScraperUrl::Get: Using "UTF-8" charset for "http://api.tmdb.org/3/movie/9806/images?api_key=XXXX&language=he"
I checked today and refreshed two of the movies that had issue and they appeared to update properly. Not sure if anything has been changed.
Same here, but TMDB plugin is still 3.9.0
Back to normal here too.
(2016-03-10, 21:03)dreamcrawler Wrote: [ -> ]I confirm TMDB scrapper suddenly stopped working well.

Scrapper configured to grab spanish information.

Grabs all Spanish info, except of the Poster, which grabs the english version. I've double checked that all these movies do have spanish cover on tmdb.
I tried again. Still grabs the english poster. But!

The change I noticed is that now the spanish poster appears in the complete poster list (if you hit the change poster button), but still you have to swap it: When it worked well, it would set spanish poster by default.
I have the same problem.
Everthying on SV (Swedish)
Some poster will be Swedish, some English and most of them are in German.