Kodi Community Forum

Full Version: hls not processing audio
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
video-1 starts playing well , but audio woun't play at all.
if i look index file there are two TYPE=AUDIO files:
is EXT-X-VERSION:4 supported on kodi,ffmpeg likje this?

#EXTM3U
#EXT-X-VERSION:4
#EXT-X-MEDIA:TYPE=AUDIO,GROUP-ID="audio",LANGUAGE="ru",NAME="rus",AUTOSELECT=YES,DEFAULT=NO,URI="audio-rus.m3u8"
#EXT-X-MEDIA:TYPE=AUDIO,GROUP-ID="audio",LANGUAGE="ee",NAME="est",AUTOSELECT=YES,DEFAULT=NO,URI="audio-est.m3u8"
#EXT-X-STREAM-INFTongueROGRAM-ID=1,BANDWIDTH=1800000,RESOLUTION=720x576,AUDIO="audio"
video-1.m3u8
#EXT-X-STREAM-INFTongueROGRAM-ID=1,BANDWIDTH=800000,RESOLUTION=640x360,AUDIO="audio"
video-2.m3u8
#EXT-X-STREAM-INFTongueROGRAM-ID=1,BANDWIDTH=300000,RESOLUTION=320x240,AUDIO="audio"
video-3.m3u8



on windows ffplay 3.0 i get probeing audio and video normally without errors
on 2.8 i get cliping sound buffering

my hls files:
http://pastebin.com/RczKR0zD
anybody..?
I just discovered the same thing. I have tried with the latest Krypton build from git, but unfortunately this is still an issue. It plays just fine in ffmpeg.

Sample HLS manifest:

Code:
#EXTM3U
#EXT-X-VERSION:4
#EXT-X-MEDIA:TYPE=AUDIO,GROUP-ID="primary",LANGUAGE="swe",NAME="Standard",AUTOSELECT=YES,DEFAULT=YES,URI="http://i.akamaihd.net/hls/live/222457/z/playlist128k.m3u8"
#EXT-X-MEDIA:TYPE=AUDIO,GROUP-ID="backup",LANGUAGE="swe",NAME="Standard",AUTOSELECT=YES,DEFAULT=NO,URI="http://i.akamaihd.net/hls/live/222457-b/z/playlist128k.m3u8"

#EXT-X-STREAM-INF:BANDWIDTH=690800,AVERAGE-BANDWIDTH=690800,CODECS="avc1.4d4015,mp4a.40.2",RESOLUTION=480x270,FRAME-RATE=25,AUDIO="primary",CLOSED-CAPTIONS=NONE
http://i.akamaihd.net/hls/live/222457/z/playlist500k.m3u8
#EXT-X-STREAM-INF:BANDWIDTH=690800,AVERAGE-BANDWIDTH=690800,CODECS="avc1.4d4015,mp4a.40.2",RESOLUTION=480x270,FRAME-RATE=25,AUDIO="backup",CLOSED-CAPTIONS=NONE
http://i.akamaihd.net/hls/live/222457-b/z/playlist500k.m3u8
look like it takes forever when developers can handle it
Here is a open ticket also http://trac.kodi.tv/ticket/16670 but unfortunately nothing has been done for 3 months.
Yeah, cause no one is currently intersted in fixing it. Other things have higher priority.