Kodi Community Forum

Full Version: Kodi with VNSI Plugin keeps VDR-Server awake
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

I use a Debian Server with VDR and vdr-plugin-vnsiserver.
The VDR Server is configured to power on when a recording is scheduled and to power off after the recording.
All works fine when the Raspberry 3 is off.

The latest OSMC / Kodi is installed on a Raspi 3.
When the Raspberry 3 is on (it is supposed to be always on) it keeps the VDR Server awake after the recording.
I can see many lines like this in the Debian Logs: "VNSI: Trigger EPG update for channel...."

Any idea how to solve it?

Is there a user-inactivity time out possible after which the VNSI PVR addon terminates the connection to the VDR-VNSI plugin?

Or is it possible to detect if the TV is switched off? Maybe by CEC? And then terminate the VNSI PVR addon.
So one could restart it when the TV is on again.

Shutting down VDR as long as there are clients connected does not make sense. The server don't know about the actions taking place on the client. Assume you browse EPG the the server shuts down. This should not happen.

Kodi does not have any user-inactivity timeout that is exposed to PVR addons. I don't know about capabilities of CEC.

I don't want to shutdown VDR as long as clients are connected.

It would be perfect if KODI could react on a CEC Message (TV goes to standby) and terminates the PVR Plugin.
After a while with out no VNSI communication VDR goes to standby.

In the Moment I have these two lines in my Keymap:


So I can manually Start / Stop the PVR Manager.
And after a while VDR goes to sleep.

Works perfect besides one need to manually press F12 or F11 - and must not forget to do it Wink

Would be a nice "woman-acceptance-factor" if this would be triggered by CEC messages from the TV going on or in standby mode.
VNSI could also wake VDR when TV is switched back on.


After recent changes start/stop PVRManager is history. PVR addons were aligned with the addon system. You need to disable/enable the addon instead.