Kodi Community Forum

Full Version: LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
(2016-04-26, 23:10)Kiralina Wrote: [ -> ]Here it is: http://xbmclogs.com/pquz55osi

Same behavior with #0423 and #0424

Thank you.

So quasar works with #0420 but not #0423 or #0424. Strange. The only obvious change in #0423 is the libressl change, possibly connman 1.32, but the quasar query isn't https, at least not to the local trakt server.

Quasar does however appear to be crashing due to an invalid/unexpected response from the local trakt server - maybe trakt is having a problem authenticating remotely? I think you need to get the log from the trakt server (if there is such a log), or speak with a trakt/quasar developer (pinging @Razze for trakt).
(2016-04-26, 21:52)Milhouse Wrote: [ -> ]
(2016-04-26, 21:31)Bor_NL Wrote: [ -> ]Is it usefull to install this build to sort out the hifiberry digi+ problems ?

The debug-enabled build won't include any change with respect to Hifiberry.

Thanks for the heads up !

I hope this issue will be solved in upcoming builds
Looks like dtoverlays for any of my soundcards (hifiberry-dacplus, hifiberry-digi, iqaudio-dacplus, rpi-dac) are not being loaded starting with #423 (all OK with #420 and earlier), so no ALSA audio options. Others here have noted this problem for hifiberry, but I believe the problem applies to other devices too.

Let me know what details you need if you wish to investigate this further,
(2016-04-26, 23:51)beertank Wrote: [ -> ]Let me know what details you need if you wish to investigate this further,

Same as for hifiberry: 2320060 (post)
hi there! Is there any news about Devupdate addon in order to support LibreElec? Is so much easier to all.
Thanks!
(2016-04-27, 00:12)sdfguerreiro Wrote: [ -> ]hi there! Is there any news about Devupdate addon in order to support LibreElec? Is so much easier to all.
Thanks!

Unfortunately I've not heard from Leopold for a few weeks, hopefully he's just on holiday or doing something more interesting with his life. Smile

I just added a post in reply to a fork of the addon, which you might want to use as an alternative to Leopolds incompatible version:

2321577 (post)

I'm assuming the forked version works - I haven't tested it - although from the changes it might be a little incomplete - ie. no changelog support - but may be updated (I'm familiar with miigotu's work on other projects and would trust him to keep it updated). However if it doesn't work, contact the author.
(2016-04-26, 20:14)MikeKL Wrote: [ -> ]Hmm perhaps spoke to soon, during reboot to load latest splash screen (Looking great :Wink ) appear to be having similar symptoms/problem (mentioned here?) with multi kodi crashes and kodi restarts before a clean start of kodi

Kodi.crashlog
kodi.log (after clean start)

Once everything up and running kodi stable (Note build #0424 installed on top of a clean LibreElec beta 2 updated to #0423 before #0424)

Debug-enabled build #0426x: RPi2

Please upload a new crashlog, thanks - with luck it will provide a clue to a PVR or core developer as PVR addons shouldn't crash Kodi.
(2016-04-26, 23:45)Milhouse Wrote: [ -> ]
(2016-04-26, 23:10)Kiralina Wrote: [ -> ]Here it is: http://xbmclogs.com/pquz55osi

Same behavior with #0423 and #0424

Thank you.

So quasar works with #0420 but not #0423 or #0424. Strange. The only obvious change in #0423 is the libressl change, possibly connman 1.32, but the quasar query isn't https, at least not to the local trakt server.

Quasar does however appear to be crashing due to an invalid/unexpected response from the local trakt server - maybe trakt is having a problem authenticating remotely? I think you need to get the log from the trakt server (if there is such a log), or speak with a trakt/quasar developer (pinging @Razze for trakt).

No, what I meant is that Quasar works in the same way in #0420, #0423 and #0424. This means it works fine, all apart from trakt integration. I'm using build #0420 because of the hifiberry kernel related problem, but I also tested with #0423 and 0424 and it's all the same. This Quasar trakt integration problem appears only in LE Krypton builds. It works fine in OE 6.95.2 and OE Krypton builds. I have 3 microsd cards with different builds on them and I tested with them all. If it would help I could provide logs from OE 6.95.2 and one of your OE Krypton builds as well. Didn't get the chance to try it with the Jarvis LE.
(2016-04-26, 23:45)Milhouse Wrote: [ -> ]
(2016-04-26, 23:10)Kiralina Wrote: [ -> ]Here it is: http://xbmclogs.com/pquz55osi

Same behavior with #0423 and #0424

Thank you.

So quasar works with #0420 but not #0423 or #0424. Strange. The only obvious change in #0423 is the libressl change, possibly connman 1.32, but the quasar query isn't https, at least not to the local trakt server.

Quasar does however appear to be crashing due to an invalid/unexpected response from the local trakt server - maybe trakt is having a problem authenticating remotely? I think you need to get the log from the trakt server (if there is such a log), or speak with a trakt/quasar developer (pinging @Razze for trakt).

Sorry for my intrusion.

#0424 Libreelec
Quasar OK
Trakt ERROR
http://xbmclogs.com/pqkd9fwd4

#0415 Openelec
Quasar OK
Trakt OK
http://xbmclogs.com/pjzpgcfsl


Both tested right now.

EDIT:
I just remembered now ... In Openelec the first time I start Trakt, opened a window with a number to be validated on their website.
This window with a number, never opened in Libreelec.
(2016-04-27, 01:17)Kiralina Wrote: [ -> ]This Quasar trakt integration problem appears only in LE Krypton builds. It works fine in OE 6.95.2 and OE Krypton builds.

(2016-04-27, 02:06)Alexander Wrote: [ -> ]Sorry for my intrusion.

#0424 Libreelec
Quasar OK
Trakt ERROR
http://xbmclogs.com/pqkd9fwd4

#0415 Openelec
Quasar OK
Trakt OK
http://xbmclogs.com/pjzpgcfsl


Both tested right now.

EDIT:
I just remembered now ... In Openelec the first time I start Trakt, opened a window with a number to be validated on their website.
This window with a number, never opened in Libreelec.

OK, thanks both.

So #0415 OE has working Trakt. It sounds like #0416 LE does not have working Trakt.

Can you try the previous LE build (this was never officially "published"), #0414 LE RPi2 and let me know if Trakt is working or not? If it is working in #0414 LE but not #0416 LE, then that narrows down when the break happened (ie. in #0416 LE).

My suspicion is that PR9621 in #0416 LE is likely to be causing a problem for Trakt. Or Quasar.
Milhouse, I added a new information in my post #204:
- The first time I installed quasar/trakt in OE appeared a window with a code to be authenticated in trakt website.
- The first time I installed quasar/trakt in LE did not show this window with the activation code.

WORKING Trakt, the file:
/.kodi/userdata/addon_data/plugin.video.quasar/settings.xml

have this lines:
<setting id="trakt_refresh_token" value="59b6d846a6bf7b1dd1b3ff1a996772b5b82abee7f8a48586c47592cd692e5f93" />
<setting id="trakt_token" value="bd4bddd541bc5114efb668fc124318c2c43689629efeaa2982b79587dd349fa7" />


NOT WORKING Trakt, the file:
/.kodi/userdata/addon_data/plugin.video.quasar/settings.xml

have this lines:
<setting id="trakt_refresh_token" value="" />
<setting id="trakt_token" value="" />
(2016-04-27, 02:37)Milhouse Wrote: [ -> ]OK, thanks both.

So #0415 OE has working Trakt. It sounds like #0416 LE does not have working Trakt.

Can you try the previous LE build (this was never officially "published"), #0414 LE RPi2 and let me know if Trakt is working or not? If it is working in #0414 LE but not #0416 LE, then that narrows down when the break happened (ie. in #0416 LE).

My suspicion is that PR9621 in #0416 LE is likely to be causing a problem for Trakt. Or Quasar.

All the same (not work Trakt) with downgrade LE #0424 with LE #0414, send by you.
I will create a new clean installation (LE #0414) and report soon.

Obs.: I copy the working quasar/trakt "settings.xml" over the NOT working "settings.xml". Reboot and the errors is gone, no more "Navigation error: HTTPError()" popup. All windows open without this popup errors, but no itens inside windows.
(2016-04-27, 02:37)Milhouse Wrote: [ -> ]OK, thanks both.

So #0415 OE has working Trakt. It sounds like #0416 LE does not have working Trakt.

Can you try the previous LE build (this was never officially "published"), #0414 LE RPi2 and let me know if Trakt is working or not? If it is working in #0414 LE but not #0416 LE, then that narrows down when the break happened (ie. in #0416 LE).

My suspicion is that PR9621 in #0416 LE is likely to be causing a problem for Trakt. Or Quasar.

OE #0415 Trakt OK
updated with LE #0414 Trakt ERROR

http://xbmclogs.com/pvtsevwi9
Hmmmm....
Hi,

Has anyone else noticed issues with DTS soundtracks with 0424 that don't exist with 0420? All my media plays perfectly with 0420, but if I switch to 0424 then DTS soundtracks get a screechy edge to what I presume would be the center channel (ie the voices) - the left/right channels seem to be ok. I'm making assumptions about the channels as I'm playing through stereo speakers Smile

None of the normal audio options make the slightest difference.

I've reverted back to 0420 for now (as I wanted to watch something Smile ) but could rollforward again and grab debug logs, although as it's audio only I'm not entirely sure if they'll show anything. I notice that 0423/0424 include a new kernel - could that be a cause and or were there additional VideoPlayer / ffmpeg updates in those two that might be the cause?

Chris