Kodi Community Forum

Full Version: LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Now the bug is unstable. Sometimes goes well, sometimes freezes. You're on the right way Smile
I found out the cause of the errors. I had received a new wifi stick that I plugged in before launching the new builds. I guess it's not supported yet.
When I plugged in the official white pi wifi stick, builds 915 and 916 work perfectly.
Build 917 is really broken. There is a huge rainbow square on the screen in the middle (rainbow screen of death) and freezes solid. This is right after powering the device on. (Pi Zero).
(2016-09-18, 01:56)smp1 Wrote: [ -> ]I get crashes with this file, 100% reproducible - https://www.dropbox.com/s/d2f4ldng0mksqz...i.mpg?dl=1

Crash log: http://sprunge.us/OXNR

To reproduce: play it to the end, Kodi will crash and reboot at the end of the video. The crash does not occur if deinterlacing is disabled.

No crash for me.Build #917 (resolution DESKTOP)

Tested again with resolution 1920x1080p 60 and it crashed...
Also no gui sounds when changing resolutions for about 20 sec.
Been running 0916 for 28 hours straight, no freezes, no crashes, just nice stable use.
Thanks for your hardwork, its awesome.

I also tried that smp1 video above with no crash either.. Desktop screen resolution...
Tried omx 1920x1080p, with deinterlace on and off, with no crash.
I Switch to mmal, deinterlace on and it crashes. So much for 28hrs Big Grin

I do like the womans voice on the video, will have to check her stuff out.. ?

Regards bm

Crashlog : Crashlog
I have problem to set my advanced settings for cache.
I know that the syntax has changed.
My settings are memorysize 0, buffermode 0 and readfactor 15.
I have a 10 Mbit upload line. When I start a movie with great bitrate I see that my upload isn't max out all the time and when I pause the movie the upload stalls. That result in shutter playback. How can I archive a maxed upload when I play a movie? I have last version installed and the connection is over FTP. Every help is welcome!
(2016-09-18, 06:49)*Spider* Wrote: [ -> ]Build 917 is really broken. There is a huge rainbow square on the screen in the middle (rainbow screen of death) and freezes solid. This is right after powering the device on. (Pi Zero).

Is this with or without the "new" WiFi stick? What wifi stick is this? There's nothing kernel related in #0917, check you've updated the SD card correctly.
(2016-09-18, 15:49)bg_x Wrote: [ -> ]I have problem to set my advanced settings for cache.
I know that the syntax has changed.
My settings are memorysize 0, buffermode 0 and readfactor 15.
I have a 10 Mbit upload line. When I start a movie with great bitrate I see that my upload isn't max out all the time and when I pause the movie the upload stalls. That result in shutter playback. How can I archive a maxed upload when I play a movie? I have last version installed and the connection is over FTP. Every help is welcome!

Upload your debug log.
(2016-09-18, 15:49)bg_x Wrote: [ -> ]I have problem to set my advanced settings for cache.
I know that the syntax has changed.
My settings are memorysize 0, buffermode 0 and readfactor 15.
I have a 10 Mbit upload line. When I start a movie with great bitrate I see that my upload isn't max out all the time and when I pause the movie the upload stalls. That result in shutter playback. How can I archive a maxed upload when I play a movie? I have last version installed and the connection is over FTP. Every help is welcome!
Memorysize set to 0 so buffer cache select SD to write with low speed, not compatible with read factor 15.
My suggestion is set memorysize to other value and decrease read factor, ex
<cachemembuffersize>104857600</cachemembuffersize>
<readbufferfactor>5.0</readbufferfactor>
@TVPL ok will try and report back.
(2016-09-18, 16:55)Milhouse Wrote: [ -> ]
(2016-09-18, 06:49)*Spider* Wrote: [ -> ]Build 917 is really broken. There is a huge rainbow square on the screen in the middle (rainbow screen of death) and freezes solid. This is right after powering the device on. (Pi Zero).

Is this with or without the "new" WiFi stick? What wifi stick is this? There's nothing kernel related in #0917, check you've updated the SD card correctly.
This was without the new wifi stick which is a Realtek RTL8192EU. This stick still gives the errors that I provided the links for yesterday.

Did you just change the Kernel file in #917? I just re-downloaded that build and now it boots without the big rainbow square and the supported white pi wifi stick.

Could you add the RTL8192EU drivers to these builds? It still locks up with #917 and the debug screen info.
Thanks
(2016-09-18, 18:33)*Spider* Wrote: [ -> ]Did you just change the Kernel file in #917? I just re-downloaded that build and now it boots without the big rainbow square and the supported white pi wifi stick.

No, nothing has changed.

(2016-09-18, 18:33)*Spider* Wrote: [ -> ]Could you add the RTL8192EU drivers to these builds? It still locks up with #917 and the debug screen info.
Thanks

RTL8192EU is already included (always has been). I'm not sure why this driver would now cause problems since #0902, although there are some kernel and firmware changes in #0902 which is why I asked you to test the kernel from #0902 with #0901 firmware.
@Milhouse, tvpl I think I found the culpit. I have the setting pathsupstitute from nfs to ftp in my advancedsettings.xml. That seems to break the buffer on <buffermode>0</buffermode>.

After set the <buffermode>1</buffermode> the cache fills and it seems to work like it should.

I think with pathsupstitute Kodi is confusing and don't see the input as internetsource.

Thx for help!

And milhouse keep up the good work.
I have a reproducable freeze upon boot, after init of PVR Manager (DVBViewer Client). I have to remove power to restart.

However no crashlog at /storage/.kodi/temp/. Is there any other location where it could be located?
(2016-09-18, 20:53)jobisoft Wrote: [ -> ]I have a reproducable freeze upon boot, after init of PVR Manager (DVBViewer Client). I have to remove power to restart.

However no crashlog at /storage/.kodi/temp/. Is there any other location where it could be located?

You mean you can't connect with ssh? Check journalctl.
ssh is still possible after the freeze, but no crashlog is written. journalctl is not showing anything interesting. hm. is there anything else? It is build 916 by the way... I will check older and later builds tonight, but a usefull log would be helpful...