Kodi Community Forum

Full Version: LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
#1127 - looping on booting ) After libreelec animated logo goes black screen, then again animated logo. and so on.
(2016-11-28, 02:17)Hoopla Wrote: [ -> ]I am not sure that this has been discussed, but the interface seems to be sluggish when switching out of videos. It takes a few seconds to load the thumbnails interface (it used to be immediate in openelec). I am using a raspberry pi 3 so hardware speed shouldn't be an issue.

Looks like it started in#0906

Ah, you are using an add-on I assume? Likely to be PR10394.
Unfortunately that was a deliberate change that will hurt add-on performance.
(2016-11-28, 21:08)popcornmix Wrote: [ -> ]
(2016-11-28, 02:17)Hoopla Wrote: [ -> ]I am not sure that this has been discussed, but the interface seems to be sluggish when switching out of videos. It takes a few seconds to load the thumbnails interface (it used to be immediate in openelec). I am using a raspberry pi 3 so hardware speed shouldn't be an issue.

Looks like it started in#0906

Ah, you are using an add-on I assume? Likely to be PR10394.
Unfortunately that was a deliberate change that will hurt add-on performance.

Yeah, the YouTube addon suffer from this a lot.
So why was caching disabled? Will it be enabled again?
(2016-11-28, 21:01)herrmeier01 Wrote: [ -> ]@Milhouse do you have plans to publish a ..x build again with the 4.9rc6 kernel? I had very good experience with it. I'm not sure but my feeling was that this build was a little bit smoother than the build with the 4.8 kernel.
I'm able to copy just the kernel.img file over the latest build but I'm not sure if some dependencies will make problems.

I'll upload a 4.9-rc7 build later tonight.
(2016-11-28, 21:03)znemo Wrote: [ -> ]#1127 - looping on booting ) After libreelec animated logo goes black screen, then again animated logo. and so on.
What build were you using previously?

Can you run (with #1127):
Code:
journalctl -a | pastebinit
cat /storage/.kodi/temp/kodi.log | pastebinit
cat /storage/.kodi/temp/kodi.old.log | pastebinit
paste $(ls -1art /storage/.kodi/temp/kodi_crashlog* | tail -1)
And paste the output.
Just for my information, what's the max. temp the RPi3 will run at? Is 76C healthy?

Thanks
(2016-11-29, 00:15)rudrood Wrote: [ -> ]Just for my information, what's the max. temp the RPi3 will run at? Is 76C healthy?

Thanks

The RPi3 will throttle the CPU at 80C, and at 85C it will reduce voltage/frequency to minimum.

76C isn't a problem, but lower is better. A small heatsink or FLIRC case should pretty much eliminate the risk of overheating.
New LibreELEC.tv Krypton build #1128: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.8.11 #1 Mon Nov 28 21:06:01 GMT 2016 armv6l GNU/Linux

# vcgencmd version
Nov 26 2016 13:28:47
Copyright (c) 2012 Broadcom
version 6f567a4db96231f764d5a9a5b11b153009d13d5b (clean) (release)

# lsb_release
LibreELEC (Milhouse) - Version: devel-20161128210447-#1128-g4d4fe5d [Build #1128]

# Kodi version
(17.0-BETA6 Git:17.0-beta5-e92818a). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (4d4fe5db, changelog) and tip of XBMC master (c5d944c1, changelog) with the following modifications: Build Highlights:
  1. New Chorus2 web interface
  2. Added pvr.octonet (Digital Devices Octopus NET Client) add-on
  3. HW mouse pointer fixes
Build Details:
  1. LibreELEC.tv:
    • packages/linux-drivers/wetekdvb: Update to wetekdvb-20161127 (PR:993, 1 commit, 1 file changed)
  2. XBMC:
    • New default webinterface Chorus2 (PR:10989, 2 commits, 115 files changed)
    • Fix GetFilter SQL for music artists, albums and songs nodes (PR:10974, 1 commit, 3 files changed)
    • Song Info Dialog contributors in control list (PR:10951, 1 commit, 4 files changed)
    • Fix processing of Performer/TMCL/TIPL Tag values (PR:10994, 1 commit, 4 files changed)
    • [Estouchy] Song Info Dialog contributors in control list (PR:11005, 1 commit, 1 file changed)
    • [estuary] sync (PR:11002, 1 commit, 107 files changed)
    • [listprovider] Refresh list when job was not finished (PR:10957, 1 commit, 4 files changed)
    • [DirectoryNodes] override GetChildType() for Episode DirectoryNodes (PR:11007, 1 commit, 2 files changed)
  3. kodi-theme-Estuary:
  4. inputstream.adaptive:
    • fix debian packaging (PR:2, 1 commit, 7 files changed)
    • cleanup (1ac4f839)
  5. pvr.hts:
    • 3.4.10. Adpated to pvr addon api 5.2.1 (3.4.9 was just to ake it compile again). (PR:251, 1 commit, 7 files changed)
  6. newclock5:
    • Commits no longer in build:
  7. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] patch: kodi-binary-addons: pvr.octonet initial package
    • Added: [env] PR:997: xorg-server: add Synaptics driver if using evdev
Quick look at #1128 and like new Chorus2 web interface to Kodi from any browser on network via xxx.xxx.xxx.xxx:8080
Very smart look CoolCool example when viewing an album

Image
Weekly kernel 4.9-rc7 test build #1128x: RPi / RPi2
(2016-11-29, 00:35)Milhouse Wrote: [ -> ]

Mouse and theme changing seems to be working better now - no crashes or corruption. Thanks.
(2016-11-29, 01:15)Milhouse Wrote: [ -> ]Weekly kernel 4.9-rc7 test build #1128x: RPi / RPi2

Thanks you very much. I will test hardware related things and give feedback
(2016-11-28, 13:22)popcornmix Wrote: [ -> ]
(2016-11-28, 10:23)dsenseb Wrote: [ -> ]Same here. after updating to #1124 the issue started. I also had the temp symbol
Went back to #1119 because of the memory crashes and the temps dropped back to about 65 degrees which are still a bit too high for my taste

Are you saying #1123 has high cpu and #1122 does not have high cpu?
The memory crashes on older builds can be avoided with total_mem=1008 (or possibly even 1023).

Nope, came from an older build to #1124
something like #1106

So after updating to #1124 i had both issues, the crashing and high cpu temp
Also have a splash loop on the Pi3. Pi2 is fine. Started with #1127 and it looks like the inputstream add-on is the cause:
https://paste.ubuntu.com/23552337/
@BigNoid you've got a version installed from the repo which isn't compatible. This wasn't a problem while I included the inputstream.mpd add-on in the build with a higher version number but now it's obsolete and no longer included your Kodi has reverted to the locally installed version. Delete it, as inputstream.mpd is no longer supported (it will be removed from the LE repo along with inputstream.smoothstream once we ship the next alpha).