Kodi Community Forum

Full Version: LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
@millhouse
Have you seen this -> https://github.com/RPi-Distro/firmware-n...e5c6fb9bd4 ?
There is an updated firmware for rpi3 wifi, as I didn't see you mentioning it in your excellent changelogs just wanted to let you know.

Code:
[    6.269616] brcmfmac: brcmf_c_preinit_dcmds: Firmware version = wl0: May 27 2016 00:13:38 version 7.45.41.26 (r640327) FWID 01-df77e4a7
There is some weird overlapped text on the bottom of LibreELEC -->About page.
(2016-06-14, 00:16)Milhouse Wrote: [ -> ]
(2016-06-13, 23:57)Little_Kitty Wrote: [ -> ]I updated to 613 and it seems to be fixed i see some options now under system

Good, because I don't know why that happened... Smile

You should be seeing something similar to the following when the System menu item is selected:

Image

Yes i have setup it like that now Smile Thanks
(2016-06-14, 00:51)asavah Wrote: [ -> ]@millhouse
Have you seen this -> https://github.com/RPi-Distro/firmware-n...e5c6fb9bd4 ?
There is an updated firmware for rpi3 wifi, as I didn't see you mentioning it in your excellent changelogs just wanted to let you know.

Code:
[    6.269616] brcmfmac: brcmf_c_preinit_dcmds: Firmware version = wl0: May 27 2016 00:13:38 version 7.45.41.26 (r640327) FWID 01-df77e4a7

It would be nice to know what's changed, as the change log isn't very informative. We'll most likely end up including it upstream in the next day or so, and should be in tonight's build. Thanks for letting me know.
(2016-06-14, 12:03)Milhouse Wrote: [ -> ]It would be nice to know what's changed, as the change log isn't very informative.

Yep, totally agree, but it's a BCM blob, guess we will never know,
I use RPI3 wifi as AP bridged to eth0, I didn't notice improvements nor regressions yet.
(2016-06-14, 12:03)Milhouse Wrote: [ -> ]It would be nice to know what's changed, as the change log isn't very informative. We'll most likely end up including it upstream in the next day or so, and should be in tonight's build. Thanks for letting me know.

The reason Broadcom provided the updated firmware was reported as a fix to lost connections when power saving is enabled.
However as this is just a new build from their tree, there may well be other fixes in there that we haven't specifically reported and they haven't described.

We are still disabling power saving currently (in kernel driver) as the benefits on a Pi3 don't outweigh the risk of other issues
(power saving on linux is problematic across a wide range of wifi devices).
But the new firmware makes enabling it down the line more likely to be successful.
Thanks popckrnmix.
(2016-06-13, 22:06)Milhouse Wrote: [ -> ]@PuGZopf: Post the link in this thread, there's no reason to start a private discussion.


Hello Milhouse,

it was a big step for me to creat a cloud, dropbox, account..so, here is the Link for you:

https://www.dropbox.com/sh/xgu5x0ggqlvsv...5bafa?dl=0
Hello Milhouse and popcornmix.

Just make a update with my Pi3 from #610 to #613 and notice that all my addons in musik/video are not present.
Only some first insalled progamm adons are here (but not all)

Make bevor update a backup over LibreElec/system and addon backup....nothing after rollback.



Go back in .update folder with the #610 build and all addons are back.

This is my second attempt to update without lost of addons in libreelec.

Edit: on Pi2 i don not have a problem with update from #608 to #613 ....will create a new SDcard, tzz


Thank for your efforts to solve this irritating issue
Harald
some alsa problems :-)


just have crackling sound on all my external soundcards. (xone x:2, arcam rdac, native instruments audio4dj (recognized but no sound at all))
if i try to set the usb to mode 1.1 like in openelec (dwc_otg.fiq_split_enable=0 in cmdline.txt) i don't get any sound Sad

raspberry pi 3
liberelec Build #0610
(2016-06-14, 17:57)tilu01 Wrote: [ -> ]some alsa problems :-)


just have crackling sound on all my external soundcards. (xone x:2, arcam rdac, native instruments audio4dj (recognized but no sound at all))
if i try to set the usb to mode 1.1 like in openelec (dwc_otg.fiq_split_enable=0 in cmdline.txt) i don't get any sound Sad

raspberry pi 3
liberelec Build #0610

I don't know if this will help but here goes.

I am using a USB sound device on my Raspberry PI. When I go to Kodi's audio menu to select the audio output device, it offers me three USB devices. One is the SPIF output which I don't use. The remaining two USB sound devices have nearly identical labels. One produces sound with loud crackling and the remaining one works fine.

If you have not done so already, explore every device listed carefully. Triple check that you are plugged into line-out. I wasted about 20 min. on that one.

Bill
(2016-06-14, 14:39)PuGZopf Wrote: [ -> ]
(2016-06-13, 22:06)Milhouse Wrote: [ -> ]@PuGZopf: Post the link in this thread, there's no reason to start a private discussion.


Hello Milhouse,

it was a big step for me to creat a cloud, dropbox, account..so, here is the Link for you:

https://www.dropbox.com/sh/xgu5x0ggqlvsv...5bafa?dl=0

In future you can use http://pastebin.com, it is easier for you and also developers to read logs Wink
@doldi, can you enable debug logging in #0610, upgrade to #0613, and then upload a link to the kodi.log from the first boot of #0613? Also, do you lose any add-ons with #0611 or #0612?
(2016-06-14, 21:26)Milhouse Wrote: [ -> ]@doldi, can you enable debug logging in #0610, upgrade to #0613, and then upload a link to the kodi.log from the first boot of #0613? Also, do you lose any add-ons with #0611 or #0612?

Have created now a fresh SDcard with LE7.0.1, take the restore point from backup #610.
After install #613 all Addons are present now.

I think the new SamsungEvo sdCard are not the best of the market

Sorry

If i get again in trouble with lost of addons - i will upload the kodi.log


thx Harald
(2016-06-14, 22:02)doldi Wrote: [ -> ]I think the new SamsungEvo sdCard are not the best of the market

I use a Samsung EVO - works very well for me.