Kodi Community Forum

Full Version: Intel Apollo Lake
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Which version of Librelec you are using?, Can you publish pictures of you Bios Settings from youre Board?
I can yes. I don't use LibreELEC. Using Ubuntu 17.10 with mesa 17.3.x and kernel 4.15.3 - nothing really special. Should match Milhouse's latest nightly. Don't use the 8.x builds they have a far too old kernel anyways.

I loaded bios defaults, enabled fast boot and use Ubuntu in UEFI mode. Everything else I kept on auto besides enabling USB Wakeup - as I power on with a remote.
Tryied, with the same issues, screen is freezing, OK, i will stop for now and wait till there is a running image availiable.
Hi everyone,

I recently bought a Gigabyte motherboard with integrated J3455 CPU (model GA-J3455N-D3H), and installed Libreelec (latest official 8.2.3). System runs ok with the exception of this:

I have a problem with the use of an internal optical disc (sata blu-ray drive). It makes the system crash every time. Kodi hangs when the disc is recognized. Sometimes, I manage to play the disc (rarely). But the drive cannot be opened after I stop the movie. And Kodi hangs when I try to reboot.

I've tried another internal sata blu-ray drive (full 5.25" drive), and the system hangs even without any disk with this one.

It only works with an external usb blu-ray drive.

I've also tried with different PSUs, in case I had a power problem, but it makes no difference. 

I don't know if it's hardware related (bad motherboard) or software related.

Has anyone any idea what might cause this ?

Thanks for your help.
Hi,

I've done some more test. I've received today another motherboard, an ASRock J3455-ITX. I have the exact same problem: Libreelec/Kodi hangs when it accesses to the internal optical drive. Works fine with USB external drive. So I guess it is software related.

By the way, I can say/confirm that HD Audio passthrough does not work properly on the ASRock J3455-ITX. I manage to get HD passthrough only if I disable autoframerate. On the other side, on the Gigabyte it works fine. Too bad because the ASRock has a far better BIOS than the Gigabyte (no fan control on the later, for instance).

So I think I'm going to the Libreelec forum to sort my problem out, I'll use a workaround for now: I'm planning to connect the Optical drive internally on the USB pins with an adapter.
When i'm right the Gigabyte Board has no HDMI 2.0, so you will have the problmens with the LSPCon on the Asrock J3455-ITX.
I have a lot of trouble with an J4205-ITX, i never had such a bad mainboard from Asrock before.
Under Linux Screen is freezing, under Windows DTS-HD-HRA makes issues, DTS Coded Musik is not played and DSD also not with the latest Intel drivers.
Testet on my IOTVX AVX1 and the HDMI Input of my Oppo UHD-203, on both exactly the same issues.

So my decission is clear to through it out back to the dealer, these LSPCon Chip Construction is worst case bullshit, sorry for that.
As said before, don't generalize. My J4205-ITX is running since > 12 months ... daily, in 99% without any issues.
(2018-02-24, 00:40)KarstenL680 Wrote: [ -> ]When i'm right the Gigabyte Board has no HDMI 2.0, so you will have the problmens with the LSPCon on the Asrock J3455-ITX.
 Indeed I think the difference comes from that.

On the ASRock, Kodi said the monitor was hooked on display port #2, and audio passthrough on HDMI#0, while everything was in fact connected to the same HDMI port.
Many people have the same issues with this board like i have, some solving the problem by using a DVI to HDMI Adapter, but this cannot be the solution for these unusable LSPCon implementation of an HDMI 2.0 port.

https://bbs.archlinux.org/viewtopic.php?id=230985

for example a documented issue like mine.

I have switched back now to my old Asrock H97 Board with an I3-4160T, using an Nvidia GT1030 with the latest development build from libreelec, this is working for me.
Not really: https://bbs.archlinux.org/viewtopic.php?...7#p1763767 <- he had broken memory
He replaced from DDR3-1600 to DDR3-1333 and for the moment it is working, but using slower memory can also not be the solution for this.
I have also tested different memory, same result, memory tested on another board with memtest = 100% OK.

We will see if gemeni Lake will get HDCP and HDR, according to a first Test of an J4105-ITX at heise.de it has not.

So be lucky wenn it is working on your setup.
My memory:

Quote:2 x 4GB (1x 4096MB) Kingston ValueRAM DDR3L-1600 SO-DIMM CL11 Single
The same i have used as it looks like, KVR16LS11/4.
My dealer said i'm not the only one with these problems, some board working, some not.
For the moment i'm using an Asus J3355I-C,yes, not the fastest one, but working without any Problems with Libreelec .
It's perfectly fine for LE and Kodi.
For a friend of mine we are using the MicroATX Board Asus J3455M-E, runs without any problems.
The reason for the Micro ATX Board is his case, On Micro ATX the PCIE Slot is on a different position than on Mini ITX, in his case it makes it easier to implement his TV card over an PCIE Extender.
The J3455 is a bit faster than the J3355 CPU, Quadcore vs Dualcore.

The two Asus Board have no USB Power ON implmentation, but OK, acceptable when the rest is working.

As i heard from a coleque the Gemeni Lake Board J4105-ITX from Asrock has also HDMI Handshake Problems, Asrock has a Signal polisher chip between chipset and HDMI Port, don't know why, but makes trouble.
So i will wait for Gemeni Lake boards from other vendors.