Kodi Community Forum

Full Version: Intel Apollo Lake
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
(2018-06-23, 12:03)blackride Wrote: [ -> ]
(2018-06-22, 21:09)fritsch Wrote: [ -> ]If not yet in LE, try:
Quote:Section "Device"
  Identifier "Device0"
  Driver "intel"
  VendorName "INTEL Corporation"
  Option "DRI" "3"
EndSection

in /storage/.config/xorg.conf 
 I changed parameter DRI to 2. And I set the frequency to 50 Hz. Became better, but not perfect. Ideal only in windows_10/kde_neon.

How to make perfect? 
 It seems you like compositing which is what you think KDE makes kodi faster. If you really like that and don't need swapBuffer synced output but triple buffered magic. Check the "man intel" page howto enable triple buffer and tear free. For everyone relying on fps being driven by display don't enable that. You are the first one that seems to like that. And: KDE uses the very same gpu acceleration kodi uses ... but compositing all the output.
(2018-06-24, 11:01)fritsch Wrote: [ -> ]
(2018-06-23, 12:03)blackride Wrote: [ -> ]
(2018-06-22, 21:09)fritsch Wrote: [ -> ]If not yet in LE, try:

in /storage/.config/xorg.conf 
 I changed parameter DRI to 2. And I set the frequency to 50 Hz. Became better, but not perfect. Ideal only in windows_10/kde_neon.

How to make perfect?  
 It seems you like compositing which is what you think KDE makes kodi faster. If you really like that and don't need swapBuffer synced output but triple buffered magic. Check the "man intel" page howto enable triple buffer and tear free. For everyone relying on fps being driven by display don't enable that. You are the first one that seems to like that. And: KDE uses the very same gpu acceleration kodi uses ... but compositing all the output. 
How does  turn on in LE?
I'm not the only one with this problem. At you too as far as I understood, there is a same motherboard. But how can not notice the friezes of the interface in the LE? It's obvious and it's annoying. In builds Millhouse, the interface is even more twitching. And my monitor and my TV display the friezes in the interface kodi. Many for this reason do not use LE, but use Windows 10. I bought this motherboard for using LE. The problems of the interface are not only in Apollo Lake, but and with Gemini Lake. I know this problem was discussed here like. But the decision was not found.
No single freeze here. I hope you use le9 with a recent kernel. I am on Ubuntu with mess 18.1 and kernel 4.17.2
del
(2018-06-25, 06:13)fritsch Wrote: [ -> ]No single freeze here. I hope you use le9 with a recent kernel. I am on Ubuntu with mess 18.1 and kernel 4.17.2
I tried the assembly of #0624 LE9 with the kernel 4.17.2. And there are the same friezes. I'll try ubuntu gnome, but it's hardly from DE depends.

BUT. I ADDED this is xorg.conf IN LE9 BUILD #0624 Milhouse AND NOW THERE ARE NO FRIEZES  Angel Blush Music
Seems sometimes my posts tend to be useful :-)
(2018-06-25, 12:39)fritsch Wrote: [ -> ]Seems sometimes my posts tend to be useful :-)
 Just occasionally Wink. (Thanks again for your continuing work on this stuff. It's appreciated by a lot of us Smile )
(2018-06-25, 04:28)blackride Wrote: [ -> ]I'm not the only one with this problem.

Pretty sure you are - I'm not aware of any "freezes" in the GUI being reported in the LE9/x86_64 testing thread (which would be the right place to report them).

Please provide corroborating links if there are any.
xrandr --verbose


With DVI to HDMI
https://paste.ubuntu.com/p/BGD2GsGT9x/

With lspcon HDMI 2.0
https://paste.ubuntu.com/p/NzkCvnvSXP/

TV only has "auto" or "16:9", but projector has the same problem, and this has a native mode...just dont know the name any more. The projector has the same error in native and manual 16:9 configuration.
Following Line is missing inside the second log: "aspect ratio: Automatic supported: Automatic, 4:3, 16:9". At least on the beginning. At the end of the log, you can find it.

Interresting (other topic) thing is that
"Broadcast RGB: Automatic supported: Automatic, Full, Limited 16:235 audio: auto supported: force-dvi, off, auto, on link-status: Good"

because full RGB doesnt work on Libreelec, Screen gets dark with fullRGB. Luckily since some weeks I can configure limited in the menu and the screen is not dark anymore, so I can use limited mode.
Only on Win10 I can use full RGB and there you can see how the screen adapts to the setting after changing.
(2018-06-25, 20:01)flyingernst Wrote: [ -> ]xrandr --verbose


With DVI to HDMI
https://paste.ubuntu.com/p/BGD2GsGT9x/

With lspcon HDMI 2.0
https://paste.ubuntu.com/p/NzkCvnvSXP/

TV only has "auto" or "16:9", but projector has the same problem, and this has a native mode...just dont know the name any more. The projector has the same error in native and manual 16:9 configuration.

Interresting (other topic) thing is that
"Broadcast RGB: Automatic supported: Automatic, Full, Limited 16:235 audio: auto supported: force-dvi, off, auto, on link-status: Good"

because full RGB doesnt work on Libreelec, only on Win10 and there you can see how the screen adapts to the setting after changing.
And your kodi.log including debugging please
Really odd:
Quote:20:13:39.405 T:139854797463744    INFO: ID:0x48 Name:1920x1080 Refresh:50.000000 Width:1920 Height:1080
20:13:39.405 T:139854797463744    INFO: Pixel Ratio: 1.000000
20:13:39.405 T:139854797463744    INFO: ID:0x9b Name:1920x1080 Refresh:60.000000 Width:1920 Height:1080
20:13:39.405 T:139854797463744    INFO: Pixel Ratio: 1.000000
20:13:39.405 T:139854797463744    INFO: ID:0x9c Name:1920x1080 Refresh:59.940201 Width:1920 Height:1080
20:13:39.405 T:139854797463744    INFO: Pixel Ratio: 1.000000
20:13:39.406 T:139854797463744    INFO: ID:0x9f Name:1920x1080 Refresh:24.000000 Width:1920 Height:1080
20:13:39.406 T:139854797463744    INFO: Pixel Ratio: 1.000000
20:13:39.406 T:139854797463744    INFO: ID:0xa1 Name:1920x1080 Refresh:23.976080 Width:1920 Height:1080
20:13:39.406 T:139854797463744    INFO: Pixel Ratio: 1.000000
20:13:39.406 T:139854797463744    INFO: ID:0x9d Name:1920x1080i Refresh:30.000000 Width:1920 Height:1080
20:13:39.406 T:139854797463744    INFO: Pixel Ratio: 1.000000
20:13:39.406 T:139854797463744    INFO: ID:0x9e Name:1920x1080i Refresh:25.000000 Width:1920 Height:1080
20:13:39.406 T:139854797463744    INFO: Pixel Ratio: 1.000000
20:13:39.406 T:139854797463744    INFO: ID:0xa0 Name:1920x1080i Refresh:29.970100 Width:1920 Height:1080
20:13:39.406 T:139854797463744    INFO: Pixel Ratio: 1.000000
20:13:39.406 T:139854797463744    INFO: ID:0xa2 Name:1280x720 Refresh:60.000000 Width:1280 Height:720
20:13:39.406 T:139854797463744    INFO: Pixel Ratio: 1.000000
20:13:39.406 T:139854797463744    INFO: ID:0xa3 Name:1280x720 Refresh:50.000000 Width:1280 Height:720
20:13:39.406 T:139854797463744    INFO: Pixel Ratio: 1.000000
20:13:39.406 T:139854797463744    INFO: ID:0xa4 Name:1280x720 Refresh:59.940201 Width:1280 Height:720
20:13:39.406 T:139854797463744    INFO: Pixel Ratio: 1.000000
20:13:39.406 T:139854797463744    INFO: ID:0xa5 Name:720x576 Refresh:50.000000 Width:720 Height:576
20:13:39.406 T:139854797463744    INFO: Pixel Ratio: 1.000000
20:13:39.406 T:139854797463744    INFO: ID:0xa6 Name:720x480 Refresh:60.000000 Width:720 Height:480
20:13:39.406 T:139854797463744    INFO: Pixel Ratio: 1.000000
20:13:39.406 T:139854797463744    INFO: ID:0xa7 Name:720x480 Refresh:59.940060 Width:720 Height:480
20:13:39.406 T:139854797463744    INFO: Pixel Ratio: 1.000000
20:13:39.406 T:139854797463744    INFO: ID:0xa8 Name:640x480 Refresh:60.000000 Width:640 Height:480
20:13:39.406 T:139854797463744    INFO: Pixel Ratio: 1.000000
20:13:39.406 T:139854797463744    INFO: ID:0xa9 Name:640x480 Refresh:59.940479 Width:640 Height:480
20:13:39.406 T:139854797463744    INFO: Pixel Ratio: 1.000000

Even Pixelratio is exactly 1.0 - so whatever happens here is highly unusual as the driver thinks it ouputs quadratic pixels.
Could you pastebin your guisettings.xml? Please check the file for privacy strings before.
yes, I think there is something wrong:
https://pastebin.com/kiNnqgLG
Yes :-)

systemctl stop kodi

now remove all <resolution> .... </resolution> which look fishy.