Kodi Community Forum

Full Version: Intel Apollo Lake
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Sry, installed Win 10 twice on 4205 and One more on 3455 without Problems Installed the drivers from Homepage and After that I used All Windows Updates. Could it be a Problem with this trusted Nonsens in BIOS and OS?!

Gesendet von meinem ONEPLUS A3003 mit Tapatalk
(2016-11-22, 23:55)flyingernst Wrote: [ -> ]Sry, installed Win 10 twice on 4205 and One more on 3455 without Problems Installed the drivers from Homepage and After that I used All Windows Updates. Could it be a Problem with this trusted Nonsens in BIOS and OS?!

Gesendet von meinem ONEPLUS A3003 mit Tapatalk

Thanks, I'll have a go using the drivers from the homepage rather than those on the CD and see if it works.
I achieved operation of DVI-HDMI, 3D framepacking only through an adapter!!!! A problem with 3D through a HDMI because of misoperation of DP-HDMI Bridge
firmware in chip DP-HDMI could be updated Wink so some issue could be rosolved, im read about problem on older NUC with 5.1 sound. intel prepare just DP-HDMI chip firmware update for resolve that.

On linux and APL/KBL still support is WIP (there are few issue with DP port etc.)
DRM debug shows even that chip -> DP branch: OUI 00-60-ad(NS) dev-ID MC2800 HW-rev 2.2 SW-rev 1.56

btw. To support HD Audio on Windows the Intel Management Engine Interface driver must be installed, it's this driver that provides the HDCP DRM necessary for the HD Audio formats to works.
Here more about problems with HD audio on windows: https://communities.intel.com/thread/77858
Thanks for that Information. Well hopefully they also solve the "double Boot to BIOS error" when the Board was disconnected from energy

Gesendet von meinem ONEPLUS A3003 mit Tapatalk
(2016-11-23, 21:15)piotrasd Wrote: [ -> ]btw. To support HD Audio on Windows the Intel Management Engine Interface driver must be installed, it's this driver that provides the HDCP DRM necessary for the HD Audio formats to works.
Here more about problems with HD audio on windows: https://communities.intel.com/thread/77858

hello piotrasd

concerning this point.. in the audio playback device setting in windows 10 dts-hd and so on is listed in the supported format section

I have just installed the intels hd 505 graphic driver after setting up win 10 and applying all updates.

but hd sound pass through is still not working under kodi.

there is an intel hdmi directsound device listed and a wasapi hdmi audio device

first one only lists DD and DTS as pass through option, the wasapi all (including HD's) but despite normal 5.1 DTS nothing is working.

---
I tried to follow your idea with getting Intel Management Engine Interface drivers.. but where and which?

the only download i could find was for intel NUC's..

thanks a lot
i readed UEFI must be enabled in BIOS and secure boot.
That would explain a lot.
hi please owners of apollo lake put command in LE (if you have connected to AVR)
"cat /proc/asound/card0/eld\#2.0" and send me here output - i think i found issue of HD audio passthrough Smile
LE #1123 with passthrough deactivated (you need activated for this test?)
Maramtz SR 7008
Asrock J4205ITX

Code:
monitor_present         1
eld_valid               1
monitor_name            marantz-AVR
connection_type         DisplayPort
eld_version             [0x2] CEA-861D or below
edid_version            [0x3] CEA-861-B, C or D
manufacture_id          0x4935
product_id              0x2d
port_id                 0x0
support_hdcp            0
support_ai              1
audio_sync_delay        0
speakers                [0x5f] FL/FR LFE FC RL/RR RC RLC/RRC
sad_count               7
sad0_coding_type        [0x1] LPCM
sad0_channels           8
sad0_rates              [0x1ee0] 32000 44100 48000 88200 96000 176400 192000
sad0_bits               [0xe0000] 16 20 24
sad1_coding_type        [0x7] DTS
sad1_channels           6
sad1_rates              [0x6c0] 44100 48000 88200 96000
sad1_max_bitrate        1536000
sad2_coding_type        [0x2] AC-3
sad2_channels           6
sad2_rates              [0xe0] 32000 44100 48000
sad2_max_bitrate        640000
sad3_coding_type        [0xb] DTS-HD
sad3_channels           8
sad3_rates              [0x1ec0] 44100 48000 88200 96000 176400 192000
sad4_coding_type        [0xa] E-AC-3/DD+ (Dolby Digital Plus)
sad4_channels           8
sad4_rates              [0xc0] 44100 48000
sad5_coding_type        [0xc] MLP (Dolby TrueHD)
sad5_channels           8
sad5_rates              [0x1ec0] 44100 48000 88200 96000 176400 192000
sad6_coding_type        [0x9] DSD (One Bit Audio)
sad6_channels           6
sad6_rates              [0x40] 44100
ok you had this information what are needed my even if is connected to AVR show me only from TV codec

Code:
monitor_present        1
eld_valid        1
monitor_name        SAMSUNG
connection_type        DisplayPort
eld_version        [0x2] CEA-861D or below
edid_version        [0x3] CEA-861-B, C or D
manufacture_id        0x6b21
product_id        0x666
port_id            0x0
support_hdcp        0
support_ai        1
audio_sync_delay    0
speakers        [0xf] FL/FR LFE FC RL/RR
sad_count        3
sad0_coding_type    [0x1] LPCM
sad0_channels        6
sad0_rates        [0x1ee0] 32000 44100 48000 88200 96000 176400 192000
sad0_bits        [0xe0000] 16 20 24
sad1_coding_type    [0x2] AC-3
sad1_channels        6
sad1_rates        [0xe0] 32000 44100 48000
sad1_max_bitrate    640000
sad2_coding_type    [0x7] DTS
sad2_channels        6
sad2_rates        [0x6e0] 32000 44100 48000 88200 96000
sad2_max_bitrate    1536000

So even if Kodi shows me support for DTS-HD, TrueHD - there are no exposed in EDID
please check my latest build with some fixes for HDMI audio
maybe will works for you https://fs11n4.sendspace.com/dl/c1f7b546...161125.tar

please disable A/V sync in kodi settings
When I deactivate autoframe then my AVR gets always the Same chabnel Information (7.1 192khz) and makes awful noises like it would use the wrong decoder (want Video+log?)?, when I activate autoframe then it is completely silent (same behavior like in all releases before) and no channel information, and when I then activate A/V synch it switches to Multichannel-PCM like it always did.

Edited


What I realy like is that 8bit hevc runs without Color errors. Win 10 sometimes has that, especially on 10bit movies.
colors, yes that was fixed in latest drm-intel
that latest fix of sound https://cgit.freedesktop.org/drm-intel/c...47a2952782
Is there a schedule to make 10bit Hardware decoding working?

Gesendet von meinem ONEPLUS A3003 mit Tapatalk
Hello,
Anybody could recommend a memory that works without problems in the J4205?,
I read some problems of users with certain memories.