Kodi Community Forum

Full Version: Intel Apollo Lake
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
(2016-12-18, 10:44)flyingernst Wrote: [ -> ]Image
Doesnt recognize the actual Firmware in the Board

Thank you for testing flyngernst, the other firmware update from asrock 170 fatality is version 1.48, i think we have the most newer firmware with 1.56.

Anyway maybe isnt a problem of firmware and will solve with kerner drm how say piostrad

Enviado desde mi iPhone utilizando Tapatalk
When I remember the time I wrote my first kernel patch - there I was 14 years old. It was a minor, really minor - but until today if one googles my name and kernel you find that :-) Just if someone searches for something he can be proud of the entire life :-)
nice ! Cool
(2016-12-18, 16:53)fritsch Wrote: [ -> ]When I remember the time I wrote my first kernel patch - there I was 14 years old. It was a minor, really minor - but until today if one googles my name and kernel you find that :-) Just if someone searches for something he can be proud of the entire life :-)

This is what I referred to with my comment earlier regarding something happening in kernel and we having no influence. But, yes, reading the release notes for the first RC1 kernel that had my own patch was a special moment - even if I was at ripe age of 33 at that time. Smile
I've tested the audio out via DVI->HDMI adapter and video direct via HDMI to the TV.
Seems to work fine, i can output DTS-HD passthrough and watch 3860x2160 60p to the TV.
The clip i've tested is thx_eclipse_long_4K_uhd_DTS-HD_MA_51-thedigitaltheater.mkv , i also tested Dolby Digital 4K clips with same good result.

So digital audio passthrough via DVI to the receiver works fine while watching HDMI 4K output to the TV.
Have not tested sync issues as i don't have 4K DTS-HD movie clips. If someone would like me to test special samples please point me and right direction.

Only file that did not play correctly due to software decoding is The World in HDR.mkv 60p (Codec: Google/On2's VP9 Video (VP90))
I was not able to output True HD via the DVI - HDMI Adapter.
(2016-12-19, 21:01)piotrasd Wrote: [ -> ]4k - http://kodi.wiki/view/Samples#4K_.28UltraHD.29
HD audio - http://kodi.wiki/view/Samples#HD_Audio_Test_Clips

Thx, i did download couple of them and tested, all worked fine with audio out via DVI and video out via HDMI.
However there are very few or not any 4K files with HD Audio , 4K files are most PCM 2.0 and some are DD 5.1 while all HD Audio files are 1080.
My receiver VSX 922 supports Dolby® TrueHD/Dolby Pro Logic IIz/Dolby Digital Plus & DTS-HD® Master Audio/DTS-ES/DTS Neo:6.
I tested DD5.1 & DTS-HD in 4K and those worked fine.

Difficult to test sync as the clips the sound in the clips is somewhat disconnected from the video, speech would be better for testing.

Any specific clips you would like me to test?
I am running test, movies now since 2 hours and I am so much in love with that Apollo Lake and what the Devs here made out of it. Even when I am not after man :-) Tarzan in 4k and 7.1 rocks... Especially the last 30 minutes....Even when watching it on fhd beamer. Where the fuck are payable 4K beamer's

Gesendet von meinem ONEPLUS A3003 mit Tapatalk
Just played VC-1_23.976_sample.mkv , my receiver show dolby digital input and output
DVI - HDMI to the receiver , HDMI direct to the TV.
the clip had speach and sync is perfect,
(2016-12-17, 18:58)piotrasd Wrote: [ -> ]here guys updated build with fix for color space range
https://www.sendspace.com/file/vaj05l (cpufreq - performance)
https://www.sendspace.com/file/xvanfm (cpufreq - ondemand)

little guide:
please dont forget create file .nocompat in .update folder (for force update from Generic to Intel )
touch /storage/.update/.nocompat

for download build from ssh over wget, from webstite https://www.sendspace.com/file/vaj05l
copy link from DOWNLOAD blue button then past with wget into ssh (each time refresh site link is generated new, and could be used once)
I had a quick test with the cpufreq performance build. Everything was ok, but the youtube add-on couldn't be started. After i returned to the last LibreElec Kodi 17 Build (#1129) the youtube was working again. I've tried it with youtube add-on 5.3.6 and 5.3.7. Also i couldn't use ssh with the standard root password. Access denied :/

Somebody has the same problems?

Another question. How should i configure limited range? Right now i use limited range on the tv and limited range on kodi. Is this ok?
Piotrasd uses le as password

Gesendet von meinem ONEPLUS A3003 mit Tapatalk
@Dr.Feelgood: big thanks for testing my DVI->AVR & HDMI->TV scenario! I had high hopes it would work, didn't see any reason why it wouldn't, but one never knows. Now I can safely order to board :-)
Confirmed 10-bit HEVC works fine on a NUC6CAYH with the LE build from Piotrasd (devel-20161217173209-r24948-gb7cc543). Same HD audio bitstreaming issues are present.
It's the very same DP -> HDMI bridge. It's a driver bug and kodi can't fix that. If you would have valuable information for the bug piotrasd opened, please add them.