Kodi Community Forum

Full Version: Intel Apollo Lake
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
(2017-03-28, 23:29)dexter98 Wrote: [ -> ]However under all OSes (win10/Linux/LE) I do notice that there is some sort of intermittent USB detach/attach issue with these boards. I have 2 of these boards on completely different hw config and both show this behavior.

My server board runs Ubuntu and that does hard crash when I don't connect any USB keyboard. When it is connected, it runs flawlessly easily 24/7.

Maybe try with USB keyboard attached.

Sent from my HTC One_M8 (typie typie)

I have had no issues with usb on a j3455-itx with or without any keyboard/mouse attached, and currently running arch off a hdd attached to usb port without issue.
(2017-03-30, 21:40)barthand Wrote: [ -> ]Hi Guys,

I have Asrock J3455-ITX and I am using Ubuntu 16.10 with Mesa 17.1 (and all VAAPI and Intel goodies) installed from Padoka PPA.
I'm experiencing issues with my display while running [email protected]60Hz (only! lower frequencies seems to work fine) and I would be very grateful if anyone could tell me if encounters the same.

Problems I'm having start from screen flickering from time to time - screen goes completely black for a second or two, then is okay for next few seconds and then it flickers again. Just to be clear: this happens to me not only while playing video content, but also in Kodi UI and sometimes even in Unity itself. Sometimes this problem starts right after playing the content, sometimes even right away after booting OS, but it happens also this doesn't show up for a longer while.

The problem disappears as soon as I switch to 24Hz - flickering is gone then. Problem is only on 4K resolution at 60Hz only.

After having flickering, often other graphics artifacts or glitches start to appear such as horizontal solid-color lines flying over the screen. In this case, I need to either restart X server (sometimes helps, not always) or reboot the box.

Software used:
Mesa 17.1, libva 1.8.0.pre1, i965 driver 1.8.1.pre1 (freshly updated and aligned with Padoka PPA)
Kernels - tried 4.8.0(-45) line as provided by Ubuntu, 4.9.13, 4.10.0-997 and 4.11.0-994 (Ubuntu's drm-intel-next)

Hardware used: ASRock J3455-ITX with BIOS 1.20, haven't updated HDMI firmware so far (no Windows installed...)

Is anyone experiencing similar problem? Maybe you have any suggestions about possible root cause?
Where do you think I should seek help (mesa-dev mailing lists? Asrock support forums)? I guess it is not impossible also that it's a hardware problem..

In case any logs are required, please just let me know (although I wasn't able to find anything interesting in Xorg.0.log so far).

Many (many!) thanks in advance.

P.S. On Mesa 17.0 and older intel drivers (installed as standard in Ubuntu) I wasn't able to run [email protected] at all, so I can't easily tell if that's Mesa/drivers issue.

Sounds like bog standard hdmi problems to me. 24hz doesn't have the problem because bandwidth is lower.
Try a few different hdmi cables without any switch / receiver between the nuc and display device.
Agreed. Typical symptoms of bad hdmi cable unable to cope with the high bandwidth required for [email protected]

Edit: And it's not about "fatness" of the cable or the brand. I have some very expensive old Monster cable, very thick too and very hard to bend, that can't run [email protected] and I have also another cheaper Monster "shoe lace" cable, that works very well and also another el-cheapo no-name thin cable bundled with something (don't remember what) that works flawlessly in [email protected] Hz.
With the update above HD Audio Problems with Linux / Libreelec are solved ? with Asrock J4205 ?
Once again: No!
(2017-03-30, 19:40)DenisDA Wrote: [ -> ]Intel released HDMI firmware update 1.66 https://downloadcenter.intel.com/downloa...duct=70407
Could update my Asrock J3455-ITX to 1.66.
Hi im compiled LE9 with Kodi Agile and inputstream.adaptive - Netflix addon works with movies in 1080p and sound 5.1 Smile and working fast like it was play from local disk
@piotrasd: HD Audio with 1080p material too? Thanks!
yes full HD i mean 1080p and sound 5.1 (but no HD audio as that stream from internet Wink so they must keep compresed - kodi raported AC3 5.1)

i will post some build if will more stable
(2017-03-30, 19:40)DenisDA Wrote: [ -> ]Intel released HDMI firmware update 1.66 https://downloadcenter.intel.com/downloa...duct=70407
Thank's for the Update.
3D hardware-based still not working. My TV recognizes the 3D signal, but I get a green screen with lines.
I don't have any problems with HD-Audio now, even with 1080p.
Tested under Windows
(2017-04-02, 13:11)piotrasd Wrote: [ -> ]Hi im compiled LE9 with Kodi Agile and inputstream.adaptive - Netflix addon works with movies in 1080p and sound 5.1 Smile and working fast like it was play from local disk

Awesome! Looking forward to an updated build Angel (hint hint)

Thanks in advance!
(2017-04-03, 13:06)reflog Wrote: [ -> ]
(2017-04-02, 13:11)piotrasd Wrote: [ -> ]Hi im compiled LE9 with Kodi Agile and inputstream.adaptive - Netflix addon works with movies in 1080p and sound 5.1 Smile and working fast like it was play from local disk

Awesome! Looking forward to an updated build Angel (hint hint)

Thanks in advance!

Hi ,

Where can i download this LE version ? Or is there a how to fot compile LE9 with Kodi Agile and inputstream.adaptive ?

Thanks
deleted
(2017-04-04, 10:41)jteeuw Wrote: [ -> ]
(2017-04-03, 13:06)reflog Wrote: [ -> ]
(2017-04-02, 13:11)piotrasd Wrote: [ -> ]Hi im compiled LE9 with Kodi Agile and inputstream.adaptive - Netflix addon works with movies in 1080p and sound 5.1 Smile and working fast like it was play from local disk

Awesome! Looking forward to an updated build Angel (hint hint)

Thanks in advance!

Hi ,

Where can i download this LE version ? Or is there a how to fot compile LE9 with Kodi Agile and inputstream.adaptive ?

Thanks

I would be highly interested in a tutorial for compiling LE9 with Kodi Agile.
Thank you in advance
Here build Kodi agile with inputstream.adaptive (default disable - so you must enable manual in addons)
https://www.sendspace.com/file/w6ggc8

Other changes
- Fixed by peak3d issue with crash when you stopped video in Netflix addon
- Mesa 17.0.3, libva vaapi 1.8.0. Ffmpeg 3.3
- kernel 4.11rc5 (drm-nighlty-intel) + patch for all 4k CEA modes

http://nmacleod.com/public/libreelec/getwidevine.sh here script for install libwidevine what need Netflix
(just execute from ssh)

https://github.com/asciidisco/plugin.video.netflix here addon

(in Nextflix addon settings put your email and pass, also in inputstream.adaptive settings change resolution to MAX if you want get 1080p from netflix
and enable Dolby sound)