Kodi Community Forum

Full Version: [REQUEST] BBC iPlayer (Video) Plugin or Script?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Cant believe how cool this looks already!

Just wanted to say thanks for all your hard work to everyone involved! Nod
Geeba Wrote:Cant believe how cool this looks already!

Just wanted to say thanks for all your hard work to everyone involved! Nod

I second that. Script works great and looks great. As for the moral argument, i pay my licence fee, and i'm not going sell, burn or distribute any downloads so my consience is clear. I also find the arguments a bit ambiguous as i have a pvr and a vhs to.

Anyway, very impressed :-)

Cheers
Hi, thanks for the great script. I was wondering if anyone else is getting a loss of audio after playing one of the downloaded .mp4 files. The first file i play is ok but if I cancel that and load another I get no audio, but video playback is fine and a reboot sorts it. I am up to date with XBMC and the scripts, probably my mistake somewhere.

Thanks again for all your work
sounds like you have a media player issue as the script just plays video with that. Mine works fine (dec xbmc build). If you play files by going into file manager and selecting vid what happens? (iplayer downloads directory on e drive from memory).

Cheers
lonegroover Wrote:Are the downloaded items in a standard format that can be played back on XBMC? I'm guessing they'll have some kind of DRM to control playback Sad

Nope no DRM.
plex Wrote:I am trying to access the video streams from hulu.com and they also use RTMP protocol. What's the status of incoporating RTMP into xbmc?

It's been circumvented due to the release of BBC iplayer for the iphone and the different way it was set up.

I hope that work doesn't cease on trying to do this mind you! It would let us actually stream from iplayer (which we currently can't do) and of course there open a HUGE new area for us in terms of online streaming (RTMP is quite popular).

Not to take away from this nice little script - very handy.

Being unable to stream might be a pain for the hard-disk challenged though!
johnsto Wrote:Lee, could you please try the latest version:

http://code.google.com/p/xbmc-iplayer/so...player.zip

Hi,
Sorry, been away for a couple of days Smile

Great! That works now.

Keep up the good work.

Lee.
Here's a quick default.tbn I've put together for this awesome script.

Image

Hope you can incorporate it into the SVN
amended link

Image
Nice logo, but all it did was remind me I forgot to add the default.tbn I'd already made to the ZIP files. D'oh!
I have downloaded the script files and can run the script but nothing happens when I try to navigate to the options to list programmes to download. If I press the A button I get the following

Image

Any ideas where I have gone wrong?

Richard
PS I am running XBMC-SVN_2007-10-28_rev10638-T3CH
richardm, are you sure you installed the script properly? I notice your screenshot shows lots of missing graphics.

If you could also put XBMC into debug mode (hold down X+Y as it boots up so you get a framerate counter in top-left of screen), then run the script to reproduce the error, and then post your xbmc.log to pastebin, that would be really handy.

If you can upgrade XBMC, I'd highly recommend you do so as I'm not sure the BBC's MP4 files are compatible with such an outdated version.
Hi Johnsto
I created a subfolder in scripts called iPlayer and copied the all the files there? Is there anything else I should have done? Should I have created a subfolder called UI and copied the png files there?

I have upgraded to the latest XBMC build now and the script apears to work but I still have the missing graphics
richardm Wrote:Hi Johnsto
I created a subfolder in scripts called iPlayer and copied the all the files there? Is there anything else I should have done? Should I have created a subfolder called UI and copied the png files there?

I have upgraded to the latest XBMC build now and the script apears to work but I still have the missing graphics

This is what you should have:

e:\Dashboard\scripts\iplayer\iplayer.py
e:\Dashboard\scripts\iplayer\default.py
e:\Dashboard\scripts\iplayer\default.tbn
e:\Dashboard\scripts\iplayer\ui\background.png
e:\Dashboard\scripts\iplayer\ui\button_focus.png
e:\Dashboard\scripts\iplayer\ui\button.png
e:\Dashboard\scripts\iplayer\ui\listitem_focus.png

Glad the script works otherwise though!