Kodi Community Forum

Full Version: [REQUEST] BBC iPlayer (Video) Plugin or Script?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Itv catchup plugin is on my downloads page.

Its good to have your licence fee used how you wish rather than be dictated to.
FANTASTIC, works a treat!

one question, can you change the default size on the iplayer alone? in default (set by movie settings) the image is too big for the screen, but changing it changes it in movies too?
johnsto Wrote:There was a RTMP fix in the T3CH build, but not the fix that got iPlayer and numerous other RTMP streams working again. These will no doubt be present in the very next T3CH build (and if they're not then I'll cry.)

Don't say "no doubt", you'll jinx it! Read this again carefully:

frosty Wrote:1) the patch to support 0x16 packets is integrated into linuxport svn r15698. It'll need to be ported to trunk to work for XBOX (many thanks to jmarshall for doing this dull job)

Many thanks indeed to jmarshall, we wouldn't want to take you for granted and just assume that things happen by magic! Big Grin
Just got the Bless build and after a slight alarm after making an elementary cock-up with the update, iPlayer is now working on my XBOX.

I've been monitoring this thread for months waiting for this moment so big thanks and credit must go to johnsto and frosty for making it happen, as well as the XBMC team. Hope you can work your magic on the higher quality and the radio streams, in time.
the merge to the trunk was done a wile ago and JM has all so fix a bug when stopping music play back, sweet Big Grin. so the xbox build should now work with iplayer as of now if you are building your self or wait for the next TC3H
Thanks again chaps. Just thought i`d join the happy mood.
marlboroman1 Wrote:the merge to the trunk was done a wile ago and JM has all so fix a bug when stopping music play back, sweet Big Grin. so the xbox build should now work with iplayer as of now if you are building your self or wait for the next TC3H

Superb!
I was getting "No programs found" for every feed until I commented out "setdefaulttimeout(timeout)" on line 265.

Seems feedparser was failing to parse feeds because of a "winsock error" as referenced here: http://trac.xbmc.org/ticket/4441
sw1tch Wrote:I was getting "No programs found" for every feed until I commented out "setdefaulttimeout(timeout)" on line 265.

Seems feedparser was failing to parse feeds because of a "winsock error" as referenced here: http://trac.xbmc.org/ticket/4441

You can change the timeout value in the Plugin Settings, saving you the need to remove that line!
johnsto Wrote:You can change the timeout value in the Plugin Settings, saving you the need to remove that line!

Changing the timeout value has no effect, as long as the setdefaulttimeout() is there feedparser cannot parse the feed under windows.
Just to say a quick thank you to Johnsto and the guy who did BLESS build. Big Grin

A couple of things I have noticed though:
- On every stream it stops and buffers after 7 or 8 seconds. It then continues to play the whole stream correctly. It doesn't appear to be doing any pre-caching. Or is it doing it in the background?

- If I let a stream play to the end it locks up the Xbox. If I stop it before the end I'm fine.

Cheers.
sw1tch Wrote:Changing the timeout value has no effect, as long as the setdefaulttimeout() is there feedparser cannot parse the feed under windows.

Ok, in the next version I'll ensure that if the plugin setting for timeout is '0', the call to settimeout is not made.
Thanks for your work guys
sw1tch Wrote:I was getting "No programs found" for every feed until I commented out "setdefaulttimeout(timeout)" on line 265.

Seems feedparser was failing to parse feeds because of a "winsock error" as referenced here: http://trac.xbmc.org/ticket/4441

Erk. That ticket's last change was 7 weeks ago, "changed from new to assigned". Doesn't look as it it's going to be worked on or fixed anytime soon? Sad