Kodi Community Forum

Full Version: [REQUEST] BBC iPlayer (Video) Plugin or Script?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I'm running XBMC r19448 (built just this morning), IPlayer 03-06-09b on MacOS 10.5.6 and no matter what show I try on which channel I get something similar to the following:

Code:
14:44:16 T:2963492864 M:252674048   DEBUG: Process - Entering source directory /Users/jonathan/Library/Application Support/XBMC/plugins/video/IPlayer
14:44:18 T:2963492864 M:252145664  NOTICE: SUBTITLES DIR: /Users/jonathan/Library/Application Support/XBMC/userdata/plugin_data/IPlayer/Subtitles
14:44:18 T:2963492864 M:252145664  NOTICE:
14:44:18 T:2963492864 M:252145664  NOTICE: (None, None, 'b00h9xh8', None, None, None, None, None)
14:44:18 T:2963492864 M:252145664  NOTICE:
14:44:18 T:2963492864 M:252362752  NOTICE: <iplayer2.item object at 0x1ba62660>
14:44:18 T:2963492864 M:252346368  NOTICE:
14:44:18 T:2963492864 M:252370944  NOTICE: None
14:44:18 T:2963492864 M:252370944  NOTICE:
14:44:18 T:2963492864 M:252370944  NOTICE:
14:44:18 T:2963492864 M:252370944  NOTICE:
14:44:18 T:2963492864 M:252370944  NOTICE: <iplayer2.item object at 0x1c855d10>
14:44:18 T:2963492864 M:252370944  NOTICE:
14:44:18 T:2963492864 M:252370944  NOTICE: default
14:44:18 T:2963492864 M:252370944  NOTICE:
14:44:18 T:2963492864 M:252370944  NOTICE:
14:44:18 T:2963492864 M:252370944  NOTICE:
14:44:18 T:2963492864 M:252370944  NOTICE: Traceback (most recent call last):
14:44:18 T:2963492864 M:252370944  NOTICE:   File "/Users/jonathan/Library/Application Support/XBMC/plugins/video/IPlayer/default.py", line 780, in ?
14:44:19 T:2963492864 M:252379136  NOTICE:
14:44:19 T:2963492864 M:252379136  NOTICE: watch(pid)
14:44:19 T:2963492864 M:252370944  NOTICE:   File "/Users/jonathan/Library/Application Support/XBMC/plugins/video/IPlayer/default.py", line 669, in watch
14:44:19 T:2963492864 M:252379136  NOTICE:
14:44:19 T:2963492864 M:252379136  NOTICE: d.ok('Error: can\'t locate tv stream')
14:44:19 T:2963492864 M:252379136  NOTICE: TypeError
14:44:19 T:2963492864 M:252379136  NOTICE: :
14:44:19 T:2963492864 M:252379136  NOTICE: function takes at least 2 arguments (1 given)
14:44:19 T:2963492864 M:252379136  NOTICE:
14:44:19 T:2963492864 M:252379136   ERROR: Scriptresult: Error

Can other folks see anything? Thanks.
jonm42 Wrote:I'm running XBMC r19448 (built just this morning), IPlayer 03-06-09b on MacOS 10.5.6 and no matter what show I try on which channel I get something similar to the following:

Code:
14:44:16 T:2963492864 M:252674048   DEBUG: Process - Entering source directory /Users/jonathan/Library/Application Support/XBMC/plugins/video/IPlayer
14:44:18 T:2963492864 M:252145664  NOTICE: SUBTITLES DIR: /Users/jonathan/Library/Application Support/XBMC/userdata/plugin_data/IPlayer/Subtitles
14:44:18 T:2963492864 M:252145664  NOTICE:
14:44:18 T:2963492864 M:252145664  NOTICE: (None, None, 'b00h9xh8', None, None, None, None, None)
14:44:18 T:2963492864 M:252145664  NOTICE:
14:44:18 T:2963492864 M:252362752  NOTICE: <iplayer2.item object at 0x1ba62660>
14:44:18 T:2963492864 M:252346368  NOTICE:
14:44:18 T:2963492864 M:252370944  NOTICE: None
14:44:18 T:2963492864 M:252370944  NOTICE:
14:44:18 T:2963492864 M:252370944  NOTICE:
14:44:18 T:2963492864 M:252370944  NOTICE:
14:44:18 T:2963492864 M:252370944  NOTICE: <iplayer2.item object at 0x1c855d10>
14:44:18 T:2963492864 M:252370944  NOTICE:
14:44:18 T:2963492864 M:252370944  NOTICE: default
14:44:18 T:2963492864 M:252370944  NOTICE:
14:44:18 T:2963492864 M:252370944  NOTICE:
14:44:18 T:2963492864 M:252370944  NOTICE:
14:44:18 T:2963492864 M:252370944  NOTICE: Traceback (most recent call last):
14:44:18 T:2963492864 M:252370944  NOTICE:   File "/Users/jonathan/Library/Application Support/XBMC/plugins/video/IPlayer/default.py", line 780, in ?
14:44:19 T:2963492864 M:252379136  NOTICE:
14:44:19 T:2963492864 M:252379136  NOTICE: watch(pid)
14:44:19 T:2963492864 M:252370944  NOTICE:   File "/Users/jonathan/Library/Application Support/XBMC/plugins/video/IPlayer/default.py", line 669, in watch
14:44:19 T:2963492864 M:252379136  NOTICE:
14:44:19 T:2963492864 M:252379136  NOTICE: d.ok('Error: can\'t locate tv stream')
14:44:19 T:2963492864 M:252379136  NOTICE: TypeError
14:44:19 T:2963492864 M:252379136  NOTICE: :
14:44:19 T:2963492864 M:252379136  NOTICE: function takes at least 2 arguments (1 given)
14:44:19 T:2963492864 M:252379136  NOTICE:
14:44:19 T:2963492864 M:252379136   ERROR: Scriptresult: Error
Can other folks see anything? Thanks.

I'm running SVN19451 on windows and not seeing this. I would suggest trying a new build now or going back to what previously worked, waiting a couple of days, then trying again. Building against the SVN really is bleeding edge and will not always work. If the problem persists then please do flag it up.

Regards
Dink
I had similar problem but updating the plugin to version 2009-03-06 from link in Dink's sig fixed it.
Hi all

Great work by everyone on this plugin, it really is brilliant, has been so useful.

Quick question, when it was first being done as a script, it was possible to download programmes before watching them rather than just streaming them, is there anyway to set it to do this with the new plugin setup?

Reason I ask is, my internet connection is normally 3mb which works fairly well normally but on some occassions (particularly when weather is bad) the speed drops and I end up with programmes constantly buffering. It would be preferable to have it download a programme fully before playing when this is the case.

Was wondering if there was any way it would be possible to add an options menu or something when selecting a programme? Thought maybe something like when you click on the programme it asks if you want to download or stream the programme?

Any help very very much appreciated.

Valve
Valve90210 Wrote:Hi all

Quick question, when it was first being done as a script, it was possible to download programmes before watching them rather than just streaming them, is there anyway to set it to do this with the new plugin setup?

Sorry but this plugin is streaming only. For download functionality you need to use some other software.

Cheers
Dink
Fair enough, just wondered if it were possible. Do you happen to know of any other such software for downloading?

If not I'll continue using this cos it really is great as it is, which is more than can be said for my internet connection at times!!

Valve
I can't seem to play anything from BBC Four on my Xbox currently. This is my first time using the plugin so I'm not sure if this is new behaviour or not. When I select a program (such as Newswipe episode 4, which is what I'm after) the ring in the top right goes round and round and round and eventually (after 3 minutes or so) disappears and the console hangs, or occasionally an error will pop up instead, saying: "Playlist playback aborted \ Too many consecutive failed items". During this time the controls are unresponsive, though the tray still opens and closes and the console may be reset.

Radio items and items from other channels work fine (I tested BBC 1 and BBC 2, though I don't have time to test them all).

The XBMC version I'm running is "SVN_2009-04-04_rev19213-T3CH-9.04-ALPHA1.rar" and the version of XBMC iPlayer plugin is 2009-03-06B.

Any ideas about what might be going wrong? I'm afraid I can't find any logs that might be useful.
jabberwocky Wrote:I can't seem to play anything from BBC Four on my Xbox currently. [snip] Newswipe episode 4, [snip]: "Playlist playback aborted \ Too many consecutive failed items". [snip

Radio items and items from other channels work fine (I tested BBC 1 and BBC 2, though I don't have time to test them all).

The XBMC version I'm running is "SVN_2009-04-04_rev19213-T3CH-9.04-ALPHA1.rar" and the version of XBMC iPlayer plugin is 2009-03-06B.
[snip]

I've had a look using a SVN:19513 windows build and can confirm the problem. It seems that XBMC is having a problem decoding the streams for that series. For now I can't suggest much other than avoid that series. Please do let me know if other problems like this turn up espically if the log ends in errors similar to
Code:
RTMP_LIB::CRTMP::GetNextMediaPacket, received: FLV tag(s) 66540 bytes
ERROR: ffmpeg: [flv] skipping flv packet: type 63, size 8007696, flags 0
ERROR: ffmpeg: [flv] skipping flv packet: type 66, size 3525505, flags 0
Cheers
Dink
Recently installed xbmc on intrepid as per the wiki and generally all seems well except radio streams on iPlayer do not work. I can select then play and the screen progress counter ticks along however there is no sound.

Debug log is at http://pastebin.com/m5d7dc564

For info, .ra files downloaded from the BBC and other sound files (mp3 + flac) all play ok.

I have a .asoundrc plus other seetings as per http://forum.xbmc.org/showthread.php?tid=49115 and I have iPlayer-2009-02-13b installed. TV content works fine (albeit with some buffering).

Not sure if this is an iPlayer or general xbmc problem with my settings, any suggestions as to what I am doing wrong?

paul
I'm afraid there seems to be a problem with recent XBMC builds on Linux and Windows playing these rtsp:// radio steams (xbox is fine as it has mplayer libs doing the decoding). I have opened a ticket but no luck with a fix so far.

Cheers
Dink


pshepherd Wrote:Recently installed xbmc on intrepid as per the wiki and generally all seems well except radio streams on iPlayer do not work. I can select then play and the screen progress counter ticks along however there is no sound.

Debug log is at http://pastebin.com/m5d7dc564

For info, .ra files downloaded from the BBC and other sound files (mp3 + flac) all play ok.

I have a .asoundrc plus other seetings as per http://forum.xbmc.org/showthread.php?tid=49115 and I have iPlayer-2009-02-13b installed. TV content works fine (albeit with some buffering).

Not sure if this is an iPlayer or general xbmc problem with my settings, any suggestions as to what I am doing wrong?

paul
dink Wrote:I'm afraid there seems to be a problem with recent XBMC builds on Linux and Windows playing these rtsp:// radio steams (xbox is fine as it has mplayer libs doing the decoding). I have opened a ticket but no luck with a fix so far.

Cheers
Dink

The radio streams don't work on Macs either for the same reason. I opened a Trac http://xbmc.org/ticket/5864 some time ago about this (mine seems older than yours Big Grin )
Thanks for the response, sounds like the same problem.

I assume that as I can d/l the .ra file (with Mass Downloader) and that plays successfully the problem lies with the rtsp:// streaming side and not the real audio codec.

paul
pshepherd Wrote:Thanks for the response, sounds like the same problem.

I assume that as I can d/l the .ra file (with Mass Downloader) and that plays successfully the problem lies with the rtsp:// streaming side and not the real audio codec.

paul


Yup, dvdplayer doesn't appear to properly support rstp. On Xbox mplayer handles the decoding and on windows as a work around you can use the external launcher to pass the url to mplayer.exe.

Cheers
Dink
Oh wow, I thought this thread had died long ago!

So I don't have to trawl through all these pages, what's the status? Do you have a working iPlayer script for XBMC on XBox?

Make sure you're properly linked off my wiki: http://beebhack.wikia.com/

and add in any techniques you've used if you're doing something new.

We were just discussing on the IRC channel for that wiki (#beebhack on freenode.net) that using a proxy to turn the iPhone video into a straight http stream on the same LAN makes it trivial to stream off XBMC.

Anyway, jump in for a chat on IRC.
Follow the link in dink's sig, the post above yours.