Kodi Community Forum

Full Version: [REQUEST] BBC iPlayer (Video) Plugin or Script?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Ready ....

Steady....

GO...

to http://www.sshcs.com/xbmc/

The 20290 build will play H.264 800 streams on the XBox


Have fun
Dink
And stop.

Damn there's a memory leak in there that causes the XBox to freeze after about 10 minutes or so.



dink Wrote:Ready ....

Steady....

GO...

to http://www.sshcs.com/xbmc/

The 20290 build will play H.264 800 streams on the XBox


Have fun
Dink
I went ahead and installed it anyway, and for the ten minutes it did run I was VERY impressed. The picture (on my 32crt) is a significant step up from the flash stream and really watchable. Its going to get lots of use when the leak gets squashed Big Grin

Thank you to everyone who has contributed to making this a reality.
the video wont sync with the audio for me, it looks like the video is playing to quickly, it might be a cache problem but since they've decided to remove the user options for that I can't check it?! youtube videos play fine.
tomolac Wrote:the video wont sync with the audio for me, it looks like the video is playing to quickly, it might be a cache problem but since they've decided to remove the user options for that I can't check it?! youtube videos play fine.

This sounds like you are playing a H.264 stream on a build that doesn't properly support it or perhaps on a PC that is a little too slow to do the decoding. In either case can you go to the plugin settings and try each of the video stream settings starting with Flash (512). If this doesn't work I will need more info about what version of XBMC you are running and what hardware it is running on. A quick and easy way to provide this is to post the first few lines of your xbmc.log.

Cheers
Dink
dink Wrote:And stop.

Damn there's a memory leak in there that causes the XBox to freeze after about 10 minutes or so.

The memory leak is fixed by http://trac.xbmc.org/ticket/5548#comment:6 which wasn't committed with the rest of that ticket ... could some passing dev with commit priviledges stick that in please.

The leak will be on all platforms, but may go unnoticed on non-xbox as there's a lot more memory to leak away before bad things happen.
@ dink

I cannot get the BBC Iplayer plugin to work! I put the folder in ~/.xbmc/plugins/video/ and then I select the plugin in the video menu, browse to a video I want to watch and select it, then xbmc shuts itself down with the message 'Segmentation Fault' on the terminal.

I am running 64bit Ubuntu jaunty with the latest xbmc from the Jaunty repository, "XBMC 9.04 r19954"

Any clues why this isn't working?
matthewbpt Wrote:@ dink

I cannot get the BBC Iplayer plugin to work! I put the folder in ~/.xbmc/plugins/video/ and then I select the plugin in the video menu, browse to a video I want to watch and select it, then xbmc shuts itself down with the message 'Segmentation Fault' on the terminal.

I am running 64bit Ubuntu jaunty with the latest xbmc from the Jaunty repository, "XBMC 9.04 r19954"

Any clues why this isn't working?

Make sure that you are using Flash 512 as none of the H.264 streams will work properly with that revision (need 20015+)

Cheers
Dink
dink Wrote:Make sure that you are using Flash 512 as none of the H.264 streams will work properly with that revision (need 20015+)

Cheers
Dink

Even with the content set to Flash 512 the segfault still happens =S
matthewbpt Wrote:Even with the content set to Flash 512 the segfault still happens =S

Can you post a log espically the first and last few lines.
dink Wrote:Can you post a log espically the first and last few lines.

It's very long here's the end of it,

Code:
19:10:39 T:1996474704 M:1502613504   DEBUG: xbp_dlopen loading python lib /usr/share/xbmc/system/python/python24.zip/array.so. flags: 2
19:10:39 T:1996474704 M:1502613504   DEBUG: Loading: /home/matthew/.xbmc/temp/array.so
19:10:39 T:1996474704 M:1502613504   DEBUG: RegisterExtensionLib, adding array.so (0x7f437cf41b40)
19:10:39 T:1996474704 M:1502613504   DEBUG: xbp_dlsym - load symbol initarray
19:10:39 T:1996474704 M:1502613504  NOTICE: SUBTITLES DIR: /home/matthew/.xbmc/userdata/plugin_data/IPlayer/Subtitles
19:10:39 T:1996474704 M:1502613504  NOTICE:
19:10:39 T:1996474704 M:1502613504  NOTICE: (<iplayer2.feed object at 0x7f437cecfe70>, 'list', None, None, None, 'Blues Britannia', None, None)
19:10:39 T:1996474704 M:1502613504  NOTICE:
19:10:39 T:2482227264 M:1502552064 WARNING: Cleanup: Having to cleanup texture pointer-nofocus.png
19:10:39 T:2482227264 M:1502552064 WARNING: Cleanup: Having to cleanup texture pointer-focus.png
19:10:39 T:2482227264 M:1502552064 WARNING: Cleanup: Having to cleanup texture pointer-focus-drag.png
19:10:39 T:2482227264 M:1502552064 WARNING: Cleanup: Having to cleanup texture pointer-focus-click.png
19:10:39 T:2482227264 M:1502552064 WARNING: Cleanup: Having to cleanup texture ProgressBack.png
19:10:39 T:2482227264 M:1502552064 WARNING: Cleanup: Having to cleanup texture ProgressFront.png
19:10:39 T:2482227264 M:1502552064 WARNING: Cleanup: Having to cleanup texture ProgressBuffer.png
19:10:39 T:2482227264 M:1502552064 WARNING: Cleanup: Having to cleanup texture seekslider.png
19:10:39 T:2482227264 M:1502552064 WARNING: Cleanup: Having to cleanup texture slider_nibFO.png
19:10:39 T:2482227264 M:1502552064 WARNING: Cleanup: Having to cleanup texture scrollbar_bar_back2.png
19:10:39 T:2482227264 M:1502552064 WARNING: Cleanup: Having to cleanup texture scrollbar_bar-vertical.png
19:10:39 T:2482227264 M:1502552064 WARNING: Cleanup: Having to cleanup texture scrollbar_bar_focus-vertical.png
19:10:39 T:2482227264 M:1502552064 WARNING: Cleanup: Having to cleanup texture scrollbar_nib-vertical.png
19:10:39 T:2482227264 M:1502552064 WARNING: Cleanup: Having to cleanup texture scrollbar_bar_back.png
19:10:39 T:2482227264 M:1502552064 WARNING: Cleanup: Having to cleanup texture scrollbar_bar.png
19:10:39 T:2482227264 M:1502552064 WARNING: Cleanup: Having to cleanup texture scrollbar_bar_focus.png
19:10:39 T:2482227264 M:1502552064 WARNING: Cleanup: Having to cleanup texture scrollbar_nib.png
19:10:39 T:2482227264 M:1502552064 WARNING: Cleanup: Having to cleanup texture Button_Side_Focus.png
19:10:39 T:2482227264 M:1502552064 WARNING: Cleanup: Having to cleanup texture Button_Side_NoFocus.png
19:10:39 T:2482227264 M:1502552064 WARNING: Cleanup: Having to cleanup texture scroll-up.png
19:10:39 T:1996474704 M:1502552064   ERROR: (pthread_mutex_destroy(&m_mutex)): [XCriticalSection.cpp:83] 16
19:10:39 T:2482227264 M:1509863424   DEBUG: GL: Sharing screen surface for thread 2482227264

Here's the full log on pastebin http://pastebin.com/m4d47af0f

-Matt
Doesn't look to be any sort of issue with the plugin. I suspect it's to do with the "64bit" part of your install. On my 32bit Jaunty install it works fine. On the XBMC Linux forum doing a search for "64bit" get quite a few hits. You may have some luck over there.

Cheers
Dink

matthewbpt Wrote:It's very long here's the end of it,

Here's the full log on pastebin http://pastebin.com/m4d47af0f

-Matt
dink Wrote:Doesn't look to be any sort of issue with the plugin. I suspect it's to do with the "64bit" part of your install. On my 32bit Jaunty install it works fine. On the XBMC Linux forum doing a search for "64bit" get quite a few hits. You may have some luck over there.

Cheers
Dink

Hmm yea 64bit does seem to cause trouble sometimes, but I can't be the only 64bit user who's tried to install your plugin, I'm suprised no one else has reported this problem.
dink Wrote:This sounds like you are playing a H.264 stream on a build that doesn't properly support it or perhaps on a PC that is a little too slow to do the decoding. In either case can you go to the plugin settings and try each of the video stream settings starting with Flash (512). If this doesn't work I will need more info about what version of XBMC you are running and what hardware it is running on. A quick and easy way to provide this is to post the first few lines of your xbmc.log.

Cheers
Dink

its the latest build from the ubuntu repositories, its on a 2ghz pc with a 6800 nvidia card, and as I said video is playing too quickly so hardware is not the problem, but yes if I switch it to flash it plays fine its just the quality makes it a bit pointless.
tomolac Wrote:its the latest build from the ubuntu repositories, its on a 2ghz pc with a 6800 nvidia card, and as I said video is playing too quickly so hardware is not the problem, but yes if I switch it to flash it plays fine its just the quality makes it a bit pointless.

The latest from the repositories is less than r20015. That explains the issue. When an upgrade appears > r20015 that will fix the problem.

Cheers
Dink