Kodi Community Forum

Full Version: can´t connect to Webinterface
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello Forum,

first poster and complete Kodi Live Tv noob here, I am trying to get my Usb dvb-T stick (chiligreen DVBE12) to work on openelec running on a Raspberry pi 2.

so, I have enabled the Tvheadend HTSP Client in addons after I had enabled pvr. Next step I guess would be to configure everything via the web server.
This is the point where I am stuck: I can´t connect to the default IP (127.0.0.1:9981) and to me this is somehow weird because my pi´s ip is 192.168.0.27
I have tried to change it to 192.168.0.27:9981, but I couldn´t connect. ( with reboots)
All I get is Connection lost notification, that pops up every 10 seconds...

I know this might seem like a basic question, but google couldn´t help me this timeConfused

thank you very much!
Have you installed/enabled tvheadend itself? All PVR software in Kodi is client/server, and you only mention the Tvh client.

Don't worry about the 127.0.0.1 address, by the way - that's the "loopback" address, which is "talk to this machine (but don't actually go out through the network card and back again". It's commonly used where client software is talking back to server software on the same machine.
Thank you very much for your answer,

I installed the PVR addon through the Openelec repository which is called "Tvheadend HTSP Client" that is the only thing I installed.
I was afraid that the actual backend was missing...
However I don´t know where to install the addon, since the pvr addons are no longer bundled with Openelec by default.
Could you give me a hint?

Thank you for the loopback address explanationSmile
I believe OpenELEC ships Tvheadend, and has their own addon for managing the server. Check in the Program addons for their Tvheadend/HTS server addon.

Tvheadend must be enabled, running and configured before the client does any good.
From my notes...

installed tvheadened service from openelec unofficial repo
installed tvheadend htsp client pvr from openelec official repo
(2016-04-26, 19:00)rpcameron Wrote: [ -> ]I believe OpenELEC ships Tvheadend, and has their own addon for managing the server. Check in the Program addons for their Tvheadend/HTS server addon.

Tvheadend must be enabled, running and configured before the client does any good.

The problem I encountered was that openelec no longer has preinstalled pvr addons, I installed the HTSP Client via the openelec repository, but last week I couldn´t find anything else. e.g a server addon. I will have a second look tonight though!
thank you, I will report my progress on this problem Smile
(2016-04-29, 04:40)greenbag Wrote: [ -> ]From my notes...

installed tvheadened service from openelec unofficial repo
installed tvheadend htsp client pvr from openelec official repo

I will try to find the tvheadend service tonight, thank you for your advice!
Wink
hope it works. Smile