Kodi Community Forum

Full Version: [Linux] Ubuntu 16.04 LTS PVR kodi-pvr-hts frontend does not connect to backend
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
I have just upgraded my computer to Ubuntu 16.04 i386.

My TVHeadend Backend is version v4.1.1931 i386

Kodi is working as it did before the upgrade except for one very annoying problem.

The frontend add-on for the TVHeadend backend refuses to connect now.

I have tried removing and reinstalling kodi-pvr-hts and it still refuses to connect.

The backend is running on the same machine and I have set the IP address in the add-on
to 127.0.0.1 (local loopback interface)

Does anyone know how to fix it?

Please let me know what logs are needed and I will submit a them via a pastebin.

Thank you in advance.

Update:

I have upgraded my TVHeadend Backend to the following version:

HTS Tvheadend 4.1-1942~g4244439

Debug Log File (expires after 1 Month):

http://pastebin.com/fDNC6LNJ
I have the same issue,
Revert backend to 4.0.8 or 4.0.9. 4.1 is buggy.
Im running HTS Tvheadend 4.0.9-4~gac9e47d~trusty on a separate server.

This started when I upgraded to Ubuntu 16.04 on the client.
Here too.

Ubuntu 16.04 + Kodi 16 or 16.1 and the TVH Client 2.18 does not load!

Ubuntu 16.04 + Kodi 15.2 and the TVH Client 2.18 works perfect.
I did not have this problem with Ubuntu Trusty 14.04 and I had TVHeadend Build v4.1.1931.

In Ubuntu Xenial 16.04, my TVHeadend Backend is working fine. It is the Kodi frontend that is playing up.
You're on Ubuntu... try..

Code:
dpkg-reconfigure tvheadend

That should let you renew your user and password. See if that's the issue.
(2016-04-26, 06:31)greenbag Wrote: [ -> ]You're on Ubuntu... try..

Code:
dpkg-reconfigure tvheadend

That should let you renew your user and password. See if that's the issue.

But it is not a Server Problem, it is a Client Problem. HTS PVR Client does not load with Ubuntu 16.04 + Kodi 16
(2016-04-26, 06:31)greenbag Wrote: [ -> ]You're on Ubuntu... try..

Code:
dpkg-reconfigure tvheadend

That should let you renew your user and password. See if that's the issue.

I tried that and it didn't work. I have to record some debug logs.
(2016-04-27, 08:02)Natascha303 Wrote: [ -> ]
(2016-04-26, 06:31)greenbag Wrote: [ -> ]You're on Ubuntu... try..

Code:
dpkg-reconfigure tvheadend

That should let you renew your user and password. See if that's the issue.

But it is not a Server Problem, it is a Client Problem. HTS PVR Client does not load with Ubuntu 16.04 + Kodi 16

Agreed.
(2016-04-27, 08:02)Natascha303 Wrote: [ -> ]
(2016-04-26, 06:31)greenbag Wrote: [ -> ]You're on Ubuntu... try..

Code:
dpkg-reconfigure tvheadend

That should let you renew your user and password. See if that's the issue.

But it is not a Server Problem, it is a Client Problem. HTS PVR Client does not load with Ubuntu 16.04 + Kodi 16

Your original post said that after the upgrade, the front end wouldn't connect to the backend.. or vice versa. It sounded like a config file got messed up. It didn't hurt to try.. did it?
(2016-04-27, 09:37)greenbag Wrote: [ -> ]
(2016-04-27, 08:02)Natascha303 Wrote: [ -> ]
(2016-04-26, 06:31)greenbag Wrote: [ -> ]You're on Ubuntu... try..

Code:
dpkg-reconfigure tvheadend

That should let you renew your user and password. See if that's the issue.

But it is not a Server Problem, it is a Client Problem. HTS PVR Client does not load with Ubuntu 16.04 + Kodi 16

Your original post said that after the upgrade, the front end wouldn't connect to the backend.. or vice versa. It sounded like a config file got messed up. It didn't hurt to try.. did it?

No it didn't hurt.

I tried it, rebooted the computer and it still did not work though.

Thanks for the tip.

I have updated the top of the thread with a debug log. Hopefully something in there will show what the problem is.
Quote:ERROR: ADDON: Could not locate pvr.hts.so

Having seen another thread where this is happening with vnsi, I think it could be a packaging/path issue. See http://forum.kodi.tv/showthread.php?tid=270095 and see if your paths are wrong like the OP in that thread.
Quote:ERROR: ADDON: Could not locate pvr.hts.so

im seeing this too,
I think we just need an update of the kodi-pvr-hts (Client)

It is not a TVH(Server), Kodi16 or Ubuntu16.04 problem.
Pages: 1 2