Kodi Community Forum

Full Version: LiveTV - Stream redirect broken?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Hi there, I am sorry if this is the wrong forum, please move the topic if it is.
I recently decided to try out the latest build of Kodi 17, I know it's still in development, but I've had so many problems with 16 so I thought this can't hurt.

Very happy with how v17 it works, truly great work guys. I am very dependent on the PVR/LiveTV section, this is what I use to watch TV in several rooms and on different devices. So far this has worked very good in Kodi 14, 15 & 16. (TVHeadend & IPTV Simple).

So when testing LiveTV in Kodi 17 (17.05.2016 build), I noticed two things:

The good:
- Pure HLS streams work amazingly FAST! Smile The channels switching is around 2 sec or less. Very happy with this, as earlier versions of Kodi took around 10-20 seconds!

The bad:
- Stream redirect seems broken. I have a local web-server that provides urls to a set of channels. These urls, when called, authenticate and generate tokens for each channel and then return the fully qualified HLS url of the stream. This works just fine in earlier versions of Kodi, but they do not work in Kodi 17.

I have fetched the debug log of the failing stream. Hope someone can shed some light on what can be the issue here. Has there been a lot of changes in how the streams are managed and opened?
http://pastebin.com/6fjedN89

The issue is present both on Windows and Mac. The urls work just fine on the same machine if I use a earlier version of Kodi or just via VLC.
(2016-05-17, 18:22)Maniac Wrote: [ -> ]... when testing LiveTV in Kodi 17 (17.05.2016 build), ...

Where are PVR client add-ons enabled (or installed) for Live TV in KODI 17?

I looked all over and could not find where to enable or install a PVR client add-on (e.g., NextPVR client). There is a "TV Setting" section in "Settings" with every Live TV setting except "Enabled."
on the main menu highlight addons and have the addon browser somewhere in the upper right corner
(2016-05-24, 07:21)Memphiz Wrote: [ -> ]on the main menu highlight addons ...

I solved the lack of a PVR client by installing a different KODI 17 build. Build 20160521 does not seem to include an "Add-ons" item in the main menu, but I found that build 20160502 does include an "Add-ons" in the main menu.
(2016-05-17, 18:22)Maniac Wrote: [ -> ]Hi there, I am sorry if this is the wrong forum, please move the topic if it is.
I recently decided to try out the latest build of Kodi 17, I know it's still in development, but I've had so many problems with 16 so I thought this can't hurt.

Very happy with how v17 it works, truly great work guys. I am very dependent on the PVR/LiveTV section, this is what I use to watch TV in several rooms and on different devices. So far this has worked very good in Kodi 14, 15 & 16. (TVHeadend & IPTV Simple).

So when testing LiveTV in Kodi 17 (17.05.2016 build), I noticed two things:

The good:
- Pure HLS streams work amazingly FAST! Smile The channels switching is around 2 sec or less. Very happy with this, as earlier versions of Kodi took around 10-20 seconds!

The bad:
- Stream redirect seems broken. I have a local web-server that provides urls to a set of channels. These urls, when called, authenticate and generate tokens for each channel and then return the fully qualified HLS url of the stream. This works just fine in earlier versions of Kodi, but they do not work in Kodi 17.

I have fetched the debug log of the failing stream. Hope someone can shed some light on what can be the issue here. Has there been a lot of changes in how the streams are managed and opened?
http://pastebin.com/6fjedN89

The issue is present both on Windows and Mac. The urls work just fine on the same machine if I use a earlier version of Kodi or just via VLC.

Did you try with caching disabled (advanced settings)?
Hmm, did it just now, if you are referring to the new <cache> settings in the advancesettings.xml ?
Still same error as in the logs above.

This is my advancesettings:
Code:
<advancedsettings>
    <cache>
      <buffermode>3</buffermode>
    </cache>
    <pvr>
      <cacheindvdplayer>false</cacheindvdplayer>
    </pvr>
</advancedsettings>

I find it weird that ffmpeg goes back to using the local host instead the one from where it downloaded the first "chunk":
Code:
DEBUG: ffmpeg[1D4C]: [http] request: GET /Stream/chunklist_w1533063924.m3u8?
DEBUG: ffmpeg[1D4C]: [http] User-Agent: Lavf/57.25.100
DEBUG: ffmpeg[1D4C]: [http] Accept: */*
DEBUG: ffmpeg[1D4C]: [http] Connection: close
DEBUG: ffmpeg[1D4C]: [http] Host: homeserver:5000
DEBUG: ffmpeg[1D4C]: [http] Icy-MetaData: 1
DEBUG: ffmpeg[1D4C]: [http]
DEBUG: ffmpeg[1D4C]: [http] header='HTTP/1.1 404 Not Found'
DEBUG: ffmpeg[1D4C]: [http] http_code=404
DEBUG: ffmpeg[1D4C]: [http] HTTP error 404 Not Found
Not sure if any of the PVR authors who implemented this somehow crappy feature of streaming URL will look into this. The Kodi part of this is rather hacky. URL of file items are changed while the cached items still point to the old one. The outcome is unpredictable.
http://forum.kodi.tv/showthread.php?tid=259830
I see, I did create a ticket on this but placed it under wrong category. Would be great if someone could change it to PVR.
http://trac.kodi.tv/ticket/16732

It would also be great if someone could look into it, I would be happy to test. This does work just fine in versions below 17.
I have problem can't play streams anymore why?

see http://pastebin.com/BTMmtgYH for log

edit by da-anda: moved log to pastebin
@M89SE

Stop posting logs segments on this site please.
Use pastebin.com or likewise to LINK logs.
The reason for this is it affects site search results.
Your cooperation is requested.
your kodi version has no support for rtmp compiled in
(2016-06-23, 00:25)OTinley Wrote: [ -> ]@M89SE

Stop posting logs segments on this site please.
Use pastebin.com or likewise to LINK logs.
The reason for this is it affects site search results.
Your cooperation is requested.

Sorry won't happen again.

(2016-06-23, 00:25)Memphiz Wrote: [ -> ]your kodi version has no support for rtmp compiled in

Yes but how come it has worked flawlessly until latest dev build? something must have changed?
something always changes Smile
Kodi will have ffmpeg support for rtmp after July 1st. In addition there is a new inputstream addon that provides rtmp
(2016-06-24, 08:29)FernetMenta Wrote: [ -> ]Kodi will have ffmpeg support for rtmp after July 1st. In addition there is a new inputstream addon that provides rtmp

Is the support for rtmp included in the latest builds? Tried one from yesterday but I get the following error i debug:
Code:
Curl::Debug - TEXT: Protocol "rtmp" not supported or disabled in libcurl
12:37:15 T:9428   DEBUG: Curl::Debug - TEXT: Closing connection -1
12:37:15 T:9428   ERROR: CCurlFile::FillBuffer - Failed: Unsupported protocol(1)
Pages: 1 2