Kodi Community Forum

Full Version: no channel switching possible (vdr 2.2.0 / vnsiserver 1.x.0 / client 1.11.16&17)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

With ref to this http://forum.kodi.tv/showthread.php?tid=273036

I now have some really strange issues.

Here're logs:



The thing is that I'm not able to change channels from within kodi ... . In this (log) case it's somehow locked to 'ZDF HD' . With regard to my former thread (see above) HD channels are in fact working. Same happens with one Android device (no logs provided). I still think this is only one manifestation on what's going on within this setup. Yesterday I remember (thought?) channel switching worked - but only for SD channels ...

With vdr-manager and vdr live I'm able to access all and switch channels from SD to HD to SD ... so the backend is somewhat working.

With old clients (13.2) everything worked like charm. Now, with all clients upgraded to 16.1 I face this strange behavior.

Any suggestions?

vdr-backend reinstall, maybe?

Thanks again
Some more (interesting) things with one intel OE client:

- If backend is tuned to a SD channel (via vdr live or something - not from running KODI) I'm able to switch and tune to all available SD channels within KODI
- If backend is tuned to a HD channel, no switching is possible
- Watching livetv might just stop after [time] and kodi crashes and restarts (a few minutes ago I got a four time reboot loop after that ...)

well, there seems to be something really, really fishy. I'll dig deeper during this weeks

Any suggestions for the time being?
did some reading and maybe I have to

a) check what vdr backend plugins are installed, really needed and possibly interfering with vnsi
b) maybe compile the vnsi-server-plugin by myself

With ref to b) and as mentioned here (https://github.com/FernetMenta/vdr-plugin-vnsiserver):

Does this apply to my setup, too? Like yavdr 0.5 with 'latest' 2.2.0 from yavdr repo

On newer VDR Versions (2.2.0) plugin can be build and installed alone, use:

$ git clone https://github.com/FernetMenta/vdr-plugin-vnsiserver
$ cd vdr-plugin-vnsiserver
$ make
$ sudo make install

If you want to fix install dir you can use this, where the end define the VDR
library folder:

$ sudo make install LIBDIR=/usr/lib/vdr

In case I mess things up big time I'm going to do a yavdr 0.6.x reinstall.
Dear diary ...

well, that didn't help either.

compiled and installed vnsiserver 1.5.0. Still the same issue(s). SD channels and chanel switch works. HD channels are stuck - from within kodi.

logfiles are more or less the same (as in #1) and did not reveal anything new. vdr plugins checked and nothing found that seems to interfere.

I now suspect this is a kodi (OE) issue. I found an old 13.2. xbmc verison (vnsiclient 1.9.8) on my android tablet and it connected well against the current backend. channel switching just works .. SD to SD to HD to SD ... great *sigh*

Any suggestion how to deal with this?
try some v17 version of kodi
well, ok. thx for this recommendation.

Will check LE as this seems to be more aggressive on K17 releases. At least for testing. In case this won't work I'm going back to 13.2 on Sunday (sigh) - which worked (besides some recently broken addons) perfect. Next time I'll check in deep if stable really means stable - no offense meant to you and/or the other kodi devs.

With ref to http://forum.kodi.tv/showthread.php?tid=...pid2339935 and adjusting priority to 0 channel switchen between SD and HD now works. Need to check with other clients and well, see if I'm stable for the time being.
PVR and VDR issues solved on all clients with client priority to '0' .

Now I have to analyze a 16.1 crash and/or freeze during idle issue with one of my clients with nvidia gfx ..