Kodi Community Forum

Full Version: Nvidia shield
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Dear Kodi users,

I'm having issue with the video refresh rate in Kodi running on a nvidia shield.

I set it up as explained in the wiki to change the rate setting on start/stop of the video or always.

Worked perfectly the rate was chaning to 24 Hz and returning to 60 Hz at the end of the video.

But since i installed an onkyo tx-nr646 amplifier in between my TV and the nvidia shield , the refresh rate stopped running. It keeps on being on 60 Hz.

Solution is to set the screen rate directly in the nvidia shield to 24 Hz so it matches the rate of the videos. But it's crappy cause the menu are not smooth anymore and normally kodi should do the job when the setting is set.

Does anyone of you has this issue ? Is it a known issue and a solution is already available ?

Thanks for your replies !
Did you try with advancedsettings.xml?

<fpsmin>29.96</fpsmin> <!-- You can also specify the fps range yourself -->
<refreshmin>59.0</refreshmin> <!-- Same for the refreshrate -->


The problem is, as already mentions in another thread, that the screen gets black shortly while switching from video to the kodi menu. till now no solution on that..
Nop , but just tried thanks.

It seems that it's not reading the file and applying the changes. Do you have an example to force a 24 Hz refresh rate ?
There is some sort of issue with the Shield when you have an HDMI 2.0 AVR and TV that his not HDMI 2.0. This combination seems to break refresh rate switching. Does this sound like your issue - what TV do you have?
Yes this is my issue. It's a Panasonic that I bought like 3 years ago. I can check the exact model.

I'll try different advancedsettings and see if it switches or not.

Anyway one solution is to always set the hdmi port in the shield's configuration to 24 Hz. The menus looks crappy but in kodi everything will be played at this rate.
Changing advanced settings probably won't do much. It is a firmware issue that may be fixed in the next firmware. It seems to still be an issue in the beta upcoming 3.2 issue, but it is still possible it may be fixed in the final version. There is a pretty big discussion on this at the nvidia forums if you want to read more.