Kodi Community Forum

Full Version: Video scaling options missing for certain videos
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I hope someone can help me here, because I just ran into a problem that is driving me crazy.

I have used Kodi for years, and I use Spline36 for my video scaling. I recently (May 26) added two new TV series to my library. I went to watch them today and was surprised to see them upscaling using Nearest Neighbor. Their only other options are: Bilinear and Auto. There's no DXVA, no bicubic, no Spline36, and no Lanczos3. Basically, these two series are not able to access any of the more advanced video scaling methods. I have no idea why.

Older series that have the same basic stats (resolution, frame rate, etc.) still use Spline36 and offer me a large variety of scalers, but these two new series do not. I tried forcing a new default using one of these videos, but that didn't have any effect on the new videos.

I'm running on Windows 8.1. I should probably mention that I have <dxvaallowhqscaling> set to true in my advancedsettings.xml file, but otherwise, my Kodi installation isn't really customized.

The only difference I can really find between the series that don't offer the advanced options and the series that do is that the ones that don't work were added more recently. Was there some kind of change made in the way settings are stored or changed for new files? Any help anyone could give me would be really appreciated.
Wow, I feel stupid for not trying this earlier, but I fixed it. If anyone else has the same problem, try going into your system settings and forcing your render method to DXVA. Mine was on auto, and for unknown reasons, it was apparently avoiding DXVA for the new files.